Bug 2760 - Intel 915 BIOS EDID Failure
Summary: Intel 915 BIOS EDID Failure
Status: RESOLVED DUPLICATE of bug 643
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 6.8.2
Hardware: x86 (IA32) FreeBSD
: high critical
Assignee: Alan Hourihane
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-03-17 19:51 UTC by Remington L
Modified: 2005-03-23 07:56 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Xorg.log File (21.68 KB, text/plain)
2005-03-17 19:52 UTC, Remington L
no flags Details
My xorg.conf file (1.74 KB, text/plain)
2005-03-17 19:53 UTC, Remington L
no flags Details
Xorg.log w/ stock driver (14.07 KB, text/x-log)
2005-03-19 10:24 UTC, Remington L
no flags Details
CORRECTION (21.71 KB, text/x-log)
2005-03-19 17:41 UTC, Remington L
no flags Details
Fatal Problem (57.99 KB, application/octet-stream)
2005-03-22 17:00 UTC, Remington L
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Remington L 2005-03-17 19:51:24 UTC
After the recommendation of 2712 I am still recieving an error, even worse than
the original problem. With both stock i810 driver and the modified driver I recieve:
(II) I810(0): I2C bus "DDC" initialized.
(II) I810(0): VESA VBE DDC supported
(II) I810(0): VESA VBE DDC Level 2
(II) I810(0): VESA VBE DDC transfer in appr. 1 sec.
(II) I810(0): VESA VBE DDC read failed
(WW) I810(0): BIOS EDID failed.

   *** If unresolved symbols were reported above, they might not
   *** be the reason for the server aborting.
Comment 1 Remington L 2005-03-17 19:52:01 UTC
Created attachment 2134 [details]
Xorg.log File
Comment 2 Remington L 2005-03-17 19:53:39 UTC
Created attachment 2135 [details]
My xorg.conf file
Comment 3 Alan Hourihane 2005-03-18 00:58:07 UTC
Please provide a log with the stock driver from 6.8.2.
Comment 4 Remington L 2005-03-19 10:24:55 UTC
Created attachment 2147 [details]
Xorg.log w/ stock driver
Comment 5 Alan Hourihane 2005-03-19 11:12:20 UTC
Try downloading my updated driver from

http://www.fairlite.demon.co.uk/intel.html and try again.
Comment 6 Remington L 2005-03-19 17:41:39 UTC
Created attachment 2157 [details]
CORRECTION

Here it is, with new driver as of 10 minutes ago
Comment 7 Alan Hourihane 2005-03-20 16:00:37 UTC
I've just uploaded a new driver.

Try that.
Comment 8 Alan Hourihane 2005-03-21 13:23:05 UTC
Any news on this ?
Comment 9 Alan Hourihane 2005-03-21 13:47:15 UTC
Fixed in CVS. Closing.
Comment 10 Remington L 2005-03-22 16:57:12 UTC
This patch does not work, need to update status. Driver crashes entire system.
Will attach Xorg.log soon
Comment 11 Remington L 2005-03-22 17:00:14 UTC
Created attachment 2188 [details]
Fatal Problem

Basically reverted to old issue, now appears to be at 1024x768. Crashes system
when attempting to CTRL+ALT+BACKSPACE out of X -xf86config as well as when
getting out of startx. After tonight will no have access to the system for
about a week
Comment 12 Alan Hourihane 2005-03-23 01:15:01 UTC

*** This bug has been marked as a duplicate of 643 ***
Comment 13 Remington L 2005-03-23 19:11:26 UTC
So what is my next course of action here?
Comment 14 Alan Hourihane 2005-03-24 02:56:24 UTC
You could use the external programs mentioned in bug 643 with the stock 6.8.2
driver.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.