Bug 27644 - radeon KMS causes corrupt VGA output on X1400
Summary: radeon KMS causes corrupt VGA output on X1400
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
Depends on:
Reported: 2010-04-14 10:37 UTC by Cameron Gorrie
Modified: 2016-02-26 05:44 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:

avivotool regs all output "UMS" (191.04 KB, text/x-ms-regedit)
2010-04-14 22:49 UTC, Cameron Gorrie
no flags Details
avivotool regs all output "KMS" (191.04 KB, text/x-ms-regedit)
2010-04-14 22:49 UTC, Cameron Gorrie
no flags Details
avitool regs all > ums.regs (191.06 KB, application/octet-stream)
2010-04-15 02:14 UTC, willjcroz
no flags Details
avitool regs all > kms.regs (190.97 KB, application/octet-stream)
2010-04-15 02:15 UTC, willjcroz
no flags Details

Description Cameron Gorrie 2010-04-14 10:37:21 UTC
(note first that this is connected to an Ubuntu bug report; take a look for some potentially-helpful logs: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/562138)

Booting up the latest 10.04 daily live-cd of Ubuntu, the VGA output is unusable. It looks like an incorrect frequency, and the screen size is wrong (it's too narrow for the resolution). The wavering/out-of-phase-ness is so bad that it's impossible to read. This happens on both the X console and X11, and goes away when I use the internal laptop LCD instead (LVDS). If I use both screens in a mirror or extend mode, the same problems occur. So, this led me to believe that the problem might be with Kernel Mode Setting (KMS).

I added the options:
"radeon.modeset=0 vga=771"
to the livecd and, voila, no more corruption. Everything works again, and I can use my big LCD via VGA!

I've attached as much information as I can; I can also show a video of the corruption. I had Ubuntu 8.10 on my computer previously; it's a Dell Inspiron 6400 with Mobility X1400 graphics from ati. I'm using the April 13th Daily LiveCD here, but the corruption was evident at least with the latest Beta livecd.

Let me know if I can give any more information!

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: xorg 1:7.5+5ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-20.30-generic
Uname: Linux 2.6.32-20-generic i686
Architecture: i386
Date: Tue Apr 13 04:48:04 2010
LiveMediaBuild: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100413)
MachineType: Dell Inc. MM061
ProcCmdLine: initrd=/ubninit file=/cdrom/preseed/hostname.seed boot=casper quiet radeon.modeset=0 vga=771 BOOT_IMAGE=/ubnkern
SourcePackage: xorg
Symptom: display
dmi.bios.date: 04/20/2007
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A15
dmi.board.name: 0XD720
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA15:bd04/20/2007:svnDellInc.:pnMM061:pvr:rvnDellInc.:rn0XD720:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: MM061
dmi.sys.vendor: Dell Inc.
 distro: Ubuntu
 codename: lucid
 architecture: i686
 kernel: 2.6.32-20-generic
Comment 1 Alex Deucher 2010-04-14 11:59:07 UTC
does radeon.new_pll=0 also fix the problem?
Comment 2 Cameron Gorrie 2010-04-14 12:26:43 UTC
(In reply to comment #1)
> does radeon.new_pll=0 also fix the problem?

Alex, it does not. I replaced "radeon.modeset=0 vga=771" with "radeon.new_pll=0".

Comment 3 Alex Deucher 2010-04-14 12:32:57 UTC
Please try dumping the registers when using kms and ums using avivotool as
avivotool regs all > ums.regs
avivotool regs all > kms.regs
And attach the dumps here.  Please specify what versions of xf86-video-ati and
kernel you used to make the dumps. avivotool is part of radeontool:
Comment 4 Cameron Gorrie 2010-04-14 22:49:24 UTC
Created attachment 35049 [details]
avivotool regs all output "UMS"
Comment 5 Cameron Gorrie 2010-04-14 22:49:43 UTC
Created attachment 35050 [details]
avivotool regs all output "KMS"
Comment 6 Cameron Gorrie 2010-04-14 22:49:49 UTC
Here you are!

$ uname -a
Linux gibraltar 2.6.32-20-generic #30-Ubuntu SMP Mon Apr 12 15:19:41 UTC 2010 i686 GNU/Linux 

$ dpkg -l xserver-xorg-video-ati
ii  xserver-xorg-video-ati 1:6.13.0-1ubuntu2 X.Org X server -- AMD/ATI display driver wrapper

And attached are the ums/kms files. I had to run avivotool a few times/reboot/re-make in order to get it to output anything, if that matters.
Comment 7 willjcroz 2010-04-15 02:11:27 UTC
Hi, same problem here, on Thinkpad T60 on external VGA output and x86_64 Ubuntu OS (10.04 Beta2).

$ uname -a
Linux t60 2.6.32-20-generic #30-Ubuntu SMP Mon Apr 12 15:20:57 UTC 2010 x86_64 GNU/Linux

$ dpkg -l xserver-xorg-video-ati
ii  xserver-xorg-video-ati  1:6.13.0-1ubuntu2       X.Org X server -- AMD/ATI display driver wrapper

heres my UMS and KMS outputs in case it helps...
Comment 8 willjcroz 2010-04-15 02:14:17 UTC
Created attachment 35053 [details]
avitool regs all > ums.regs
Comment 9 willjcroz 2010-04-15 02:15:00 UTC
Created attachment 35054 [details]
avitool regs all > kms.regs
Comment 10 Cameron Gorrie 2010-05-06 07:06:15 UTC
According to the Ubuntu bug


this is fixed in 2.6.34-rc3. I can say at least that this fix worked for me; I'm now using KMS with my LCD!

Comment 11 Oliver Joos 2011-01-27 11:03:36 UTC
Seems I have the same problem with an ATI X600 (chipset RV380) in my laptop HP Compaq nx8220. Same symptoms and the kernel parameters "radeon.modeset=0 vga=771" also fixed it finally, whereas "radeon.new_pll=0" alone did not help (another dozen of googled suggestions failed too. So many thanks for this hint!)

My graphics adapter:
01:00.0 VGA compatible controller: ATI Technologies Inc M24 1P [Radeon Mobility X600]

I use Ubuntu Lucid with kernel 2.6.35-23 and disabled KMS ever since, because with KMS overlay video playback is not possible anymore and textured video playback shows artifact (looks like a diagonal edge of an OpenGL triangle not drawn correctly synchronized with vsync. But thats another bug...).

If I can help with further data or tests, then please just ask.
Comment 12 Christopher M. Penalver 2016-02-26 05:44:49 UTC
Fix released downstream.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.