Bug 27660 - DPI settings are detected by driver and then ignored
Summary: DPI settings are detected by driver and then ignored
Status: RESOLVED DUPLICATE of bug 23705
Alias: None
Product: xorg
Classification: Unclassified
Component: Lib/Xfont (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-15 03:51 UTC by Antti Mäkelä
Modified: 2010-04-15 08:25 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Antti Mäkelä 2010-04-15 03:51:33 UTC
After I upgraded xorg-server to 1.7.6 (latest Gentoo stable), I experienced that my displays resolution was always set to 96x96 instead of real 130x130 (and my fonts ended up being really small). My previous version, 1.6.5 worked just fine.

I have tried this with intel-driver 2.9 and 2.11, 2.9 with and without KMS. 2.9 without KMS worked fine with xorg 1.6.5.

Xdpyinfo | grep resolution says

resolution:96x96

However, xrandr says

Screen 0: minimum 320 x 200, current 1680 x 1050, maximum 4096 x 4096
VGA1 disconnected (normal left inverted right x axis y axis)
LVDS1 connected 1680x1050+0+0 (normal left inverted right x axis y axis) 331mm x 207mm
   1680x1050      60.1*+   50.1
   1400x1050      60.0
   1280x1024      60.0
   1280x960       60.0
   1024x768       60.0
   800x600        60.3     56.2
   640x480        59.9
TV1 disconnected (normal left inverted right x axis y axis)

..so it's as if the driver detects LVDS properties correctly but they are not set for the *screen*. 

I tried without xorg.conf and a xorg.conf where Monitor section has DisplaySize defined - no effect. 

Right now I'm using xrandr --dpi 130 in my .xinitrc as a workaround and it works properly (xdpyinfo lists correct resolution and fonts are ok).
Comment 1 Julien Cristau 2010-04-15 08:25:35 UTC
Nothing to do with libXfont...

*** This bug has been marked as a duplicate of bug 23705 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.