Bug 2782 - i810 / i915 driver TV-Out only outputting in NTSC
Summary: i810 / i915 driver TV-Out only outputting in NTSC
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: git
Hardware: x86 (IA32) Linux (All)
: medium enhancement
Assignee: Eric Anholt
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
: 9146 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-03-21 10:57 UTC by Pedro Ramalhais
Modified: 2007-08-27 09:48 UTC (History)
8 users (show)

See Also:
i915 platform:
i915 features:


Attachments
*WRONG FILE* (66.85 KB, text/plain)
2007-03-09 17:38 UTC, Hein-Pieter van Braam
no flags Details
*WRONG FILE* (4.24 KB, application/octet-stream)
2007-03-09 17:38 UTC, Hein-Pieter van Braam
no flags Details
xorg.conf of the modesetting (5.68 KB, text/plain)
2007-03-09 17:45 UTC, Hein-Pieter van Braam
no flags Details
Logfile of modesetting branch (23.29 KB, text/plain)
2007-03-09 17:45 UTC, Hein-Pieter van Braam
no flags Details
xorg.conf of the modesetting branch (proper this time) (3.77 KB, text/plain)
2007-03-10 05:57 UTC, Hein-Pieter van Braam
no flags Details
Logfile of modesetting branch (proper this time) (158.88 KB, text/plain)
2007-03-10 05:58 UTC, Hein-Pieter van Braam
no flags Details
xrandr output for modesetting branch (1.21 KB, text/plain)
2007-03-10 05:58 UTC, Hein-Pieter van Braam
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro Ramalhais 2005-03-21 10:57:13 UTC
I have a Centrino Laptop with an i855 graphics. Using Xorg + drm + mesa from CVS
compiled today.
I don't know of any way to change the output of the TV encoder to send PAL
signals instead of NTSC (i only see Black&White). The only way i could do this
was with the nvtv tool from sourceforge.net/projects/nv-tv-out and some
experimentation i had done in the past trying to make tv-out work with that tool.
The resolution for TV-Out is always 800x600, is there a way to change it to
1024x768?
There's also no way of specifying the overscan/underscan modes of the tv encoder.
Is this something that should be done in userspace instead of the i915 driver?

Thanks!
Comment 1 Alan Hourihane 2005-03-21 11:05:02 UTC
Changing to enhancement request.

Basically the driver only supports the TV format to what has been set by the
Video BIOS. There is no support for underscan/overscan either.
Comment 2 Pedro Ramalhais 2005-03-21 11:23:37 UTC
Where does the driver get the resolution for the TV output (800x600 in my case)?

I also have a problem with setting up dual-head with the LFP and the TV out. The
MAN page is not very clear about the way dual-head works. I tried:
Option          "MonitorLayout"         "TV,LFP"
and also the reverse "LFP,TV", but without enabling Clone i can't get any signal
on the TV. Do i need another Section "Device" besides the normal one? I tried
that and adding another Section "Screen" for it and then adding in Section
"ServerLayout":
Screen 1        "TV" RightOf "LCD"
But still nothing. Is there a document that explains it better than the MAN page?

Thanks!
Comment 3 Alan Hourihane 2005-03-21 11:29:01 UTC
If you want clone then you can do this..

Option "MonitorLayout" "NONE,LFP+TV"

or if you want independent content on each head then,

Option "MonitorLayout" "TV,LFP" 

is the right way to do it with a new Device section, and modify the ServerLayout.
Comment 4 Dan Ballard 2005-09-05 12:31:29 UTC
I havea i915 graphics card in my toshiba m40x laptop and it also is only putting
out black and white tv out.  I was uable to get nvtv to recognize my card, even
after I found a i855 patch (no surprise it didn't work for my i915).  Is there
any information I can gather that would mhelp in any way. I'd love to get this
working and would be happy to help in any way I can to further it along.
Comment 5 Krzysztof Kozlowski 2006-09-26 12:57:36 UTC
Is planned adding PAL support to i810/i915 driver?

In Europe NTSC is not used... (see http://en.wikipedia.org/wiki/Image:NTSC-PAL-
SECAM.png :) ), so S-Video-out in Centrino notebooks is useless...
Comment 6 Alan Hourihane 2006-09-27 01:25:10 UTC
If anything, this would have to be done in the new modesetting branch as the
BIOS is incapable of doing it.
Comment 7 Alan Hourihane 2006-11-24 04:41:45 UTC
*** Bug 9146 has been marked as a duplicate of this bug. ***
Comment 8 philippe 2006-12-01 06:30:27 UTC
About the missing overscan mode : is it a hardware or a software issue ?

Is there a chance that one day the board will be able to play videos on TV with
overscan activated ?
Comment 9 Eric Anholt 2006-12-01 13:50:32 UTC
Just software.  Your DVO chip almost surely provides control for overscan. 
It'll be a matter of figuring out what chip you have (probably chrontel, so you
might look through their public docs to figure out how to probe each one, if you
don't want to pull your laptop apart to find out), then writing a loadable
driver for it that supports your TV out on the modesetting branch.  It'll be
more complicated than the DVI DVO modules we have currently, certainly, but
should still be doable by someone in their spare time.
Comment 10 Daniel Stone 2007-02-27 01:25:52 UTC
Sorry about the phenomenal bug spam, guys.  Adding xorg-team@ to the QA contact so bugs don't get lost in future.
Comment 11 Hein-Pieter van Braam 2007-03-01 14:41:08 UTC
I've just purchased a 945GM based system, an aopen MP945-VXR, and I have got the same problem. Just black and white because of the NTSC/PAL problem. 
Comment 12 Gordon Jin 2007-03-01 23:56:43 UTC
Nanhai added more TV modes support into modesetting branch about 2 months ago. 
So if you use recent modesetting code, you should be able to get a colorful PAL TV-out.
Comment 13 Hein-Pieter van Braam 2007-03-09 17:38:31 UTC
Created attachment 9060 [details]
*WRONG FILE*
Comment 14 Hein-Pieter van Braam 2007-03-09 17:38:52 UTC
Created attachment 9061 [details]
*WRONG FILE*
Comment 15 Hein-Pieter van Braam 2007-03-09 17:40:51 UTC
With the latest git modesetting code I get the following error when I am trying to use it with my machine's tv-out pipe:

Xorg: symbol lookup error: /opt/xorg-git/lib/xorg/modules/drivers//i810_drv.so: undefined symbol: i830PipeFindClosestMode

I have tried building just the needed parts of the X server and driver and rebuilding the entire git tree, and both give the same result.

Connecting a monitor to the DVI/VGA port does work as expected.
Comment 16 Hein-Pieter van Braam 2007-03-09 17:45:22 UTC
Created attachment 9062 [details]
xorg.conf of the modesetting
Comment 17 Hein-Pieter van Braam 2007-03-09 17:45:51 UTC
Created attachment 9063 [details]
Logfile of modesetting branch
Comment 18 Hein-Pieter van Braam 2007-03-10 05:54:39 UTC
I am terribly sorry about this, but I got it all wrong. Some stuff failed to compile and I was using some sort of bastardised cross between the modesetting and non-modesetting branch... quite amazing that it even worked.

Now that I AM using the right drivers, I am getting output on the tv-connected pipe, and the xorg logfile shows that it also found that it is using the s-video output. However, the output is still black and white, no matter what I do.
xrandr output shows a whole bunch of modes such as "PAL-M 640x480" but when I try to switch to one of these modes my screen dissapears, then reappears in the exact same resolution, and still black and white.

Attached you'll find the (proper) xorg.conf, Xorg.0.log and output of xrandr
Comment 19 Hein-Pieter van Braam 2007-03-10 05:57:44 UTC
Created attachment 9073 [details]
xorg.conf of the modesetting branch (proper this time)
Comment 20 Hein-Pieter van Braam 2007-03-10 05:58:09 UTC
Created attachment 9074 [details]
Logfile of modesetting branch (proper this time)
Comment 21 Hein-Pieter van Braam 2007-03-10 05:58:36 UTC
Created attachment 9075 [details]
xrandr output for modesetting branch
Comment 22 Gordon Jin 2007-03-14 19:24:10 UTC
The bug priority was upgraded (P2->high) with the bugzilla configuration change.
I'm Changing the priority back to the normal one.
Sorry for the spam.
Comment 23 Gordon Jin 2007-08-07 02:00:41 UTC
I'm closing as the supporting for PAL and more modes has been added to the driver.
If anyone has TV issue with the latest driver, please open a seperate bug.
Comment 24 marco bernardi 2007-08-24 07:08:44 UTC
(In reply to comment #23)
> I'm closing as the supporting for PAL and more modes has been added to the
> driver.
> If anyone has TV issue with the latest driver, please open a seperate bug.
> 

Fine !
but where is the new driver ? I downloaded the latest one but date is still july second....

Thank's
Marco
Comment 25 Gordon Jin 2007-08-25 18:59:09 UTC
The fix goes into 2.0 rlease. So if "july second" indicates 2007, then it should be fine.
Comment 26 marco bernardi 2007-08-27 09:48:14 UTC
(In reply to comment #25)
> The fix goes into 2.0 rlease. So if "july second" indicates 2007, then it
> should be fine.
> 

it do not seems to me ... but using i810 2.1 I can see colors...


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.