Bug 28000 - [Mobile GM965/GL96][Wine][3D] Display and textures corrupted in Warhammer 40k Soulstorm
Summary: [Mobile GM965/GL96][Wine][3D] Display and textures corrupted in Warhammer 40k...
Status: RESOLVED INVALID
Alias: None
Product: DRI
Classification: Unclassified
Component: General (show other bugs)
Version: XOrg git
Hardware: x86 (IA32) Linux (All)
: medium critical
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-06 11:33 UTC by fdelente
Modified: 2019-10-14 13:20 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg.0.log (50.48 KB, application/octet-stream)
2010-05-06 11:33 UTC, fdelente
no flags Details
dmesg (30.39 KB, application/octet-stream)
2010-05-06 11:34 UTC, fdelente
no flags Details
xrandr --verbose (2.13 KB, application/octet-stream)
2010-05-06 11:34 UTC, fdelente
no flags Details
Wine output with LIBGL and MESA debug mode (172.93 KB, application/octet-stream)
2010-05-06 11:36 UTC, fdelente
no flags Details
Corruption of bitmaps (704.56 KB, image/png)
2010-05-06 11:37 UTC, fdelente
no flags Details
Textures corruption (500.71 KB, image/png)
2010-05-06 11:38 UTC, fdelente
no flags Details
Polygons stretched / models of characters distorted (not the buildings?) (664.29 KB, image/png)
2010-05-07 09:37 UTC, fdelente
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description fdelente 2010-05-06 11:33:39 UTC
Created attachment 35465 [details]
Xorg.0.log

$ lspci
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)
$ uname -m
i686
$ uname -a
Linux slick 2.6.32.3-smp #7 SMP PREEMPT Tue Apr 6 19:10:03 CEST 2010 i686 Intel(R) Core(TM)2 Duo CPU     T5750  @ 2.00GHz GenuineIntel GNU/Linux
-- xf86-video-intel/xserver/mesa/libdrm version:
xf86-video-intel-2.11.0-i386-1
xorg-server-1.8.0-i386-1
Mesa-7.8.1-i386-1 
libdrm-2.4.20-i386-1
-- kernel version: ("uname -r")
2.6.32.3-smp
-- Linux distribution:
Slackware 13.0 initially, but I recompiled many packages from source
-- Machine or mobo model:
Packard Bell BG46 fr
-- Display connector: (e.g. VGA, DVI, HDMI, S-video, ...)
VGA? LCD panel
3) Reproduce steps. Probability if not 100% reproducible.
100% reproducible: when starting Soulstorm, some bitmaps and 3D textures are corrupted. The same game works flawlessly on another computer with an Nvidia card.
4) Attachment:
-- Xorg.0.log
-- dmesg output (better with boot option "drm.debug=0x06")
-- xorg.conf (if you changed any default options)
No change there
-- screenshot or photo (optional, a picture is worth a thousand words)
-- output of "xrandr --verbose" for display mode issue
-- intel_reg_dumper output (see the guide) for display issue.
-- for GPU hang, get the last batch buffer (see the guide).
Comment 1 fdelente 2010-05-06 11:34:11 UTC
Created attachment 35466 [details]
dmesg
Comment 2 fdelente 2010-05-06 11:34:56 UTC
Created attachment 35467 [details]
xrandr --verbose
Comment 3 fdelente 2010-05-06 11:36:09 UTC
Created attachment 35468 [details]
Wine output with LIBGL and MESA debug mode
Comment 4 fdelente 2010-05-06 11:37:12 UTC
Created attachment 35469 [details]
Corruption of bitmaps
Comment 5 fdelente 2010-05-06 11:38:25 UTC
Created attachment 35470 [details]
Textures corruption
Comment 6 Sven Arvidsson 2010-05-06 14:13:31 UTC
Having played both the original game and the Winter Assault expansion without problems using the i965 driver, I gave the demo of Soulstorm a try. It works fine here, but if I disable S3TC support, I get the same corruption as your screenshots.

Could you try either:

- Installing the libtxc_dxtn library (should be available somewhere for your distro, otherwise get it here: http://homepage.hispeed.ch/rscheidegger/dri_experimental/s3tc_index.html )

- Setting "Enable S3TC texture compression" to "Yes" in driconf. (or just force_s3tc_enable=true )
Comment 7 fdelente 2010-05-07 06:28:14 UTC
(In reply to comment #6)
> Could you try either:
> 
> - Installing the libtxc_dxtn library (should be available somewhere for your
> distro, otherwise get it here:
> http://homepage.hispeed.ch/rscheidegger/dri_experimental/s3tc_index.html )

Installing that library has solved the textures and bitmaps corruption problem, thanks! However, the GPU still hangs as mentionned in dmesg.

I tried getting a dump, but I couldn't find intel_reg_dumper in intel-gpu-tools-1.0.2, I only found intel_gpu_dump. However, it doesn't work as a user, and it hangs the machine as root, forcing me to reboot (I tried intel_gpu_dump > gpu_dump as root, and the machine becomes completely unresponsive).

> - Setting "Enable S3TC texture compression" to "Yes" in driconf. (or just
> force_s3tc_enable=true )

I couldn't find driconf, and I don't know where to put force_s3tc_enable=true; however, since installing libtxc_dxtn worked, I guess it isn't mandatory?

Thanks for your help!

-- 
F. Delente
Comment 8 Sven Arvidsson 2010-05-07 07:02:53 UTC
(In reply to comment #7)
> Installing that library has solved the textures and bitmaps corruption problem,
> thanks! However, the GPU still hangs as mentionned in dmesg.
> 
> I tried getting a dump, but I couldn't find intel_reg_dumper in
> intel-gpu-tools-1.0.2, I only found intel_gpu_dump. However, it doesn't work as
> a user, and it hangs the machine as root, forcing me to reboot (I tried
> intel_gpu_dump > gpu_dump as root, and the machine becomes completely
> unresponsive).

The GPU reset function will probably mean that you won't get a meaningful dump with that kernel anyway. The best way is to retry with git master of Mesa, and the latest rc of 2.6.34. 

If the hang is still there, grab a dump with intel_error_decode.

(At least this is what I usually do.)

> I couldn't find driconf, and I don't know where to put force_s3tc_enable=true;
> however, since installing libtxc_dxtn worked, I guess it isn't mandatory?

No, shouldn't be necessary if the lib is used.
Comment 9 fdelente 2010-05-07 09:36:34 UTC
(In reply to comment #8)
Thanks for your suggestions, installing the latest git of Mesa and/or 2.6.34-rc6 solved the GPU hang problem.

Now the game plays, but some models are distorted: the polygons extend out of the characters(?).

Furthermore, about 1 pixel is chopped of the letters (see screenshot).

Thanks again anyway!

-- 
F. Delente
Comment 10 fdelente 2010-05-07 09:37:29 UTC
Created attachment 35500 [details]
Polygons stretched / models of characters distorted (not the buildings?)
Comment 11 Sven Arvidsson 2010-05-07 11:24:09 UTC
(In reply to comment #9)
> Now the game plays, but some models are distorted: the polygons extend out of
> the characters(?).
> 
> Furthermore, about 1 pixel is chopped of the letters (see screenshot).

These I can't reproduce, sorry.

I guess either the demo isn't enough to reproduce this, or it's a problem specific to your hardware (I use a X4500HD).
Comment 12 Martin Peres 2019-10-14 13:20:14 UTC
Hi,

Freedesktop's Bugzilla instance is EOLed and open bugs are about to be migrated to http://gitlab.freedesktop.org.

To avoid migrating out of date bugs, I am now closing all the bugs that did not see any activity in the past year. If the issue is still happening, please create a new bug in the relevant project at https://gitlab.freedesktop.org/drm (use misc by default).

Sorry about the noise!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.