Bug 28102 - PackageKit doesn't inform about broken depencies installation
Summary: PackageKit doesn't inform about broken depencies installation
Status: RESOLVED INVALID
Alias: None
Product: PackageKit
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: medium minor
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-14 01:49 UTC by Markku Korkeala
Modified: 2012-01-05 11:01 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Yum output about the broken packages situation (3.48 KB, text/plain)
2010-05-14 01:49 UTC, Markku Korkeala
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Markku Korkeala 2010-05-14 01:49:17 UTC
Created attachment 35647 [details]
Yum output about the broken packages situation

PackageKit doesn't inform about broken depencies when installing packges but fails silently. In the Gnome user interface, status goes:
Starting
Running
Resolving depencies

And the returns to state picking packages. I would expect information failed installation because of broken depencies in packages.

My system is up to date Fedora 13. I tried to install xguest, contacts and dates applications, I attached yum output of the installation I tried after PackageKit failed.

Version of PackageKit
Name       : PackageKit
Arch       : i686
Version    : 0.6.4
Comment 1 Jean-François Fortin Tam 2012-01-05 11:01:18 UTC
Hi there,
This bug report is very old and based on a version not supported anymore. By upgrading to a newer version of PackageKit you could receive bug fixes and new functionality. You may need to upgrade your Linux distribution to obtain a newer version of PackageKit.
Please feel free to reopen this bug if the problem still occurs with the latest version.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.