Bug 28231 - Distortion in image scaling
Summary: Distortion in image scaling
Status: RESOLVED MOVED
Alias: None
Product: poppler
Classification: Unclassified
Component: cairo backend (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: poppler-bugs
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-24 06:33 UTC by Hadmut Danisch
Modified: 2018-08-20 22:00 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hadmut Danisch 2010-05-24 06:33:36 UTC
Hi,

I found that evince is producing distorted pictures, slight problems when displaying an image. 

The authors of evince were able to reproduce the problem and asked me to file the bug against poppler/cairo. 

The description:

I am preparing pictures for a given screen size to fit in exactly
without rescaling, e.g. to fit into a 1024x768 screen. I therefore
generate a PDF document with the same aspect and paste pictures into to
fully expand to either width or height (depending on aspect).

While in principle evince does what I expect, you'll find little
distortions when comparing the picture with what evince displays


E.g. compare the details at the car or the cables in to top right
corner at

http://www.danisch.de/tmp/evincetest.pdf
http://www.danisch.de/tmp/evincetest.jpg

you'll find a visible loss of image quality both on larger screens
where both need to be rescaled as on screen with the exact height
of 768 pixels.

Screendump with distortions (look at the cables or the car):

http://www.danisch.de/tmp/Screenshot.png
Comment 1 Carlos Garcia Campos 2010-07-13 01:55:21 UTC
I've tested it again and it works, you can try with the images demo in poppler-glib-demo program. I think the problem is that in evince 100% zoom usually requires rescaling, because screen dpi is taken into account. With the images demo you can see how the image is rendered at 1x without rescaling.
Comment 2 GitLab Migration User 2018-08-20 22:00:32 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/poppler/poppler/issues/154.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.