Bug 28295 - xv video output is distorted
Summary: xv video output is distorted
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Carl Worth
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
: 28141 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-05-28 00:51 UTC by ccc1
Modified: 2010-06-24 02:42 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
video that trigger the bug (161.72 KB, video/x-msvideo)
2010-05-28 00:52 UTC, ccc1
no flags Details
disorted video screen (71.17 KB, image/png)
2010-06-07 11:49 UTC, alium
no flags Details

Description ccc1 2010-05-28 00:51:46 UTC
See summary. 

xorg-server: 1.8.1
xf86-video-intel: 2.11.0
hardware: Intel GMA X4500HD


it doesn't happen with every video and attached sample video plays fine with mplayer -vo gl test.avi. seems to be a regression, since the videos used to play fine.
Comment 1 ccc1 2010-05-28 00:52:56 UTC
Created attachment 35901 [details]
video that trigger the bug
Comment 2 alium 2010-06-04 23:27:35 UTC
some of my videos do the same thing, Intel GMA X4500MHD, but not with -vo gl, but -vo xv
Comment 3 alium 2010-06-07 11:49:16 UTC
Created attachment 36114 [details]
disorted video screen
Comment 4 Hanno Böck 2010-06-13 07:26:53 UTC
*** Bug 28141 has been marked as a duplicate of this bug. ***
Comment 5 Hanno Böck 2010-06-13 07:30:08 UTC
I'm seeing the same, this happens on all videos with a width not dividable by
4. The attached video has 450, I saw the same, reported it to mplayer and got
that tip:
http://bugzilla.mplayerhq.hu/show_bug.cgi?id=1712

It can also be triggered with mplayer -vf crop=401:300 or similar on any big
enough video.
Comment 6 Thomas Green 2010-06-21 02:31:21 UTC
git bisect says:

cb06aa32d433f54affe87da2cf964f0308d3c258 is the first bad commit
commit cb06aa32d433f54affe87da2cf964f0308d3c258
Author: Daniel Vetter <daniel.vetter@ffwll.ch>
Date:   Mon Mar 1 22:57:39 2010 +0100

    Xv: fixup XvMC on i915
    
    I've accidentally broken i915 xvmc due to alignment constrains that
    break my assumption that Y-pitch == UV-pitch*2. Fix this up by consistenly
    using dstPitch2 for the Y-pitch. This also unifies the dst pitch
    computation slightly, now that the i915 xvmc special case is gone.
    
    Bugzilla: http://bugs.freedesktop.org/show_bug.cgi?id=25949
    
    Signed-off-by: Daniel Vetter <daniel.vetter@ffwll.ch>
    
    (Minor edit to support compilation without INTEL_XVMC defined by
    Carl Worth <cworth@cworth.org>)

:040000 040000 581e91ddb28f783bf765ea1259d4bcab9488ca75 dd733a90fcc54f47d26e811c416fbb61da888899 M	src

http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/commit/?id=cb06aa32d433f54affe87da2cf964f0308d3c258
Comment 7 Thomas Green 2010-06-21 08:11:49 UTC
Actually, I can't reproduce this in the latest release (2.11.901) so it seems to have been fixed somewhere between 2.11.0 and 2.11.901.
Comment 8 ccc1 2010-06-24 02:42:46 UTC
Fixed in 2.11.901.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.