Bug 2852 - Bug when I enable DRI, xfree86 take 100% CPU
Bug when I enable DRI, xfree86 take 100% CPU
Status: RESOLVED FIXED
Product: DRI
Classification: Unclassified
Component: General
unspecified
x86 (IA32) Linux (All)
: high critical
Assigned To: Default DRI bug account
http://yolagang.servebeer.com/bug
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-29 11:03 UTC by zorxd
Modified: 2005-03-29 00:44 UTC (History)
0 users

See Also:


Attachments
Xfree86 config file (3.88 KB, text/plain)
2005-03-29 11:04 UTC, zorxd
no flags Details
xfree86 log file (35.56 KB, text/plain)
2005-03-29 11:04 UTC, zorxd
no flags Details
extra info (2.73 KB, text/plain)
2005-03-29 11:05 UTC, zorxd
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description zorxd 2005-03-29 11:03:39 UTC
Hi
My laptop freeze when I enable DRI in my XF86Config-4
I am using Debian sarge and Xfree86 4.3. If it can helps, my laptop is a compaq
evo N160 with a blazing fast mobility radeon M6 8Mb DDR.
What I tried :
-Kernel 2.6.8 to 2.6.11
-testing and unstable debian packages xserver-xfree86
-a lower resolution
-I also tried the dri-trunk unofficial debian package to get drivers from Xorg

The problem :
My computer boot and get to the KDM login screen. From there I can either start
KDE or hit ctrl+alt+f1 to open a terminal. When I launch KDE, it freezes a few
seconds later. When I open a terminal, it works, but if I go back to KDM, it
also freezes.

The freeze
It is not a constant thing. Most of the time I can move the mouse and connect by
ssh, but that's all. I can't click on anything and the keyboard doesn't work.
The image can be corrupted. What I know is that Xfree86 process takes 99% of my
CPU at this time, and it is impossible to kill (even with -9). The reboot
command doesn't work. I know the problem comes from DRI because if I comment it
in my XF86Config-4, everything works.

my config files are at http://yolagang.servebeer.com/bug
Comment 1 zorxd 2005-03-29 11:04:31 UTC
Created attachment 2241 [details]
Xfree86 config file
Comment 2 zorxd 2005-03-29 11:04:50 UTC
Created attachment 2242 [details]
xfree86 log file
Comment 3 zorxd 2005-03-29 11:05:06 UTC
Created attachment 2243 [details]
extra info
Comment 4 Michel Dänzer 2005-03-29 11:13:05 UTC
Apparently, you didn't read the top of the log file you attached... anyway, does
it also happen without Option "AGPMode"?
Comment 5 Dave Airlie 2005-03-29 17:44:26 UTC
Try getting the DRM from CVS and using it - 2.6.12 will have a fixed DRM for
X4.3, simple patch just got missed, I might push it into a 2.6.11.7 depends on
if I get time..


Comment 6 zorxd 2005-03-29 18:44:49 UTC
option agpmode=4 was the problem