Bug 28579 - can't install a mime definition xml with a space in its path.
Summary: can't install a mime definition xml with a space in its path.
Alias: None
Product: xdgmime
Classification: Unclassified
Component: xdgmime (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Jonathan Blandford
QA Contact:
Depends on:
Reported: 2010-06-17 02:54 UTC by John Goering
Modified: 2018-10-13 10:34 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Description John Goering 2010-06-17 02:54:46 UTC
When the XML describing the mimetype is in a folder which contains a space, xdg-mime does not install it. Otherwise the file works fine.

I tried it in two different ways:

> xdg-mime install "/home/dev/my folder/my-mfe.xml"


> xdg-mime install /home/dev/my\ folder/my-mfe.xml

Note that using the same XML file just in a different location, the following worked:

> xdg-mime install /home/dev/myfolderwithoutaspace/my-mfe.xml

Just for completeness' sake, here is my XML:

<?xml version="1.0" encoding="UTF-8"?>
<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
   <mime-type type="application/myfiletype.archive">
	   <comment>my type</comment>
	   <glob pattern="*.mfe"/>
Comment 1 GitLab Migration User 2018-10-13 10:34:24 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xdg/xdgmime/issues/20.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.