Bug 28749 - [ilk] piglit/shaders/glsl-fs-pointcoord fail
Summary: [ilk] piglit/shaders/glsl-fs-pointcoord fail
Status: VERIFIED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: All All
: medium normal
Assignee: Eric Anholt
QA Contact: lu hua
URL:
Whiteboard:
Keywords:
: 18995 (view as bug list)
Depends on:
Blocks: 29044
  Show dependency treegraph
 
Reported: 2010-06-24 23:25 UTC by Gordon Jin
Modified: 2012-10-23 08:26 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gordon Jin 2010-06-24 23:25:40 UTC
piglit/shaders/glsl-fs-poincoord has been failed since Eric added this test on April 8th.

Output:
Probe at (0,0)
  Expected: 0.000000 1.000000 0.000000
  Observed: 0.000000 0.000000 0.000000
PIGLIT: {'result': 'fail' }

I'm using mesa master, on Piketon.
Comment 1 Gordon Jin 2010-07-20 19:34:26 UTC
It also fails with glsl2 branch.
Comment 2 Eric Anholt 2010-08-16 23:43:26 UTC
*** Bug 18995 has been marked as a duplicate of this bug. ***
Comment 3 Gordon Jin 2010-12-06 17:36:18 UTC
It passes on Pineview (i915).
Comment 4 Eric Anholt 2011-01-08 22:41:49 UTC
*** Bug 32429 has been marked as a duplicate of this bug. ***
Comment 5 Eric Anholt 2012-08-13 01:17:00 UTC
commit 43af02ac731dac7d80f7e47feb0c80e4da156769
Author: Yuanhan Liu <yuanhan.liu@linux.intel.com>
Date:   Mon Feb 27 15:46:32 2012 +0800

    i965: handle gl_PointCoord for Gen4 and Gen5 platforms
    
    This patch add the support of gl_PointCoord gl builtin variable for
    platform gen4 and gen5(ILK).
Comment 6 Gordon Jin 2012-10-23 05:47:55 UTC
Hua, can you help verifying on Piketon?
Comment 7 Gordon Jin 2012-10-23 08:26:21 UTC
verified.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.