Bug 28794 - Use GSettings instead of GConf
Summary: Use GSettings instead of GConf
Status: RESOLVED FIXED
Alias: None
Product: GeoClue
Classification: Unclassified
Component: Master Server (obsolete) (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Geoclue Bugs
QA Contact: Geoclue Bugs
URL:
Whiteboard:
Keywords:
: 27893 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-06-28 05:52 UTC by Bastien Nocera
Modified: 2012-02-17 06:27 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
0001-Port-to-GSettings.patch (8.10 KB, patch)
2010-06-28 05:52 UTC, Bastien Nocera
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Bastien Nocera 2010-06-28 05:52:18 UTC
Created attachment 36574 [details] [review]
0001-Port-to-GSettings.patch

Which removes some of the dependencies that non-GNOME don't like.
Comment 1 Bastien Nocera 2010-06-28 05:54:05 UTC
We could probably stop passing GValues, and pass GVariants instead.
Comment 2 Bastien Nocera 2010-06-30 04:11:21 UTC
*** Bug 27893 has been marked as a duplicate of this bug. ***
Comment 3 Bastien Nocera 2011-04-06 15:45:55 UTC
We can't intermix GVariant and GDBus here, so we'll carry on using the same process for this.

commit 59f49112b023310487142d48891f1d86b43b1e42
Author: Bastien Nocera <hadess@hadess.net>
Date:   Wed Jun 2 19:31:22 2010 +0100

    Port to GSettings
    
    Instead of GConf.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.