Bug 28796 - Hangcheck timer elapsed... GPU hung
Summary: Hangcheck timer elapsed... GPU hung
Status: RESOLVED DUPLICATE of bug 27187
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium major
Assignee: Carl Worth
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-28 06:16 UTC by SMF
Modified: 2010-06-29 01:02 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
dmesg output and Xorg.log (112.79 KB, text/plain)
2010-06-28 06:16 UTC, SMF
no flags Details
/sys/kernel/debug/dri/0/i915_error_state (761.75 KB, application/octet-stream)
2010-06-29 00:42 UTC, SMF
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description SMF 2010-06-28 06:16:02 UTC
Created attachment 36577 [details]
dmesg output and Xorg.log

IBM ThinkPad R51, model 2889SG1 (Linux KMS kernel 2.6.33.5)
LFS Build with Xorg built from latest individal sources.

X server and kernel report a hung GPU after 4-5 minutes usage.
Comment 1 Chris Wilson 2010-06-28 09:18:25 UTC
Hmm, not much info in there. You will need to update your kernel to a 2.6.34 or later which will automatically capture the error state upon a GPU hang. Then please upload the /sys/kernel/debug/dri/0/i915_error_state.
Comment 2 SMF 2010-06-29 00:42:34 UTC
Created attachment 36592 [details]
/sys/kernel/debug/dri/0/i915_error_state

Linux 2.6.34 Kernel with debugfs enabled as requested.

output from /sys/kernel/debug/dri/0/i915_error_state after failure.

thanks.
Comment 3 Chris Wilson 2010-06-29 01:02:19 UTC
Ah, in the middle of that batch is the infamous missing cache-line:

0x057858d8:      0x7f1c000b: 3DPRIMITIVE inline RECTLIST
0x057858dc:      0x42f80000:               vertex data (124.000000 float)
0x057858e0:      0x43250000:               vertex data (165.000000 float)
0x057858e4:      0x3f800000:               vertex data (1.000000 float)
0x057858e8:      0x3f800000:               vertex data (1.000000 float)
0x057858ec:      0x42f60000:               vertex data (123.000000 float)
0x057858f0:      0x43250000:               vertex data (165.000000 float)
0x057858f4:      0x00000000:               vertex data (0.000000 float)
0x057858f8:      0x3f800000:               vertex data (1.000000 float)
0x057858fc:      0x42f60000:               vertex data (123.000000 float)
0x05785900:      0x00000000:               vertex data (0.000000 float)
0x05785904:      0x00000000:               vertex data (0.000000 float)
0x05785908:      0x00000000:               vertex data (0.000000 float)
0x0578590c:      0x00000000: MI_NOOP
0x05785910:      0x00000000: MI_NOOP
0x05785914:      0x00000000: MI_NOOP
0x05785918:      0x00000000: MI_NOOP
0x0578591c:      0x00000000: MI_NOOP
0x05785920:      0x00000000: MI_NOOP
0x05785924:      0x00000000: MI_NOOP
0x05785928:      0x00000000: MI_NOOP
0x0578592c:      0x00000000: MI_NOOP
0x05785930:      0x00000000: MI_NOOP
0x05785934:      0x00000000: MI_NOOP
0x05785938:      0x00000000: MI_NOOP
0x0578593c:      0x00000000: MI_NOOP
0x05785940:      0x00000000: MI_NOOP
0x05785944:      0x00000000: MI_NOOP
0x05785948:      0x00000000: MI_NOOP
0x0578594c:      0x00000000: MI_NOOP
0x05785950:      0x00000000: MI_NOOP
0x05785954:      0x00000000: MI_NOOP
0x05785958:      0x00000000: MI_NOOP
0x0578595c:      0x00000000: MI_NOOP
0x05785960:      0x00000000: MI_NOOP
0x05785964:      0x00000000: MI_NOOP
0x05785968:      0x00000000: MI_NOOP
0x0578596c:      0x00000000: MI_NOOP
0x05785970:      0x00000000: MI_NOOP
0x05785974:      0x00000000: MI_NOOP
0x05785978:      0x00000000: MI_NOOP
0x0578597c:      0x00000000: MI_NOOP
0x05785980: HEAD 0x3f800000:    UNKNOWN
0x05785984:      0x3f800000:    UNKNOWN
0x05785988:      0x42f60000: 2D UNKNOWN
0x0578598c:      0x43280000: 2D UNKNOWN
0x05785990:      0x00000000: MI_NOOP
0x05785994:      0x3f800000:    UNKNOWN
0x05785998:      0x42f60000: 2D UNKNOWN
0x0578599c:      0x43270000: 2D UNKNOWN
0x057859a0:      0x00000000: MI_NOOP
0x057859a4:      0x00000000: MI_NOOP
0x057859a8:      0x7f1c000b: 3DPRIMITIVE inline RECTLIST
0x057859ac:      0x42f80000:               vertex data (124.000000 float)
0x057859b0:      0x43290000:               vertex data (169.000000 float)

which confirms this being an instance of incoherency which is still a battle we have not won on the i8xx. If you try the patches on bug 27187, that should improve stability of your system (but do not yet seem to be a complete cure).

*** This bug has been marked as a duplicate of bug 27187 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.