Bug 28841 - Heavy text corruption in virtual consoles using DRI
Summary: Heavy text corruption in virtual consoles using DRI
Status: RESOLVED INVALID
Alias: None
Product: DRI
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-30 01:48 UTC by Elio Blanca
Modified: 2019-10-14 13:20 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
My xorg.conf (569 bytes, application/octet-stream)
2010-06-30 01:52 UTC, Elio Blanca
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Elio Blanca 2010-06-30 01:48:25 UTC
I have a clean install of latest ubuntu lucid lynx, I added framebuffer support for g550 (matroxfb) and text in virtual consoles appears corrupted, it is made of random pixels appearing far away from the expected prompt. I can get back to clean text if I switch to xorg (ctrl+f7) then back to the virtual console, but if I type in new text, it appears ugly as usual.
The only workaround for this is to disable DRI, then the text appears perfect and no switch is needed. Of course, this way the system cannot support any game.
I attach my actual xorg.conf.

My config: ubuntu 10.04 (Lucid) 2.6.32-22-generic i686 GNU/Linux with
gnome 2.30.2 and xorg X server 1.7.6.
Comment 1 Elio Blanca 2010-06-30 01:52:08 UTC
Created attachment 36625 [details]
My xorg.conf

xorg mga driver is version 1.4.11.dfsg-2ubuntu1
Comment 2 Martin Peres 2019-10-14 13:20:06 UTC
Hi,

Freedesktop's Bugzilla instance is EOLed and open bugs are about to be migrated to http://gitlab.freedesktop.org.

To avoid migrating out of date bugs, I am now closing all the bugs that did not see any activity in the past year. If the issue is still happening, please create a new bug in the relevant project at https://gitlab.freedesktop.org/drm (use misc by default).

Sorry about the noise!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.