Bug 28894 - slang build fails if absolute path contains spaces
slang build fails if absolute path contains spaces
Status: RESOLVED FIXED
Product: Mesa
Classification: Unclassified
Component: Mesa core
git
All All
: medium normal
Assigned To: nobled
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-02 15:41 UTC by nobled
Modified: 2010-08-25 17:36 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
wrap absolute path in quotes (1.61 KB, patch)
2010-07-06 12:26 UTC, nobled
Details | Splinter Review
wrap absolute paths in quotes v2 (2.10 KB, patch)
2010-07-15 12:58 UTC, nobled
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description nobled 2010-07-02 15:41:12 UTC
Compiling on Windows with "scons statetrackers=mesa drivers=softpipe winsys=gdi" failed when it tried to run compile.exe:

C:\Documents and Settings\[...]\mesa\build\windows-x86-debug-glsl\compile.exe fragment src\mesa\slang\library\slang_common_builtin.gc src\mesa\slang\library\slang_common_builtin_gc.h
'C:\Documents' is not recognized as an internal or external command, operable program or batch file.
scons: *** [src\mesa\slang\library\slang_common_builtin_gc.h] Error 1
scons: building terminated because of errors.

The problem looks like it starts in library/SConscript:

bld_frag = Builder(
	action = Action(glsl_compile[0].abspath + ' fragment $SOURCE $TARGET', '$CODEGENCODESTR'),
	emitter = glsl_compile_emitter,
	suffix = '.gc',
	src_suffix = '_gc.h')
Comment 1 nobled 2010-07-06 12:26:20 UTC
Created attachment 36789 [details] [review]
wrap absolute path in quotes

FTR, this is a regression on 3371f7e5025e5288eaba78973a2c81ec5d5b1e4d. (Is the abspath really necessary?)
Comment 2 nobled 2010-07-15 12:58:43 UTC
Created attachment 37086 [details] [review]
wrap absolute paths in quotes v2
Comment 3 Eric Anholt 2010-08-25 17:36:32 UTC
Slang is gone.