Bug 29183 - [llvmpipe] piglit glsl-bug-22603 fails
[llvmpipe] piglit glsl-bug-22603 fails
Status: CLOSED FIXED
Product: Mesa
Classification: Unclassified
Component: Other
git
x86 (IA32) Linux (All)
: medium normal
Assigned To: Jose Fonseca
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-20 16:47 UTC by Vinson Lee
Modified: 2010-07-23 13:20 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
glsl-bug-22603.png (8.25 KB, image/png)
2010-07-20 16:47 UTC, Vinson Lee
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vinson Lee 2010-07-20 16:47:43 UTC
Created attachment 37253 [details]
glsl-bug-22603.png

mesa: 62f8b56dc6bcc13a30ed4f8c2d71e5a139b57b33 (master)

Run piglit glsl-bug-22603. The test fails. This test passes with swrast and softpipe.

$ ./bin/glsl-bug-22603
...
Mesa: User error: GL_INVALID_OPERATION in glUniform(program not linked)
...
Probe at (500,400)
  Expected: 0.300000 0.300000 0.300000
  Observed: 1.000000 1.000000 1.000000
Probe at (220,300)
  Expected: 0.100000 0.100000 0.100000
  Observed: 1.000000 1.000000 1.000000
Probe at (450,350)
  Expected: 0.300000 0.300000 0.300000
  Observed: 1.000000 1.000000 1.000000
Probe at (270,350)
  Expected: 0.100000 0.100000 0.100000
  Observed: 1.000000 1.000000 1.000000
Probe at (270,225)
  Expected: 0.010000 0.010000 0.010000
  Observed: 1.000000 1.000000 1.000000
Probe at (450,250)
  Expected: 0.090000 0.090000 0.090000
  Observed: 1.000000 1.000000 1.000000
Comment 1 Brian Paul 2010-07-23 12:43:17 UTC
Fixed with Mesa commit e393350904a48d332d832881af9549400194608c.

Also, the GL_INVALID_OPERATION error was caused by a bug in the piglit test.  I've committed a fix for that too (0b10850dc508fb471950dd2b3302794676dc3ff7)
Comment 2 Vinson Lee 2010-07-23 13:20:56 UTC
mesa: e393350904a48d332d832881af9549400194608c (master)
piglit: dacd049dfceb749617be0dd8ee0321083d770523

piglit glsl-bug-22603 passes with llvmpipe.