Bug 2919 - glest segfaults on r200
glest segfaults on r200
Status: RESOLVED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/r200
6.2.1
x86 (IA32) Linux (All)
: high critical
Assigned To: Default DRI bug account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-07 03:32 UTC by Bug
Modified: 2005-08-24 15:57 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bug 2005-04-07 03:32:04 UTC
When selecting a character in glest for linux r7, X mouse and keyboard are
eaten, game freezes. http://www.glest.org

gdb:

Program received signal SIGSEGV, Segmentation fault.
0xb6e24cd2 in do_emit (ctx=0x815dc38, 
    start=0, end=389, dest=0xae399020)
    at t_vertex.c:1028
        in t_vertex.c

or:

Program received signal SIGSEGV, Segmentation fault.
0xb6d76cd2 in do_emit (ctx=0x81799c0, start=0, end=389, dest=0xae2eb020)
at t_vertex.c:1028
1028 t_vertex.c: No such file or directory.
in t_vertex.c
(gdb) bt
#0 0xb6d76cd2 in do_emit (ctx=0x81799c0, start=0, end=389, dest=0xae2eb020)
at t_vertex.c:1028
#1 0xb6d77482 in _tnl_build_vertices (ctx=0x81799c0, start=0, end=389,
newinputs=4294967295) at t_vertex.c:1249
#2 0xb6d71c0a in run_render (ctx=0x81799c0, stage=0x830be0c)
at t_vb_render.c:296
#3 0xb6d5116f in _tnl_run_pipeline (ctx=0x81799c0) at t_pipeline.c:159
#4 0xb6db2fff in r200WrapRunPipeline (ctx=0x81799c0) at r200_state.c:2270
#5 0xb6d4f215 in _tnl_draw_range_elements (ctx=0x81799c0, mode=4,
max_index=389, index_count=1284, indices=0x998a2c0) at t_array_api.c:118
#6 0xb6d4f8cf in _tnl_DrawRangeElements (mode=4, start=0, end=388,
count=1284, type=5125, indices=0x998a2c0) at t_array_api.c:341
#7 0x080f0029 in Shared::Graphics::Gl::ModelRendererGl::renderMesh (
this=0x1405, mesh=0x0) at model.h:91
#8 0x080f0a27 in Shared::Graphics::Gl::ModelRendererGl::render (
this=0x83117d0, model=0x97ca9d8) at model.h:142
#9 0x080ced19 in Glest::Game::Renderer::renderUnitsFast (this=0x8150200)
at sources/renderer.cpp:2178
#10 0x080d2b5b in Glest::Game::Renderer::computeSelected (this=0x8150200,
units=@0xbffff340, posDown=@0x814fe80, posUp=@0x0)
at sources/renderer.cpp:1765
#11 0x080ae634 in Glest::Game::Gui::computeSelected (this=0x8b71d1c,
doubleClick=false) at gui.h:72
#12 0x080aebdf in Glest::Game::Gui::mouseDownLeftGraphics (this=0x8b71d1c,
---Type <return> to continue, or q <return> to quit---
x=190, y=466) at sources/gui.cpp:203
#13 0x080b67e5 in Glest::Game::Game::mouseDownLeft (this=0x8b71990, x=466,
y=190) at sources/game.cpp:273
#14 0x080d6eb7 in Shared::Platform::Window::handleEvent ()
at lib/sources/platform/window.cpp:108
#15 0x0808aa69 in Glest::Game::glestMain () at sources/main.cpp:178
#16 0x0808acd1 in main () at sources/main.cpp:197 

Might be the same bug as:
https://bugs.freedesktop.org/show_bug.cgi?id=2780
Comment 1 Jarrod Johnson 2005-08-01 04:53:27 UTC
I also experience similar problem with gliv:
) bt
#0  do_emit (ctx=0x816f430, start=0, end=0, dest=0x0) at t_vertex.c:1028
#1  0xb733c6a4 in run_render (ctx=0x816f430, stage=0x0) at t_vb_render.c:296
#2  0xb73289ad in _tnl_run_pipeline (ctx=0x816f430) at t_pipeline.c:159
#3  0xb7375f0f in r200WrapRunPipeline (ctx=0x816f430) at r200_state.c:2270
#4  0xb734a001 in _tnl_flush_vtx (ctx=0x816f430) at t_vtx_exec.c:282
#5  0xb7348891 in _tnl_FlushVertices (ctx=0x816f430, flags=1)
    at t_vtx_api.c:836
#6  0xb7380f0e in r200FlushVertices (ctx=0x816f430, flags=1)
    at r200_swtcl.c:906
#7  0xb726dd94 in _mesa_RenderMode (mode=7168) at feedback.c:475
#8  0x080600d1 in matrix_tile_visible ()
#9  0xc411c000 in ?? ()
#10 0x43070000 in ?? ()
#11 0xc3e40000 in ?? ()
#12 0x08416950 in ?? ()
#13 0x00000000 in ?? ()
#14 0x083352e8 in ?? ()
#15 0x0806b4d2 in get_write_config_file ()
#16 0x08324648 in ?? ()
#17 0x00000000 in ?? ()
#18 0x3f800000 in ?? ()
#19 0x080602a8 in is_filtering_needed ()
#20 0x3f800000 in ?? ()

Anyone have an idea of what's going on?
Comment 2 Michel Dänzer 2005-08-02 01:34:12 UTC
I used to get a similar crash with gliv, but it was fixed in Mesa CVS a while
ago. Have you guys tried a recent CVS snapshot?
Comment 3 Roland Scheidegger 2005-08-25 08:57:56 UTC
Just tried glest on my rv250, seems to work fine with current Mesa cvs. Not sure
how the OP got it to run though, it will bail out if GL_ARB_texture_env_crossbar
is not supported, which so far isn't in cvs yet... maybe older versions didn't
require it (1.1.0 tested).