Bug 29368 - Branch 1.9 of libcairo2 breaks display with nvidia proprietary drivers
Summary: Branch 1.9 of libcairo2 breaks display with nvidia proprietary drivers
Status: RESOLVED NOTOURBUG
Alias: None
Product: cairo
Classification: Unclassified
Component: general (show other bugs)
Version: 1.9.14
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Carl Worth
QA Contact: cairo-bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-02 16:05 UTC by Yotam Benshalom
Modified: 2010-08-03 02:40 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yotam Benshalom 2010-08-02 16:05:20 UTC
I use geforce 9500m with nvidia 256.44 drivers on 64-bit ubuntu 10.10.

The system is very sluggish and unresponsive comparing to prior experience with ubuntu 10.04, which used libcairo2 1.8. Compiz animations stutter and window contents are being drawn slowly. Moreover, there are elements the system fails to paint correctly with the nvdia driver:

1. Selected menu items and progress bars are brighter then they should be.

2. The lovely glowing dots below docky icons, which mark which app is being ran, become large, ugly grey blobs.

The issues disappear if I downgrade libcairo to the 1.8 branch.

Screenshots are found in the ubuntu bug report (https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/612614). This bug has links to many reports of people who suffer from similar issues.
Comment 1 Benjamin Otte 2010-08-03 02:40:15 UTC
That is a bug with the nvidia binary driver's rendering of gradients. See https://bugs.launchpad.net/murrine/+bug/605979/comments/13 for a more detailed discussion of the problem.


bug/show.html.tmpl processed on May 31, 2016 at 21:48:45.
(provided by the Example extension).