Bug 29400 - R300G : Regression, Transparency in KDE effects is corrupted
Summary: R300G : Regression, Transparency in KDE effects is corrupted
Status: RESOLVED DUPLICATE of bug 30007
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r300 (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Default DRI bug account
QA Contact:
Depends on:
Reported: 2010-08-04 09:23 UTC by Bruno Jacquet (Xaapyks)
Modified: 2010-12-17 04:30 UTC (History)
0 users

See Also:
i915 platform:
i915 features:

screenshot (116.91 KB, image/png)
2010-08-04 09:25 UTC, Bruno Jacquet (Xaapyks)
transparency ok (51.62 KB, image/png)
2010-08-05 10:00 UTC, Bruno Jacquet (Xaapyks)
with swrast thumbnail OK (77.34 KB, image/png)
2010-08-05 11:35 UTC, Bruno Jacquet (Xaapyks)

Description Bruno Jacquet (Xaapyks) 2010-08-04 09:23:09 UTC

This report concerns R300G, please change the target component if it should be in another category.

Build from git (e3a0e46), configured with  --with-state-trackers=dri,glx --with-dri-drivers=r300 --enable-gallium-radeon --prefix=/usr --disable-egl --disable-glu --disable-glw --disable-glut --disable-gallium-swrast --disable-gallium-nouveau --disable-gallium-svga --disable-gallium-i915 --disable-gallium-i965 --disable-gallium-r600 --disable-gallium-llvm

This is a regression (about 3 weeks ago it worked). I tried to bisect it but I think some weird bug in my KDE (or in my way to do it...) prevents me to do it in a convenient way...

If you have an advice on the way to proceed to bisect and easily test, please tell me. I don't want to always make , delete my whole kde settings, run KDE from root's call to init level change etc...
(The way I was doing was to use LIBGL_DRIVERS_PATH=... startx in a vt but I was not able to correctly use it. I may try again if I have time)
Comment 1 Bruno Jacquet (Xaapyks) 2010-08-04 09:25:27 UTC
Created attachment 37572 [details]
Comment 2 Niels Ole Salscheider 2010-08-04 09:27:50 UTC
Do you have blur enabled? If so, try to reduce the blur strength. For me, it seems that some sort of clipping occurs if the setting is too high so that all blurred parts become distorted.
Comment 3 Bruno Jacquet (Xaapyks) 2010-08-04 09:53:44 UTC
Well... in my upgrade from linux 2.6.34 to 2.6.35, the problem has changed...
Now the transparency looks OK but when the fade is enabled, and a menu appears it start transparent, goes to half opaque, then blocks for about 1 second and finishes opaque.

I don't know if it is related to my original bug report...

Disabling blur did not solve the problem.
Comment 4 Marek Olšák 2010-08-04 14:52:19 UTC
I do not use KDE, so it is not clear to me what is wrong on the screenshot. Please also attach the screenshot how it should look like, so that we can compare.

Here's some advice on how to bisect efficiently.

Your driver is usually located in something like: /usr/lib/dri/r300_dri.so

Delete that file and make a new symlink r300_dri.so in place of the original file and point it to .../mesa/lib/gallium/radeong_dri.so, where mesa is your git-cloned mesa repository.

Here I have:

$ ls -l /usr/lib/dri/r300_dri.so 
lrwxrwxrwx 1 root root 47 2010-05-23 21:22 /usr/lib/dri/r300_dri.so -> /home/eosie/dev/mesa/lib/gallium/radeong_dri.so

Now when you just compile the driver ("make"), it will be automatically used by all applications you run, and those running ones should be just restarted. Concerning KDE, you probably want to restart kdm after typing "make" in the mesa directory. It's really that simple. Now there is nothing stopping you from bisecting. ;)
Comment 5 Bruno Jacquet (Xaapyks) 2010-08-05 09:57:56 UTC

Thanks for your advices on bisecting, I did not even think of symlinking >.>
Anyways, it looks like there is some kind of bug, sometimes KDE says it can enable effects and after when reverting to a working dri driver it never wants to enable it again... I'll have to sort this out...

Anyways, the transparency problem is solved (on a kernel update ?)
And the other issue I reported, (the lag in the fade effect) also seems to be gone... I don't understand how...

I' attach a screenshot of how it is now (partially fixed ? transparency is OK but why don't I have the thumbnail of my window ?)
Comment 6 Bruno Jacquet (Xaapyks) 2010-08-05 10:00:25 UTC
Created attachment 37591 [details]
transparency ok

thumbnail at the center is missing, I don't know why. I'll have to find out if it's related to KDE or r300g
Comment 7 Bruno Jacquet (Xaapyks) 2010-08-05 11:35:03 UTC
OK I confirm the thumbnail bug is not in kde but in r300g
I'll post a screenshot with swrast_dri.so.
Comment 8 Bruno Jacquet (Xaapyks) 2010-08-05 11:35:57 UTC
Created attachment 37598 [details]
with swrast thumbnail OK
Comment 9 Marek Olšák 2010-12-17 04:30:14 UTC
Yep, the blur should be fixed. For the thumbnails bug, please see bug 30007.

*** This bug has been marked as a duplicate of bug 30007 ***

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.