Bug 29490 - [glsl2] Compiler generates reads from shader outputs
Summary: [glsl2] Compiler generates reads from shader outputs
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Mesa core (show other bugs)
Version: git
Hardware: All All
: medium normal
Assignee: mesa-dev
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-10 12:48 UTC by Ian Romanick
Modified: 2010-08-16 23:48 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ian Romanick 2010-08-10 12:48:05 UTC
GL_ARB_vertex_program and GL_ARB_fragment_program do not allow reads from shader outputs, and many pieces of hardware (e.g., r300 and i915) don't allow this either.  Because of that, Mesa and many drivers assume that there are no reads from shader outputs, and some drivers will assert otherwise.
Comment 1 Brian Paul 2010-08-10 14:02:17 UTC
See the _mesa_remove_output_reads() function.
Comment 2 Eric Anholt 2010-08-16 23:48:20 UTC
commit 83baa8a6c5541829003bbffe1d2b8cee5a0263fd
Author: Marek Olšák <maraeo@gmail.com>
Date:   Mon Aug 16 01:53:30 2010 +0200

    st/mesa: remove output register reads inside shaders
    
    This is a GLSL2 regression fix.

(I don't think there are any other candidates for this: 965 is fine with it, and radeon developers claimed to be OK with it).


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.