Bug 29588 - Authorization dialog box (asking for a password) is hidden, not visible.
Summary: Authorization dialog box (asking for a password) is hidden, not visible.
Status: RESOLVED NOTOURBUG
Alias: None
Product: PackageKit
Classification: Unclassified
Component: packagekit-qt (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-16 04:12 UTC by johnjones492
Modified: 2010-08-31 03:11 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
A picture of PackageKit showing the bug. (102.73 KB, image/png)
2010-08-21 10:42 UTC, johnjones492
Details

Note You need to log in before you can comment on or make changes to this bug.
Description johnjones492 2010-08-16 04:12:06 UTC
In KPackageKit when I attempt to install updates, it sometimes stalls due to a dialog box not working correctly.  

The dialog box is one that asks the user to enter a root password; the problem is that this dialog box is sometimes hidden behind the main window of KPackageKit

The program  KPackageKit seems to stall for no reason, when it is waiting for the user to enter a password.  The dialog box that asks for a password is not visible; its behind the main window.  When this happens, a different dialog box appears that says something like "Awaiting authorization".
Comment 1 johnjones492 2010-08-21 10:42:59 UTC
Created attachment 38049 [details]
A picture of PackageKit showing the bug.

When this bug occurs, for users who are new to Linux, it will probably seem that KPackageKit has stalled for no reason.  The message "Awaiting Authorisation" looks like it could be referring to something on the server that the repository resides on.
Comment 2 johnjones492 2010-08-22 03:21:30 UTC
I'm not sure if I put this bug report in the right place.  I put it under the heading packagekit-qt because I guessed that "qt" refers to the GUI part of KPackageKit, not a backend.  But I may have put this bug report in the wrong place.  

This bug occurs on KPackageKit; I don't know if its in PackageKit for Gnome too.

The good thing about this bug is that it should be easy to fix, I think.  I think that when a dialog window pops up, the window has Properties that determine whether the window is above all other windows.  So this bug can be fixed by changing the properties of the dialog-bog that asks for a password.  (That's how it would be done in Delphi, which is a type of Pascal.  Unfortunately I don't know C++ so I can't be sure if it can be done the same way here.)
Comment 3 Richard Hughes 2010-08-31 03:11:37 UTC
This is a bug in the PolicyKit-kde package, not PackageKit-qt, sorry.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.