Bug 29673 - 82852/855GM Can't see mouse pointer in x (xorg-server-1.8.2) on ThinkPad X40 with gentoo-sources >=2.6.35
Summary: 82852/855GM Can't see mouse pointer in x (xorg-server-1.8.2) on ThinkPad X40 ...
Status: RESOLVED DUPLICATE of bug 29413
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i915 (show other bugs)
Version: unspecified
Hardware: Other Linux (All)
: medium normal
Assignee: Eric Anholt
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-19 04:54 UTC by Michael Volland
Modified: 2010-08-19 10:14 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Xorg.0.log (25.78 KB, text/plain)
2010-08-19 04:54 UTC, Michael Volland
Details
dmesg (43.17 KB, application/octet-stream)
2010-08-19 04:57 UTC, Michael Volland
Details
xorg.conf (4.23 KB, text/plain)
2010-08-19 05:00 UTC, Michael Volland
Details
xrandr (4.40 KB, application/octet-stream)
2010-08-19 05:07 UTC, Michael Volland
Details
glxinfo (9.21 KB, application/octet-stream)
2010-08-19 05:14 UTC, Michael Volland
Details
lspci -v (6.84 KB, application/octet-stream)
2010-08-19 05:16 UTC, Michael Volland
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Volland 2010-08-19 04:54:05 UTC
Created attachment 37973 [details]
Xorg.0.log

82852/855GM (rev 02) Subsystem: IBM Device 0557 i686
libdrm-2.4.21
Kernel: 2.6.35-gentoo-r1
gentoo linux
IBM ThinkPad X40
Display integrated (subnotebook)

After installing a new kernel form gentoo-sources-2.6.35-r1 I got no visible
mouse pointer on X (xorg-server-1.8.2) on my ThinkPad X40 I use icewm-1.2.37
but tried fvwm-2.5.30 and it is the same thing. It's possible to use the
pointer - you just can't see it. The last working kernel is:
gentoo-sources-2.6.34-r4 (34-r5 did not compile on the x40 - never happened
before) With the Kernel from gentoo-sources-2.6.35 I've got the same problem.

Reproducible: Always

Steps to Reproduce:
1. Install and compile gentoo-sources-2.6.35-r1 on the Thinkpad X40
2. start xorg-server-1.8.2 with icewm-1.2.37 or vwm-2.5.30 - probably with any
window-manager
Actual Results:  
It's not possible to see the mouse pointer, but you can use it to point and
click in any usual way.

Expected Results:  
After starting X you see the mouse pointer on the screen.

gpm works on the tty-console
Comment 1 Michael Volland 2010-08-19 04:57:18 UTC
Created attachment 37974 [details]
dmesg
Comment 2 Michael Volland 2010-08-19 05:00:44 UTC
Created attachment 37975 [details]
xorg.conf
Comment 3 Michael Volland 2010-08-19 05:07:08 UTC
Created attachment 37976 [details]
xrandr
Comment 4 Michael Volland 2010-08-19 05:14:25 UTC
Created attachment 37977 [details]
glxinfo
Comment 5 Michael Volland 2010-08-19 05:16:14 UTC
Created attachment 37978 [details]
lspci -v
Comment 6 Chris Wilson 2010-08-19 10:14:34 UTC

*** This bug has been marked as a duplicate of bug 29413 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.