Bug 29741 - [glsl] wine with GLSL renders incompletely or not at all
Summary: [glsl] wine with GLSL renders incompletely or not at all
Status: RESOLVED DUPLICATE of bug 29137
Alias: None
Product: Mesa
Classification: Unclassified
Component: Mesa core (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: mesa-dev
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-22 16:26 UTC by Rubén Fernández
Modified: 2010-08-22 16:45 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Screenshot with GLSL disabled, rendering correctly (359.07 KB, image/png)
2010-08-22 16:28 UTC, Rubén Fernández
Details
Screenshot with GLSL enabled, rendering incorrectly (23.41 KB, image/png)
2010-08-22 16:30 UTC, Rubén Fernández
Details
Log generated with MESA_GLSL=dump and RADEON_DEBUG=fp, with GLSL enabled (109.06 KB, application/octet-stream)
2010-08-22 16:31 UTC, Rubén Fernández
Details
Log generated with RADEON_DEBUG=fp, with GLSL disabled (8.04 KB, application/octet-stream)
2010-08-22 16:32 UTC, Rubén Fernández
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rubén Fernández 2010-08-22 16:26:30 UTC
Altough not giving any compilation errors now, most GLSL shaders generated by wine fail to render correctly.

In some applications/games, some objects are shown, others aren't. In some games, nothing is rendered at all.

Testing a revision of git previous to the glsl2 merge, I found that this bug happened exactly the same with the old GLSL compiler; this suggests that the problem might not be the compiler per se, but the r300g driver executing the resulting assembly incorrectly. The fact that the games render correctly with the LLVMpipe software renderer seems to confirm this.

Graphics Card: ATI Technologies Inc RV505 [Radeon X1550 64-bit]
CPU: Intel Core Duo 1.8 Ghz, 2.5 GB RAM
Linux kernel 2.6.34, libdrm 2.4.21
Comment 1 Rubén Fernández 2010-08-22 16:28:55 UTC
Created attachment 38078 [details]
Screenshot with GLSL disabled, rendering correctly

when wine is set to disable GLSL, it generates the shaders using the ARB assembly shader language; then, it renders most apps/games correctly
Comment 2 Rubén Fernández 2010-08-22 16:30:35 UTC
Created attachment 38079 [details]
Screenshot with GLSL enabled, rendering incorrectly

However, when GLSL is enabled in wine, only some objects are rendered; in this screenshot, the creatures and the torch flames are shown, but not the door or the walls.
Comment 3 Rubén Fernández 2010-08-22 16:31:28 UTC
Created attachment 38080 [details]
Log generated with MESA_GLSL=dump and RADEON_DEBUG=fp, with GLSL enabled
Comment 4 Rubén Fernández 2010-08-22 16:32:40 UTC
Created attachment 38081 [details]
Log generated with RADEON_DEBUG=fp, with GLSL disabled

A log without GLSL (when it is rendered correctly) for reference
Comment 5 Marek Olšák 2010-08-22 16:45:45 UTC
According to your logs, it seems to be the same issue as bug 29137. See the discussion here:

https://bugs.freedesktop.org/show_bug.cgi?id=29137#c12

*** This bug has been marked as a duplicate of bug 29137 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.