Bug 29765 - require automake 1.11 for at-spi2-core
Summary: require automake 1.11 for at-spi2-core
Alias: None
Product: at-spi2
Classification: Unclassified
Component: core (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Rob Taylor
QA Contact:
Depends on:
Reported: 2010-08-23 13:53 UTC by Bryan Hundven
Modified: 2015-06-05 07:50 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Description Bryan Hundven 2010-08-23 13:53:10 UTC
While building the 'gnome-3.0' moduleset from jhbuild, I ran into an issue where if I ran 'jhbuild bootstrap' it would install automake 1.10.3, which caused the following error:

checking for gcc option to accept ISO C89... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
./configure: line 3639: syntax error near unexpected token `disable-static'
./configure: line 3639: `LT_INIT(disable-static)'
*** Error during phase configure of at-spi2-core: 
########## Error running ./autogen.sh --prefix /home/bryan/gnome --libdir '/home/bryan/gnome/lib'  --disable-gtk-doc  *** [30/266]

which produces a configure with:


Where as if I don't build 'jhbuild bootstrap' and use the 1.11.1 automake from my OS, I am able to configure and build at-spi2-core.

at-spi2-core should require automake 1.11.
Comment 1 Andre Klapper 2010-08-23 13:55:15 UTC
http://www-old.cae.wisc.edu/pipermail/octave-maintainers/2009-October/013645.html also implies that 1.11 is needed. No clue why though.
Comment 2 Bryan Hundven 2010-08-23 13:59:10 UTC
Info Andre requested while debugging:

Comment 3 Patrick Welche 2010-08-31 06:06:42 UTC
To me it looks as though libtool 2 is required but only libtool 1.5 or so is installed, and nothing to do with automake. So what version(s) of libtool are installed?

Do you have a successful build when simply doing a
sh bootstrap
bootstrap will run autoreconf, which will run libtoolize (hopefully getting you your installed version 2), followed by aclocal which will make use of the version 2 in your objdir/m4...

It is possible that your automake version difference in behaviour is due to aclocal coming with automake and maybe looking in its own stash of m4 files. libtoolize should get you the right thing though...
Comment 4 Andre Klapper 2010-09-20 06:32:01 UTC
I still get this error in jhbuild and it blocks testing gnome for me.


jhbuild bootstrap builds automake 1.8, 1.9 and 1.10 for me and states:
"I: some modules (gettext, m4, autoconf, libtool, automake-1.11, pkg-config, python, guile) were automatically ignored as a sufficient enough version was found installed on your system."
Comment 5 Patrick Welche 2010-09-20 06:52:58 UTC
Any chance of a login on your system to have a look for myself?

My analysis still hasn't changed: LT_INIT appears in your configure script, which means that the definition of the LT_INIT macro wasn't found by autoconf. The definition should be in libtool.m4 in the m4 directory, and copied there by libtoolize. aclocal should then add a line of the form


to aclocal.m4, so that autoconf can find it when building configure.
Comment 6 Patrick Welche 2010-09-20 06:59:07 UTC
P.S. Note the complete lack of the word "automake" in the previous comment ;-)
Comment 7 Andre Klapper 2015-06-05 07:50:03 UTC
I assume this is nowadays obsolete (at least no problems on my current system).

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.