Bug 29845 - backlight control stopped working with 19c48d3b3f33582baa87a9b3a9189e320e4cea45 on Thinkpad T400
Summary: backlight control stopped working with 19c48d3b3f33582baa87a9b3a9189e320e4cea...
Status: RESOLVED DUPLICATE of bug 29716
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Carl Worth
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-27 14:43 UTC by Felix Möller
Modified: 2010-09-01 08:26 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Möller 2010-08-27 14:43:34 UTC
Hi,

after hours of bisecting I found the offending commit:
19c48d3b3f33582baa87a9b3a9189e320e4cea45

<http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/commit/?id=19c48d3b3f33582baa87a9b3a9189e320e4cea45> breaks my backlight control. The light is then fixed at the lowest possible brightness.
Comment 1 Chris Wilson 2010-09-01 08:26:34 UTC
Kernel bug - some of the backlight control paths do not respect the legacy mode.

*** This bug has been marked as a duplicate of bug 29716 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.