Bug 29916 - systemctl should default to --full if stdout is not tty
Summary: systemctl should default to --full if stdout is not tty
Status: RESOLVED FIXED
Alias: None
Product: systemd
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: low minor
Assignee: Lennart Poettering
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-31 16:23 UTC by Zbigniew Jedrzejewski-Szmek
Modified: 2011-01-20 15:23 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zbigniew Jedrzejewski-Szmek 2010-08-31 16:23:25 UTC
I'd expect 'systemctl | cat' do ignore terminal width.
E.g. 'systemctl | grep virtio' and 'systemctl --full | grep virtio' should give the same result, but they don't.

Another small thing:
even with --full, the descriptions are truncated to terminal width anyway. Would be nice if they could be printed in full when output is not a terminal. This
is useful when the description contains the un-mangled device name which one want to copy.
Comment 1 Lennart Poettering 2010-09-05 17:33:47 UTC
(In reply to comment #0)
> I'd expect 'systemctl | cat' do ignore terminal width.
> E.g. 'systemctl | grep virtio' and 'systemctl --full | grep virtio' should give
> the same result, but they don't.

Hmm, interesting idea. Also see https://bugzilla.redhat.com/show_bug.cgi?id=626891

> Another small thing:
> even with --full, the descriptions are truncated to terminal width anyway.
> Would be nice if they could be printed in full when output is not a terminal.

This is now fixed in v9.
Comment 2 Zbigniew Jedrzejewski-Szmek 2010-09-06 11:21:23 UTC
(In reply to comment #1)
> (In reply to comment #0)
> > I'd expect 'systemctl | cat' do ignore terminal width.
> > E.g. 'systemctl | grep virtio' and 'systemctl --full | grep virtio' should give
> > the same result, but they don't.
> 
> Hmm, interesting idea. Also see
> https://bugzilla.redhat.com/show_bug.cgi?id=626891
Basically this part is a duplicate of the other bug. I'm going to reply over there.

> > Another small thing:
> > even with --full, the descriptions are truncated to terminal width anyway.
> > Would be nice if they could be printed in full when output is not a terminal.
> 
> This is now fixed in v9.
Yes. Works!
Comment 3 Lennart Poettering 2010-10-08 07:13:50 UTC
I closed the rhbz bug a while back, closing this one too.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.