Bug 29935 - X locks up with second monitor with DPMS
Summary: X locks up with second monitor with DPMS
Status: RESOLVED INVALID
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/nouveau (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Nouveau Project
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-01 05:14 UTC by Johannes Berg
Modified: 2013-08-18 18:10 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
xserver / kernel log (30.08 KB, text/plain)
2010-09-01 05:30 UTC, Johannes Berg
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Berg 2010-09-01 05:14:58 UTC
(Version is 1:0.0.16+git20100518+4b8f1a0-1)

When powersaving kicks in and turns off my laptop's display and the external monitor, X locks up (or maybe it locks up on waking up).

(--) NOUVEAU(0): Chipset: "NVIDIA NVac"
(==) NOUVEAU(0): Depth 24, (--) framebuffer bpp 32
(==) NOUVEAU(0): RGB weight 888
(==) NOUVEAU(0): Default visual is TrueColor
(==) NOUVEAU(0): Using HW cursor
(II) NOUVEAU(0): Output LVDS-1 using monitor section Configured Monitor
(II) NOUVEAU(0): Output DP-1 has no monitor section
(II) NOUVEAU(0): EDID for output LVDS-1
(II) NOUVEAU(0): Manufacturer: APP  Model: 9c8c  Serial#: 16843009
(II) NOUVEAU(0): Year: 2008  Week: 5
(II) NOUVEAU(0): EDID Version: 1.3

(II) NOUVEAU(0): EDID for output DP-1
(II) NOUVEAU(0): Manufacturer: SAM  Model: 194  Serial#: 1112092985
(II) NOUVEAU(0): Year: 2005  Week: 52
(II) NOUVEAU(0): EDID Version: 1.3
(II) NOUVEAU(0): Digital Display Input
(II) NOUVEAU(0): Max Image Size [cm]: horiz.: 38  vert.: 30
(II) NOUVEAU(0): Gamma: 2.20
(II) NOUVEAU(0): DPMS capabilities: Off

I'm wary to reproduce, but if you tell me what information is needed I will do so.
Comment 1 Johannes Berg 2010-09-01 05:15:38 UTC
Could be related to #29934, I suppose.
Comment 2 Johannes Berg 2010-09-01 05:30:54 UTC
Created attachment 38356 [details]
xserver / kernel log

Now with 1:0.0.16+git20100825+390f1c8-1.

After both screens went blank, only laptop display came back, external monitor stayed blank. VT switching no longer worked, and restarting X didn't recover the second monitor.
Comment 3 Ilia Mirkin 2013-08-18 18:10:13 UTC
It appears that this bug report has laid dormant for quite a while. Sorry we haven't gotten to it. Since we fix bugs all the time, chances are pretty good that your issue has been fixed with the latest software. Please give it a shot. (Linux kernel 3.10.7, xf86-video-nouveau 1.0.9, mesa 9.1.6, or their git versions.) If upgrading to the latest isn't an option for you, your distro's bugzilla is probably the right destination for your bug report.

In an effort to clean up our bug list, we're pre-emptively closing all bugs that haven't seen updates since 2011. If the original issue remains, please make sure to provide fresh info, see http://nouveau.freedesktop.org/wiki/Bugs/ for what we need to see, and re-open this one.

Thanks,

The Nouveau Team


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.