Bug 30026 - xorg-server 1.8.2: crash in DrawableGone upon access glxPriv->pDraw
Summary: xorg-server 1.8.2: crash in DrawableGone upon access glxPriv->pDraw
Status: RESOLVED DUPLICATE of bug 28181
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/General (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) FreeBSD
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-05 03:28 UTC by Andriy Gapon
Modified: 2010-09-05 03:36 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
snippet from gdb session (1.88 KB, text/plain)
2010-09-05 03:28 UTC, Andriy Gapon
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andriy Gapon 2010-09-05 03:28:57 UTC
Created attachment 38448 [details]
snippet from gdb session

I have xorg-server 1.8.2 with radeon driver from xf86-video-ati 6.13.1.
Mesa version is 7.8.2.
FreeBSD DRI doesn't support DRI2, so DRI is used.

X server reproducibly crashes when I repeatedly minimize and restore a window by pressing its icon on a taskbar in KDE4 with OpenGL effects enabled.

I am attaching a snippet from gdb debugging session.
Please let me know if you would like any additional information or testing.
Comment 1 Michel Dänzer 2010-09-05 03:35:17 UTC

*** This bug has been marked as a duplicate of bug 28181 ***
Comment 2 Andriy Gapon 2010-09-05 03:36:01 UTC
Couple of details: glxPriv->pDraw is not NULL but gdb says that it points to inaccessible memory.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.