Bug 30080 - [i915] piglit nodepth-test fails
[i915] piglit nodepth-test fails
Status: VERIFIED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i915
git
Other All
: medium normal
Assigned To: Eric Anholt
:
: 35193 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-08 00:48 UTC by jiajia
Modified: 2011-08-25 20:22 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jiajia 2010-09-08 00:48:38 UTC
Test environment:
Pineview
Kernel_version:		2.6.36-rc2_unstable_20100907+
Libdrm:		(master)2.4.21-18-g23287f05cf2443ddf9e028e29beb5bd30979c6cf
Mesa:		(master)4a730b773f0cae9ff5defb407bb2b7ca43234c35

Problem:
piglit nodepth-test has failed on Pineview(i915) since we started to test it on Pineview on 2010-05-19. While it passes on Piketon(i965).

Output:
Probe at (0,0)
  Expected: 0.000000 1.000000 0.000000
  Observed: 1.000000 0.000000 0.000000
PIGLIT: {'result': 'fail' }
Comment 1 jiajia 2010-09-08 01:13:29 UTC
sorry, a typo. nodepth-test has been failed since 2009-12-30 on i915.
Comment 2 Eric Anholt 2011-07-13 10:09:44 UTC
*** Bug 35193 has been marked as a duplicate of this bug. ***
Comment 3 Eric Anholt 2011-07-18 11:44:11 UTC
commit fc4fba52cf7e9616c70dd76b4d6bdba6582e157b
Author: Eric Anholt <eric@anholt.net>
Date:   Tue Jul 12 10:48:40 2011 -0700

    i915: Disable the depth test whenever we don't have a depth buffer.
    
    We were disabling it once at the moment we changed draw buffers, but
    later enabling of depth test could turn it back on.  Fixes
    fbo-nodepth-test.
    
    Note that ctx->DrawBuffer has to be checked because during context
    create we get called while it's still unset.  However, we know we'll
    get an intel_draw_buffer() after that, so it's safe to make a silly
    choice at this point.
    
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=30080
Comment 4 Gordon Jin 2011-08-25 20:22:21 UTC
verified on Pineview.