Bug 30146 - Horizontal Couloured Lines with Nvidia 6,800 GT (NV40)
Summary: Horizontal Couloured Lines with Nvidia 6,800 GT (NV40)
Status: RESOLVED INVALID
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/nouveau (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Nouveau Project
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-12 06:06 UTC by Steven Ward
Modified: 2013-08-18 18:09 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Snippet of the main KDM.log (3.73 KB, text/plain)
2010-09-12 06:06 UTC, Steven Ward
no flags Details
dmesg when my nv40 crashed (28.14 KB, text/plain)
2010-09-12 06:08 UTC, Steven Ward
no flags Details
Xorg.0.log when my NV40 crashed (57.93 KB, text/plain)
2010-09-12 06:11 UTC, Steven Ward
no flags Details
Dmesg with init 3 and no nouveau.noaccel=1 (28.26 KB, application/x-trash)
2010-09-18 03:20 UTC, Steven Ward
no flags Details
Xorg.0.log with init 3,no nouveau.noaccel=1 and I used "startx -- -logverbose 6" (51.77 KB, application/x-trash)
2010-09-18 03:22 UTC, Steven Ward
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Steven Ward 2010-09-12 06:06:16 UTC
Created attachment 38646 [details]
Snippet of the main KDM.log

Hi to all,
         For the past week or so,I've been experiencing a major problem with my graphics card with the nouveau driver from both the git repository and the packaged version from Fedora.The version of Fedora I'm using is Rawhide(Fc15)with all the latest updates installed for it. I currently compile DRM,linux-2.6,Mesa and the xf86-video-nouveau source code from the git repositories.They all get git pulled regularly.

The problem I'm experiencing is this. I boot into the latest kernel,I give out the temporary workaround of init=/sbin/upstart.

I see the fedora logo building up with a lot black blocks(I see them both with my NV11 and my NV40).

But when I get to the KDM login screen,all I see are blue,black,red,and white horizontal lines across my screen,and X is locked up,I have to do a hard reset.

I've tried both vesa and nv in the driver section in my xorg.conf,and they work fine,I can get to the desktop (although,I have to do a rmmod -f the nouveau.ko module for the nv driver to work.

I have been using my Geforce MX400 (NV11)with the nouveau driver with no problems,I get to KDM normally with that Graphics Card.

I have attached my dmesg,Xorg.0.log and a snippet of my kdm.log.
I very much hope somebody can help me with this one.it is driving me nuts!

Regards,
       STEVE555
Comment 1 Steven Ward 2010-09-12 06:08:54 UTC
Created attachment 38647 [details]
dmesg when my nv40 crashed
Comment 2 Steven Ward 2010-09-12 06:11:03 UTC
Created attachment 38648 [details]
Xorg.0.log when my NV40 crashed
Comment 3 Steven Ward 2010-09-12 06:15:10 UTC
To make it clear,I'm having problems with my Nvidia Geforce 6,800 GT (NV40)
not my spare Geforce MX400 (NV11).
Comment 4 Francisco Jerez 2010-09-14 05:23:10 UTC
Does it work OK with acceleration disabled? (e.g. boot with "nouveau.noaccel=1" in your kernel command line)
Comment 5 Steven Ward 2010-09-14 08:44:27 UTC
(In reply to comment #4)
> Does it work OK with acceleration disabled? (e.g. boot with "nouveau.noaccel=1"
> in your kernel command line)

Hi there Francisco,
                  I haven't tried that option in my kernel parameters,but I will give it a try,and report back if it doesn't.

Regards,
       STEVE555
Comment 6 Steven Ward 2010-09-14 08:57:17 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > Does it work OK with acceleration disabled? (e.g. boot with "nouveau.noaccel=1"
> > in your kernel command line)
> 
> Hi there Francisco,
>                   I haven't tried that option in my kernel parameters,but I
> will give it a try,and report back if it doesn't.
> 
> Regards,
>        STEVE555

Dear Francisco,
              I've just tried out your solution to my problem and it works!
I'd like to thank you very much indeed.I hope they'll be a patch soon so I won't have to type in nouveau.noaccel=1 all the time.

Regards,
       STEVE555
Comment 7 Francisco Jerez 2010-09-14 09:30:18 UTC
This is a regression, right? Do you remember when it stopped to work? You could try "git bisect" to find the commit that introduced the problem.
Comment 8 Steven Ward 2010-09-18 02:58:42 UTC
Hi Francisco,
            I'm sorry for the late reply,I had discussed my issue on the nouveau irc channel.I did do a git bisect on the linix-2.6 kernel module branch with not much success.I simply can't remember when the code broke for me,although it was around the start of 30-08-2010.

I think a different approach to solve the problem could be better.Since the kernel option of nouveau.noaccel=1,I can boot fine into the desktop  with no problems.

If I now leave out the parameter,I can get as far as the desktop,but the X server will freeze as soon as it does.

I will upload my latest dmesg and Xorg.0.log whenb that problem occurs.

Regards,
        STEVE555
Comment 9 Steven Ward 2010-09-18 03:20:09 UTC
Created attachment 38777 [details]
Dmesg with init 3 and no nouveau.noaccel=1
Comment 10 Steven Ward 2010-09-18 03:22:13 UTC
Created attachment 38778 [details]
Xorg.0.log with init 3,no nouveau.noaccel=1 and I used "startx -- -logverbose 6"
Comment 11 Francisco Jerez 2010-09-19 19:05:42 UTC
(In reply to comment #8)
> Hi Francisco,
>             I'm sorry for the late reply,I had discussed my issue on the
> nouveau irc channel.I did do a git bisect on the linix-2.6 kernel module branch
> with not much success.I simply can't remember when the code broke for
> me,although it was around the start of 30-08-2010.
> 
> I think a different approach to solve the problem could be better.Since the
> kernel option of nouveau.noaccel=1,I can boot fine into the desktop  with no
> problems.
> 
Well, your kernel logs aren't very useful, because they end before the crash, they don't even have a trace of the X server starting up. Your best bet is still 'git-bisect', e.g. if you start bisecting from the 15 Aug it shouldn't take you than 12 steps to get to the culprit.

> If I now leave out the parameter,I can get as far as the desktop,but the X
> server will freeze as soon as it does.
> 
> I will upload my latest dmesg and Xorg.0.log whenb that problem occurs.
> 
> Regards,
>         STEVE555
Comment 12 Steven Ward 2010-09-29 15:58:17 UTC
(In reply to comment #11)
> (In reply to comment #8)
> > Hi Francisco,
> >             I'm sorry for the late reply,I had discussed my issue on the
> > nouveau irc channel.I did do a git bisect on the linix-2.6 kernel module branch
> > with not much success.I simply can't remember when the code broke for
> > me,although it was around the start of 30-08-2010.
> > 
> > I think a different approach to solve the problem could be better.Since the
> > kernel option of nouveau.noaccel=1,I can boot fine into the desktop  with no
> > problems.
> > 
> Well, your kernel logs aren't very useful, because they end before the crash,
> they don't even have a trace of the X server starting up. Your best bet is
> still 'git-bisect', e.g. if you start bisecting from the 15 Aug it shouldn't
> take you than 12 steps to get to the culprit.
> 
> > If I now leave out the parameter,I can get as far as the desktop,but the X
> > server will freeze as soon as it does.
> > 
> > I will upload my latest dmesg and Xorg.0.log whenb that problem occurs.
> > 
> > Regards,
> >         STEVE555

Dear Francisco,
              Here is an update to to my efforts.
I tried to a git bisect on the nouveau kernel modules,but I seemed to messed up my Fedora installation,so I did a fresh install of a nightly build of Fedora 14,and did a yum upgrade to Fedora 15.

I tried to install the kernel-modules with the latest Fedora 14 kernel at the time,(kernel.i686 0:2.6.35.4-12.fc14),but the build kept running into an error when trying to build with it.

So when I used the latest Fedora 15 kernel(2.6.36-0.28.rc6.git0.fc15.i686),I found I couldn't even boot with that kernel.So I used the parameters:
enforcing=0 nouveau.noaccel=1 and I could boot into the desktop.

So what I'm trying to say is I'm not so sure now if the kernel-module code is at fault,as I haven't built the latest kernel-module code with the latest kernel for Fedora 15 yet.

Regards,
       STEVE555
Comment 13 Ilia Mirkin 2013-08-18 18:09:40 UTC
It appears that this bug report has laid dormant for quite a while. Sorry we haven't gotten to it. Since we fix bugs all the time, chances are pretty good that your issue has been fixed with the latest software. Please give it a shot. (Linux kernel 3.10.7, xf86-video-nouveau 1.0.9, mesa 9.1.6, or their git versions.) If upgrading to the latest isn't an option for you, your distro's bugzilla is probably the right destination for your bug report.

In an effort to clean up our bug list, we're pre-emptively closing all bugs that haven't seen updates since 2011. If the original issue remains, please make sure to provide fresh info, see http://nouveau.freedesktop.org/wiki/Bugs/ for what we need to see, and re-open this one.

Thanks,

The Nouveau Team


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.