Bug 30151 - HDMI audio via radeon DRM driver is not working.
Summary: HDMI audio via radeon DRM driver is not working.
Status: RESOLVED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: XOrg git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-12 15:32 UTC by crocket
Modified: 2013-01-15 21:39 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description crocket 2010-09-12 15:32:04 UTC
I have X1250 video card integrated into the motherboard.
I enabled KMS.
HDMI audio device can be seen, but no sound can be played via HDMI audio device.
Comment 1 pitamila 2012-02-02 12:47:26 UTC
I can confirm this.

linux 3.2
graphic board hd4870

HDMI audio device seen  and unmuted
set in the grub kernel boot command radeon.audio=1

but when playing, no sound and no error
the audio file seems to be read faster than normal (compared to the
time it is played on my soundboard)
Comment 2 pitamila 2012-02-05 04:02:45 UTC
In fact, when you use a HDMI cable (not a DVI one)  it just work pretty well for
me :)
Forget the last comment and sorry for the noise.

Pita.
Comment 3 mtzseb 2013-01-15 09:21:43 UTC
No sound with HDMI port on my Radeon HD3650 mobility (with free drivers because Kernel>3.2)

Description of problem:
I have no sound with my HDMI port, but the image is OK.
I use it with the VLC player or smplayer with HDMI audio output alsa. 
With Kernels <= 3.2, I used the fglrx catalyst drivers, that worked perfectly.
I tested the solution for adding the entry "radeon.audio = 1" in Grub2 but without success.
With smplayer, videos plays too fast and without sound.
With vlc, I receive an error message, also without sound.
"The audio output failed:
Audio device 'hdmi: CARD = HDMI, DEV = 0 "can not be used:
Device or resource busy. "


Version-Release number of selected component (if applicable):
Rosa Desktop 2012 "fresh", lib64drm_radeon1 2.4.40, radeon-firmware 20120322, Kernel 3.6.10, alsa 1.0.26, pulseaudio 2.1, rosa mediaplayer 1.5.1, smplayer 0.8.3, vlc 2.0.4

I don't know what to do ... only using analog output and a simple converter jack / rca ... Good Bye Dolby Digital !
Comment 4 Andy Furniss 2013-01-15 10:21:01 UTC
(In reply to comment #3)
> No sound with HDMI port on my Radeon HD3650 mobility (with free drivers
> because Kernel>3.2)
> 
> Description of problem:
> I have no sound with my HDMI port, but the image is OK.
> I use it with the VLC player or smplayer with HDMI audio output alsa. 
> With Kernels <= 3.2, I used the fglrx catalyst drivers, that worked
> perfectly.
> I tested the solution for adding the entry "radeon.audio = 1" in Grub2 but
> without success.
> With smplayer, videos plays too fast and without sound.
> With vlc, I receive an error message, also without sound.
> "The audio output failed:
> Audio device 'hdmi: CARD = HDMI, DEV = 0 "can not be used:
> Device or resource busy. "
> 
> 
> Version-Release number of selected component (if applicable):
> Rosa Desktop 2012 "fresh", lib64drm_radeon1 2.4.40, radeon-firmware
> 20120322, Kernel 3.6.10, alsa 1.0.26, pulseaudio 2.1, rosa mediaplayer
> 1.5.1, smplayer 0.8.3, vlc 2.0.4
> 
> I don't know what to do ... only using analog output and a simple converter
> jack / rca ... Good Bye Dolby Digital !

Can you post the output from 

cat /proc/asound/cards
and
cat /proc/asound/devices
Comment 5 mtzseb 2013-01-15 17:51:24 UTC
Off course !

cat /proc/asound/cards
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfc500000 irq 47
 1 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xfc010000 irq 48

cat /proc/asound/devices
  2: [ 0- 0]: digital audio playback
  3: [ 0- 0]: digital audio capture
  4: [ 0- 0]: hardware dependent
  5: [ 0]   : control
  6: [ 1- 3]: digital audio playback
  7: [ 1- 0]: hardware dependent
  8: [ 1]   : control
 33:        : timer
Comment 6 Andy Furniss 2013-01-15 19:35:51 UTC
(In reply to comment #5)
> Off course !
> 
> cat /proc/asound/cards
>  0 [Intel          ]: HDA-Intel - HDA Intel
>                       HDA Intel at 0xfc500000 irq 47
>  1 [HDMI           ]: HDA-Intel - HDA ATI HDMI
>                       HDA ATI HDMI at 0xfc010000 irq 48
> 
> cat /proc/asound/devices
>   2: [ 0- 0]: digital audio playback
>   3: [ 0- 0]: digital audio capture
>   4: [ 0- 0]: hardware dependent
>   5: [ 0]   : control
>   6: [ 1- 3]: digital audio playback
>   7: [ 1- 0]: hardware dependent
>   8: [ 1]   : control
>  33:        : timer

Looks like vlc is trying the wrong device - from your output -

"Audio device 'hdmi: CARD = HDMI, DEV = 0 "can not be used:"

You need to get vlc to use card 1 device 3, I don't use vlc so can't help with that. I don't use smplayer either but with plain mplayer you would do -

mplayer -ao alsa:device=hw=1.3

Pulse may complicate things - I don't know as I don't use that.

If you still can't get any playback run alsamixer press F6 select hdmi and make sure it says OO not MM. Pressing m will toggle between Open and Mute.
Comment 7 mtzseb 2013-01-15 21:39:10 UTC
Everything works fine now on Rosa. Certainly an update yesterday and today on this young distro (because I've had several) which resolved a conflict. So, this system approaches perfection. My best linux distro I installed on my PC! Bug resolved ! I'm sorry for the soliciting caused by this digging out bug, but thank you for the time you have given me for his resolution.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.