Bug 30163 - telepathy-butterfly crashed with TypeError in _send_chunk()
Summary: telepathy-butterfly crashed with TypeError in _send_chunk()
Status: RESOLVED DUPLICATE of bug 29967
Alias: None
Product: Telepathy
Classification: Unclassified
Component: papyon (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Louis-Francis Ratté-Boulianne
QA Contact: Telepathy bugs list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-13 06:43 UTC by Pedro Villavicencio
Modified: 2010-09-13 08:34 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro Villavicencio 2010-09-13 06:43:27 UTC
this report has been filed here:

https://bugs.edge.launchpad.net/ubuntu/+source/telepathy-butterfly/+bug/629501

it seems to be a random crash, not sure how to reproduce it. Here's the traceback:

Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/papyon/switchboard_manager.py", line 366, in _sb_message_received
    handler._on_message_received(message)
  File "/usr/lib/pymodules/python2.6/papyon/msnp2p/transport/switchboard.py", line 116, in _on_message_received
    self._on_chunk_received(self._peer, self._peer_guid, chunk)
  File "/usr/lib/pymodules/python2.6/papyon/msnp2p/transport/base.py", line 157, in _on_chunk_received
    self.__send_chunk(peer, peer_guid, ack_chunk)
  File "/usr/lib/pymodules/python2.6/papyon/msnp2p/transport/base.py", line 224, in __send_chunk
    self._send_chunk(peer, peer_guid, chunk)
  File "/usr/lib/pymodules/python2.6/papyon/msnp2p/transport/switchboard.py", line 98, in _send_chunk
    peer_guid + "}"}
TypeError: cannot concatenate 'str' and 'NoneType' objects
Comment 1 Louis-Francis Ratté-Boulianne 2010-09-13 08:34:22 UTC

*** This bug has been marked as a duplicate of bug 29967 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.