Bug 30192 - Doom3-demo segfaults since glsl2 branch merged.
Doom3-demo segfaults since glsl2 branch merged.
Status: RESOLVED INVALID
Product: Mesa
Classification: Unclassified
Component: Mesa core
git
x86 (IA32) Linux (All)
: medium normal
Assigned To: mesa-dev
:
Depends on:
Blocks: 29044
  Show dependency treegraph
 
Reported: 2010-09-14 15:05 UTC by Andy Furniss
Modified: 2010-11-11 09:27 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andy Furniss 2010-09-14 15:05:37 UTC
Git mesa and drm-radeon-testing on a r600 card.

The problem is the same with both LIBGL_ALWAYS_SOFTWARE=1 and r600c.

Since mesa master commit -

commit 6c03c576cc49bbb008de66d374f4302ff0fe0390
Merge: 15a3b42... a433cd2...
Author: Ian Romanick <ian.d.romanick@intel.com>
Date:   Mon Aug 16 19:08:53 2010 -0700

    Merge branch 'glsl2'

Doom3-demo segfaults on startup -

----- R_InitOpenGL -----
Setup X display connection
dlopen(libGL.so.1)
dlopen(libGL.so.1)
idRenderSystem::Shutdown()
signal caught: Segmentation fault
si_code 1
Was in fatal error shutdown: Unable to initialize OpenGL
Trying to exit gracefully..
Comment 1 Andy Furniss 2010-11-10 16:42:03 UTC
Turns out that there is an easy workaround for this.

Edit the doom3-demo script which starts the game to comment out the line 

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:.
Comment 2 Tobias Jakobi 2010-11-11 09:27:50 UTC
I also encountered this. I tracked it down to some incompatibility between my 32bit multilib system libraries and the libs (libstdc++ and so on) that the doom3 installer ships with the binary. Removing these compat libs from the game directory also solved the problem, however this is essentially the same as changing the library path for LD.