Bug 30193 - [SNB] Compiz failed to come up
Summary: [SNB] Compiz failed to come up
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: unspecified
Hardware: Other All
: medium critical
Assignee: Wang Zhenyu
QA Contact: Xorg Project Team
Depends on:
Reported: 2010-09-14 16:10 UTC by Manjeet Singh
Modified: 2010-11-02 18:59 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:

xorg.log file attached (34.83 KB, application/octet-stream)
2010-09-14 17:48 UTC, Manjeet Singh
no flags Details
dmesg logs attached (30.56 KB, text/plain)
2010-09-14 17:48 UTC, Manjeet Singh
no flags Details

Description Manjeet Singh 2010-09-14 16:10:49 UTC
Bug description: Huron River UMA [8086:0106]- Compiz failed to come up.

System environment: 
-- chipset:00:00.0 Host bridge [0600]: Intel Corporation Sandy Bridge DRAM Controller [8086:0104] (rev 07)
00:02.0 VGA compatible controller [0300]: Intel Corporation Sandy Bridge Integrated Graphics Controller [8086:0106] (rev 07)
-- system architecture: i386-bit
-- xf86-video-intel:
-- xserver:X Server 1.8.2
-- libdrm:libdrm-2.4.21
-- kernel: 2.6.35-ng #1
-- Linux distribution: fedora based.
-- Machine or mobo model: Huron River UMA
-- Display connector:LVDS

Reproducing steps:
Boot to fedora based linus with kernel 2.6.35 and latest xorg 2.12 driver.
Compiz failed to come up- falling back to metacity.
when try to start compiz manually- the whole screen turns to white.

Additional info:
Compiz is coming up fine on Huron River ATI. The issue is only with HR UMA.
see the attached dmesg and xorg log files.
Comment 1 Manjeet Singh 2010-09-14 17:48:30 UTC
Created attachment 38705 [details]
xorg.log file attached
Comment 2 Manjeet Singh 2010-09-14 17:48:56 UTC
Created attachment 38706 [details]
dmesg logs attached
Comment 3 Manjeet Singh 2010-09-14 17:58:01 UTC
We this fatal error when Compiz is try to start:

compiz (core) - Fatal: No valid GL extensions string found.
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0

We are using this driver- xorg-x11-drv-intel-2.12.0-0.ptl.i686

Let me know if any more traces are needed from my side.
Comment 4 Manjeet Singh 2010-09-16 10:44:27 UTC
We have taken latest mesa from git and tried to run compiz on FC13 with 2.6.36-rc2 kernel (2D driver xf86-video-intel-2.12.0) . This mesa has support for device IDs 0x0102, 0x0106, 0x0126

Here are the observations .

-compiz –replace will make screen hang while trying to switch. Mouse is able to move though(which was different from complete screen hang seen with mesa-7.8.2)
-Set INTEL_NO_BLIT env variable. After starting compiz screen comes up corrupted.
-Set INTEL_STRICT_CONFORMANCE=2 to enable SW only rendering. Compiz crashes after starting with Seg fault displaying message
Compiz (video) – Warn: No 8 bit GLX pixmap format, disabling YV12 image format
Comment 5 Gordon Jin 2010-09-16 17:54:16 UTC
Decreasing priority and severity. 
Compiz is not expected to work at this point. Please understand this is an unlaunched platform and the driver is in development, so it's not a surprise to see compiz broken as it involves complex 3D features.
Comment 6 Ian Romanick 2010-10-05 17:35:07 UTC
Using [SNB] as the tag for bugs specific to Sandybridge hardware.
Comment 7 Eric Anholt 2010-10-06 17:39:58 UTC
With Mesa master, the only issue I'm seeing with compiz (window movement, wobbly windows, screen switching not using the cube plugin) is that the screen switching transitions to black when dragging a window do provoke screen transition, instead of something else.  Can you confirm with current 2D driver and Mesa?
Comment 8 Gordon Jin 2010-10-13 01:36:12 UTC
I get the same result as Eric, with .36-rc7, xf86-video-intel 2.13.0, mesa 7.9.
Comment 9 Wang Zhenyu 2010-11-02 18:59:50 UTC
compiz works with mesa master, so close this.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.