Bug 30199 - [Huron River] render corruption after S3 resume (with tiling)
[Huron River] render corruption after S3 resume (with tiling)
Status: VERIFIED FIXED
Product: DRI
Classification: Unclassified
Component: DRM/Intel
unspecified
All Linux (All)
: high major
Assigned To: Yuanhan Liu
: patch
: 30499 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-14 23:46 UTC by Gordon Jin
Modified: 2010-10-26 00:55 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
The Patch to fix this bug (1.63 KB, patch)
2010-09-16 00:54 UTC, Yuanhan Liu
no flags Details | Splinter Review
Updated patch based on zhenyu's review (1.65 KB, patch)
2010-09-16 01:38 UTC, Yuanhan Liu
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Gordon Jin 2010-09-14 23:46:41 UTC
This is forked from bug#29631, and intends to focus on the tiling issue.

Sandybridge D0 (pci id = 0126).

kernel 2.6.36-rc4, 2.6.35.
Comment 1 Yuanhan Liu 2010-09-16 00:54:49 UTC
Created attachment 38734 [details] [review]
The Patch to fix this bug
Comment 2 Wang Zhenyu 2010-09-16 01:04:03 UTC
Good catch! But I'm pretty sure that fence reg only changed on sandybridge, but not for ironlake. So you should use IS_GEN6(dev) instead of HAS_PCH_SPLIT().

Please send this to intel-gfx list and cc stable.

thanks.
Comment 3 Yuanhan Liu 2010-09-16 01:38:54 UTC
Created attachment 38735 [details] [review]
Updated patch based on zhenyu's review

(In reply to comment #2)
> Good catch! But I'm pretty sure that fence reg only changed on sandybridge, but
> not for ironlake. So you should use IS_GEN6(dev) instead of HAS_PCH_SPLIT().
> 
> Please send this to intel-gfx list and cc stable.
> 


Thanks. And here is the new patch.
Comment 4 Gordon Jin 2010-09-16 18:19:07 UTC
Ummm, I can't reproduce this problem now, with 2.6.34-rc6, even without your patch. I'd suggest just commit it since it works on your machine.
Comment 5 Chris Wilson 2010-09-19 11:13:27 UTC
Applied to -fixes, will send pull request to Linus after I have had a chance to boot test [on pre-Sandybridge].
Comment 6 Matthias Hopf 2010-10-01 03:39:30 UTC
*** Bug 30499 has been marked as a duplicate of this bug. ***