Bug 30267 - openarena mouse faliure since dix: don't create core motion events for non-x/y valuators
Summary: openarena mouse faliure since dix: don't create core motion events for non-x/...
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/Input/Core (show other bugs)
Version: git
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
: 30198 30933 (view as bug list)
Depends on:
Blocks: xserver-1.9
  Show dependency treegraph
 
Reported: 2010-09-19 11:42 UTC by Andy Furniss
Modified: 2010-10-20 05:33 UTC (History)
6 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Standard x server log (111.05 KB, text/plain)
2010-10-06 16:03 UTC, Andrew Randrianasulu
no flags Details
With de8be07cc0a8163b6ef04455706fd5ca2cebe587 reverted (38.69 KB, text/plain)
2010-10-06 16:04 UTC, Andrew Randrianasulu
no flags Details
X log (127.17 KB, text/plain)
2010-10-10 21:59 UTC, Andrew Randrianasulu
no flags Details
X log with "dix: don't create core motion events for non-x/y valuators." reverted (35.00 KB, text/plain)
2010-10-10 22:14 UTC, Andrew Randrianasulu
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andy Furniss 2010-09-19 11:42:02 UTC
It seems that xserver master

commit de8be07cc0a8163b6ef04455706fd5ca2cebe587
Author: Peter Hutterer <peter.hutterer@who-t.net>
Date:   Tue Aug 17 12:08:52 2010 +1000

    dix: don't create core motion events for non-x/y valuators

causes me to loose mouse in games like openarena and nexuiz.

As I am running radeon ddx on a recent card the games are set not to use dga.

In my xorg.conf I have -

Section "ServerFlags"
 Option "AllowEmptyInput" "off"
EndSection

Found with bisect and now running master OK with above reverted.
Comment 1 Andy Furniss 2010-09-29 13:19:24 UTC
I found that all I need to do to get round this is set the ENV

SDL_MOUSE_RELATIVE=0
Comment 2 Andy Furniss 2010-09-29 13:56:17 UTC
Ugh, should have tested this on more than the menues.

It does work in game also, but it's useless as you can't spin round and round by continuing to move the mouse in one direction - you come to a stop.
Comment 3 Andrew Randrianasulu 2010-10-06 16:02:33 UTC
(In reply to comment #0)
> It seems that xserver master
> 
> commit de8be07cc0a8163b6ef04455706fd5ca2cebe587
> Author: Peter Hutterer <peter.hutterer@who-t.net>
> Date:   Tue Aug 17 12:08:52 2010 +1000
> 
>     dix: don't create core motion events for non-x/y valuators
> 
> causes me to loose mouse in games like openarena and nexuiz.
> 
> As I am running radeon ddx on a recent card the games are set not to use dga.
> 
> In my xorg.conf I have -
> 
> Section "ServerFlags"
>  Option "AllowEmptyInput" "off"
> EndSection
> 
> Found with bisect and now running master OK with above reverted.

With "dix: don't create core motion events for non-x/y valuators." reverted (on top of git master up to commit 853d7ebfa3e2d281d92890a39010ff5787a00ffd) I have my mouse cursor in doom3-demo back! But older glxquake still can't be controlled  with mouse at all - it sees no events!

I'll add my log files for two runs: standard and with commit de8be07cc0a8163b6ef04455706fd5ca2cebe587 reverted
Comment 4 Andrew Randrianasulu 2010-10-06 16:03:24 UTC
Created attachment 39243 [details]
Standard x server log
Comment 5 Andrew Randrianasulu 2010-10-06 16:04:02 UTC
Created attachment 39244 [details]
With de8be07cc0a8163b6ef04455706fd5ca2cebe587 reverted
Comment 6 Andrew Randrianasulu 2010-10-06 16:05:43 UTC
In doom3-demo X log spammed with "[dix] XIGetDevice failed on XACE restrictions (149)", but in glxquake there was no such errors, so i  assume there are two bugs?
Comment 7 Jeremy Huddleston Sequoia 2010-10-09 10:44:22 UTC
This got picked up in 1.9.1rc1, so we need to either fix this or revert the change.  If I don't have anything by next Friday to address this, I'll just revert it and put out 1.9.1rc2.
Comment 8 Jeremy Huddleston Sequoia 2010-10-09 10:47:08 UTC
Andrew, I know you were testing with master, but would you mind jumping over to the 1.9 branch and trying out glxquake and doom3-demo (with and without the reversion).  Not all the input patches landed in 1.9-branch, so I'm curious if the glxquake issue is specific to master or in 1.9-branch as well.
Comment 9 Andrew Randrianasulu 2010-10-10 21:18:37 UTC
(In reply to comment #8)
> Andrew, I know you were testing with master, but would you mind jumping over to
> the 1.9 branch and trying out glxquake and doom3-demo (with and without the
> reversion).  Not all the input patches landed in 1.9-branch, so I'm curious if
> the glxquake issue is specific to master or in 1.9-branch as well.

Compiling 1.9 branch ... Bug https://bugs.freedesktop.org/show_bug.cgi?id=30198 can be duplicate of this bug, i'll post my results here.
Comment 10 Andrew Randrianasulu 2010-10-10 21:59:54 UTC
Created attachment 39338 [details]
X log

X log from 1.9.1-rc1, unmodified, up to commit 8ab87dc7ff48d4db8e5f95a74df627dac9c53c0a ( Bump version to 1.9.0.901 (1.9.1 rc1) )

same error/bug IS present here, for both glxquake and doom3-demo.
Comment 11 Andrew Randrianasulu 2010-10-10 22:14:21 UTC
Created attachment 39339 [details]
X log with "dix: don't create core motion events for non-x/y valuators." reverted

Server from 1.9 branch, only one commit reverted:

Revert "dix: don't create core motion events for non-x/y valuators."
    This reverts commit d4ef63f602325a9920dc1cbf64e3969dfa394d5f.

On this branch single revert seems to cure mouse problem in BOTH glxquake and doom3-demo!
Comment 12 Peter Hutterer 2010-10-12 17:00:42 UTC
(In reply to comment #11)
> Created an attachment (id=39339) [details]
> X log with "dix: don't create core motion events for non-x/y valuators."
> reverted
> 
> Server from 1.9 branch, only one commit reverted:
> 
> Revert "dix: don't create core motion events for non-x/y valuators."
>     This reverts commit d4ef63f602325a9920dc1cbf64e3969dfa394d5f.
> 
> On this branch single revert seems to cure mouse problem in BOTH glxquake and
> doom3-demo!

Jeremy, please revert this patch for now. it needs a follow-up patch for DGA in master but that's not good enough for the 1.9.1 timeframe.
Comment 13 Peter Hutterer 2010-10-12 17:37:34 UTC
Patch proposed here:
http://lists.freedesktop.org/archives/xorg-devel/2010-October/013990.html
Comment 14 Andrew Randrianasulu 2010-10-12 19:56:27 UTC
(In reply to comment #13)
> Patch proposed here:
> http://lists.freedesktop.org/archives/xorg-devel/2010-October/013990.html

Patch applied to master fixes both games, thanks!

Tested-by: Andrew Randrianasulu <randrik@mail.ru>
Comment 15 Peter Hutterer 2010-10-12 22:21:39 UTC
*** Bug 30198 has been marked as a duplicate of this bug. ***
Comment 16 Andy Furniss 2010-10-13 03:12:49 UTC
(In reply to comment #13)
> Patch proposed here:
> http://lists.freedesktop.org/archives/xorg-devel/2010-October/013990.html

This fixes master for me.
Comment 17 Gerwin 2010-10-19 10:27:47 UTC
Is this patch already applied in master git? Running xorg-egders ppa, i still can't move the mouse in games
Comment 18 Julien Cristau 2010-10-20 05:32:37 UTC
*** Bug 30933 has been marked as a duplicate of this bug. ***
Comment 19 Julien Cristau 2010-10-20 05:33:37 UTC
Guilty patch reverted in 1.9-branch, master fixed with:

commit 9872e0f0115cd7d0543e55a1831facddf3aff90c
Author: Peter Hutterer <peter.hutterer@who-t.net>
Date:   Wed Oct 13 10:31:51 2010 +1000

    xfree86: set mask for valuators 0/1 when emulating core events (#30267)

Closing.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.