Bug 30459 - Not finding available updates results in a confusing message
Summary: Not finding available updates results in a confusing message
Status: RESOLVED FIXED
Alias: None
Product: PackageKit
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-29 04:33 UTC by Hicham HAOUARI
Modified: 2010-09-29 05:53 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hicham HAOUARI 2010-09-29 04:33:04 UTC
If I run :
***************************
pkcon update
***************************

and there are no available updates, I receive the following confusing message :

*************************************************************
The transaction failed: no-packages-to-update, Nothing to do
*************************************************************

I think "The transaction failed:" part is confusing, "No packages to to update" will be enough as an answer.



PackageKit version : 0.6.6-2.fc13.i686
Comment 1 Richard Hughes 2010-09-29 05:53:51 UTC
commit 2474054245b21459084b2c9ee098538cf55c0fa3
Author: Richard Hughes <richard@hughsie.com>
Date:   Wed Sep 29 13:54:02 2010 +0100

    Add a nicer translated error when UpdatePackages has no packages to update. Fixes fd#30459


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.