Bug 30502 - [RADEON:R600C] atmospheres of planets get transparent when going away from planets in celestia
Summary: [RADEON:R600C] atmospheres of planets get transparent when going away from pl...
Status: RESOLVED WORKSFORME
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/R600 (show other bugs)
Version: 7.9
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-30 08:49 UTC by aceman
Modified: 2012-01-31 10:15 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Far view of Titan - atmosphere transparent (88.38 KB, image/png)
2010-09-30 08:49 UTC, aceman
Details
Near view of Titan - atmosphere almost opaque (176.89 KB, image/png)
2010-09-30 08:50 UTC, aceman
Details
Directory of git bisect data which I created in the process (20.08 KB, application/octet-stream)
2010-10-03 11:04 UTC, aceman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description aceman 2010-09-30 08:49:50 UTC
Created attachment 39071 [details]
Far view of Titan - atmosphere transparent

The atmosphere of some planets (not all) gets transparent when approaching the planets. As intended, the atmosphere of Titan should be opaque at all distances (except when standing on the surface). However, currently it gets more transparent as the observer is moving AWAY from the planet. From the distance, atmosphere is invisible, near the planet it is opaque.
Comment 1 aceman 2010-09-30 08:50:44 UTC
Created attachment 39072 [details]
Near view of Titan - atmosphere almost opaque
Comment 2 aceman 2010-09-30 08:51:54 UTC
This did not happen in Mesa 7.8.2.
It happens with Mesa 7.9-rc2, kernel 2.6.35.5, radeon driver 6.13.2, X.org 1.7.7.
OpenGL renderer string: Mesa DRI R600 (RV710 954F) 20090101 x86/MMX+/3DNow!+/SSE2 TCL DRI2
OpenGL version string: 2.1 Mesa 7.9-rc2
OpenGL shading language version string: 1.20
Comment 3 Alex Deucher 2010-09-30 08:55:47 UTC
(In reply to comment #2)
> This did not happen in Mesa 7.8.2.

Any chance you could bisect it?
Comment 4 aceman 2010-09-30 11:18:38 UTC
It also does not happen on 7.9 with software rendering.
I could try to bisect by date, but I don't know where to download the nightly snapshots.
Comment 5 Alex Deucher 2010-09-30 12:03:46 UTC
It would be much easier to checkout the mesa tree with git and use git bisect.
Comment 6 aceman 2010-09-30 12:59:17 UTC
From here: git://anongit.freedesktop.org/mesa/mesa ?
Comment 7 Alex Deucher 2010-09-30 13:11:46 UTC
yes.  see the mesa3d section of this guide for more info:
http://wiki.x.org/wiki/radeonBuildHowTo
Comment 8 aceman 2010-10-03 11:03:38 UTC
I have tried it, and managed several iterations. But now I have hit a range where celestia crashes on start with this error:
celestia: radeon_texture.c:703: radeon_store_teximage: Predpoklad `dstRowStride' nesplnený. (Prerequisite `dstRowStride' not met)

I have tried to get out of this range using "git bisect skip" on hundreds of commits, but I was not successful.

If you can help me get out of this hole I could continue bisecting.
Comment 9 aceman 2010-10-03 11:04:36 UTC
Created attachment 39138 [details]
Directory of git bisect data which I created in the process
Comment 10 Rafał Miłecki 2010-10-04 10:04:20 UTC
(In reply to comment #8)
> I have tried it, and managed several iterations. But now I have hit a range
> where celestia crashes on start with this error:
> celestia: radeon_texture.c:703: radeon_store_teximage: Predpoklad
> `dstRowStride' nesplnený. (Prerequisite `dstRowStride' not met)
> 
> I have tried to get out of this range using "git bisect skip" on hundreds of
> commits, but I was not successful.
> 
> If you can help me get out of this hole I could continue bisecting.

Driver broken for hundreds of commits? Sounds weird... Could you try "make distclean" and "make realclean" and then compile previously-broken-commit?
Comment 11 aceman 2010-10-09 04:07:08 UTC
Didn't help. No change.
Comment 12 aceman 2011-01-12 12:30:22 UTC
After trying bisecting mesa 7.9 and finally returning to the official snapshot, the problem vanished at the planet. It is still visible at some nebulas, but I am not sure it is the same problem. Both seem like a problem with some depth (distance from screen) determination.
Comment 13 aceman 2011-01-12 12:36:22 UTC
The broken driver problem seems to be Bug 28284 according to the error message. I probably returned the tree into that time range.
Comment 14 Jerome Glisse 2011-03-08 09:52:45 UTC
Please try r600g, classic driver is no longer actively supported
Comment 15 aceman 2012-01-31 10:15:27 UTC
I have not seen it since the report so let's close it for now.
And I am on R600g as it gets usable and the default.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.