Bug 30575 - Hard Lockup with r300g
Summary: Hard Lockup with r300g
Status: RESOLVED DUPLICATE of bug 29389
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r300 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-02 16:24 UTC by Hicham HAOUARI
Modified: 2010-11-21 02:59 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
glxinfo (23.44 KB, text/plain)
2010-10-02 16:24 UTC, Hicham HAOUARI
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hicham HAOUARI 2010-10-02 16:24:08 UTC
Created attachment 39127 [details]
glxinfo

I am having a hard lockup with r300g when playing Penumbra Black Plague game ( a free demo is available via http://www.penumbragame.com/demo.php ), or when playing flash content with lightspark.

Card   : ATI Mobility Radeon X700 PCIE ( RV410 )
Kernel : 2.6.35.6-37.fc14.i686
driver : xf86-video-ati-6.13.2
mesa   : d6e2b707baecb7655cd09d64080fc944cc5704a6 , built with Fedora spec file
glxinfo: (attached)

I am sorry for filing this bug with this few information, but the hard lockup left me out of options.
Comment 1 Marek Olšák 2010-10-02 16:58:25 UTC
Could you please try latest kernel 2.6.36-rcN? There are some hardlock fixes.

Please see also bug 29389, which describes another possible cause of hardlocks with a workaround. There is also bug 28474, where user Tormod Volden had had hardlocks with the same GPU as you and the workaround in bug 29389 helped him.

Links:
https://bugs.freedesktop.org/show_bug.cgi?id=29389
https://bugs.freedesktop.org/show_bug.cgi?id=28474
Comment 2 Hicham HAOUARI 2010-10-20 11:29:01 UTC
booting 2.6.36-0.41.rc8.git5.fc14.i686 with drm_kms_helper.poll=0 fixes the lockup for me
Comment 3 Marek Olšák 2010-11-21 02:59:35 UTC

*** This bug has been marked as a duplicate of bug 29389 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.