Bug 3059 - X server crashes after running cedega
Summary: X server crashes after running cedega
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/General (show other bugs)
Version: 6.8.2
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Xorg Project Team
QA Contact:
URL:
Whiteboard:
Keywords: want-backtrace
Depends on:
Blocks:
 
Reported: 2005-04-18 09:11 UTC by Göran Uddeborg
Modified: 2006-05-31 01:44 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Configuration file (3.21 KB, text/plain)
2005-04-18 09:13 UTC, Göran Uddeborg
no flags Details
X server log file when just starting cedega/rct, and immediately exiting (40.62 KB, text/plain)
2005-04-18 09:14 UTC, Göran Uddeborg
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Göran Uddeborg 2005-04-18 09:11:53 UTC
I run the game Roller Coaster Tycoon in cedega.  The program runs normally, but
when I finish it the X server crashes, and I have to use Alt-SysRq-k to get out.
 I've seen occasional crashes that I do not know if they are related.  But the
only repeatable case is using cedega; I have no pure OSS test case.

Using xorg-x11-6.8.2-19 from Fedora Core 4 test release 2.
Comment 1 Göran Uddeborg 2005-04-18 09:13:46 UTC
Created attachment 2449 [details]
Configuration file
Comment 2 Göran Uddeborg 2005-04-18 09:14:37 UTC
Created attachment 2451 [details]
X server log file when just starting cedega/rct, and immediately exiting
Comment 3 Göran Uddeborg 2005-07-03 14:36:34 UTC
Created attachment 3021 [details]
Standalone test case that actually stands alone

The component was changed to Driver/nVidia, but that is most likely incorrect. 
I see this problem with other graphics cards too.  I attach a configuration
file for a machine with an Matrox Millenium II.  Running Roller Coaster Tycoon
on this machine fails in the same way.
Comment 4 Adam Jackson 2005-07-03 14:45:40 UTC
starting with the 6.8.99.14 snapshot, on linux systems, the X server can print
its own backtrace when it crashes.  please confirm that these bugs are still
valid with 6.8.99.14 or later, and if they are please attach a the server log
from the crash.
Comment 5 Göran Uddeborg 2005-07-03 15:01:45 UTC
I will do that.  I have understood the X tree isn't the easiest thing to
rebuild. Therefore I will wait a bit and see if RPMs appear in Fedora's
development area.
Comment 6 Erik Andren 2006-04-23 06:23:13 UTC
How's that backtrace going?
Comment 7 Göran Uddeborg 2006-04-25 06:20:23 UTC
Oh, yes!  Roller Coaster Tycoon was replaced by other games on our local
top-ten, so I forgot.

But I'll do an upgrade of a machine to FC5 and see if the problem is still there
in the resent version.
Comment 8 Göran Uddeborg 2006-05-03 02:34:14 UTC
Update: It's not easy to reproduce any more.  I've done some different tests but
do not get the problem.  It looks like it has been fixed.

I want to upgrade and test on one more machine with different hardware before I
completely close this.  But it looks good so far.
Comment 9 Erik Andren 2006-05-31 01:44:51 UTC
Closing this one as the problem seems to be fixed. 



Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.