Bug 30648 - Video playback not smooth and exhibits stuttering at 720p while running Youtube HD stream
Summary: Video playback not smooth and exhibits stuttering at 720p while running Youtu...
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/R600 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) All
: high major
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-06 03:32 UTC by samit vats
Modified: 2010-10-20 05:57 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
glxinfo (16.03 KB, text/plain)
2010-10-06 03:32 UTC, samit vats
Details
Xorg.log (29.29 KB, patch)
2010-10-06 03:35 UTC, samit vats
Details | Splinter Review
xorg.conf (1.38 KB, text/plain)
2010-10-06 03:35 UTC, samit vats
Details

Note You need to log in before you can comment on or make changes to this bug.
Description samit vats 2010-10-06 03:32:09 UTC
Created attachment 39217 [details]
glxinfo

KMS Driver Stack details :
=========================

1)    Kernel-2.6.32-21-generic-pae   
2)    Libdrm-2.4.19                               
3)    Mesa-7.8                                
4)    Xorg-server-1.7.4                      
5)    ddx: xf86-video-ati-6.13.0 


System Environment :
===================

O.S. - Ubuntu-10.04(32 bit)
Asic - M97 Mobility RadeonHD 4830
CPU  - AMD Athlon(tm) 64 FX-60 Dual Core Processor@2.60 GHz


Steps to Reproduce:
===================
1)	Launch firefox  and run Youtube HD stream using link below
         http://www.youtube.com/watch?v=hbLgszfXTAY

2)	Select the resolution 720p

3) Let the stream buffer completely and playback
   


Expected :  The video plays without  incident such as frozen and corruption.
--------------

Observation :  Video playback not smooth and exhibits stuttering at 720p while running Youtube HD stream
Comment 1 samit vats 2010-10-06 03:35:05 UTC
Created attachment 39219 [details] [review]
Xorg.log
Comment 2 samit vats 2010-10-06 03:35:32 UTC
Created attachment 39220 [details]
xorg.conf
Comment 3 Alex Deucher 2010-10-06 07:48:37 UTC
Do things improve any with xf86-video-ati 6.13.2?  Also what are you using to view the videos?  Adobe's flash player?  html5 video embed? gnash?
Comment 4 samit vats 2010-10-08 03:07:24 UTC
(In reply to comment #3)
> Do things improve any with xf86-video-ati 6.13.2?  Also what are you using to
> view the videos?  Adobe's flash player?  html5 video embed? gnash?


1) Yes The Adobe flash player is used for viewing . 
2) Please suggest whether Youtube on Linux is using UVD by design or not. 
3) Since UVD is not implemented yet in driver , does the playing the HD stream with  hardware accelearation enabled in You Tube window impacts the performance and buffering time.
Comment 5 Alex Deucher 2010-10-08 07:27:19 UTC
(In reply to comment #4)
> 1) Yes The Adobe flash player is used for viewing . 
> 2) Please suggest whether Youtube on Linux is using UVD by design or not. 
> 3) Since UVD is not implemented yet in driver , does the playing the HD stream
> with  hardware accelearation enabled in You Tube window impacts the performance
> and buffering time.

The open driver does not support UVD at this time, and adobe flash does not use any acceleration support provided by the open driver at this time.
Comment 6 Ernst Sjöstrand 2010-10-08 13:32:28 UTC
You can try to add
OverrideGPUValidation=true
to
/etc/adobe/mms.cfg
( http://blogs.adobe.com/penguinswf/2008/08/secrets_of_the_mmscfg_file_1.html )
Comment 7 samit vats 2010-10-20 05:57:42 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > 1) Yes The Adobe flash player is used for viewing . 
> > 2) Please suggest whether Youtube on Linux is using UVD by design or not. 
> > 3) Since UVD is not implemented yet in driver , does the playing the HD stream
> > with  hardware accelearation enabled in You Tube window impacts the performance
> > and buffering time.
> The open driver does not support UVD at this time, and adobe flash does not use
> any acceleration support provided by the open driver at this time.



Resolved : fixed with the latest build


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.