Bug 30750 - [r300g] Too many ALU instructions
Summary: [r300g] Too many ALU instructions
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r300 (show other bugs)
Version: git
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-10 07:41 UTC by Ivan Sukin
Modified: 2011-03-12 11:51 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Sukin 2010-10-10 07:41:35 UTC
"Toyball" standard demo is not working now (it was working with older versions of Mesa). Output is:
r300 FP: Compiler Error:
r300_fragprog_emit.c::emit_alu(): Too many ALU instructions
Using a dummy shader instead.
Comment 1 Tom Stellard 2010-11-21 21:43:22 UTC
This is fixed in git master.
Comment 2 Ivan Sukin 2010-11-22 01:05:13 UTC
Many thanks.
Comment 3 Ionut Biru 2011-03-12 04:52:02 UTC
@Tom is the fix available in mesa 7.10.1?

i'm still having this bug when using gnome-shell
Comment 4 Tom Stellard 2011-03-12 10:57:12 UTC
(In reply to comment #3)
> @Tom is the fix available in mesa 7.10.1?
> 
> i'm still having this bug when using gnome-shell

Can you file a new bug.  This is a different problem.
Comment 5 Marek Olšák 2011-03-12 11:11:51 UTC
(In reply to comment #3)
> @Tom is the fix available in mesa 7.10.1?
> 
> i'm still having this bug when using gnome-shell

Yes, it's in 7.10.

Note that this is not a bug, it's a hardware limitation. Sometimes we can improve the compiler so that it generates a little less instructions, but that only applies to shaders the size of which is very close to the hardware limit. Too long shaders are simply NOT supported by hardware. Period.

Please set the environment variable RADEON_DEBUG=fp and attach the output gnome-shell will generate (in a new bug).
Comment 6 Ionut Biru 2011-03-12 11:51:46 UTC
(In reply to comment #5)
> (In reply to comment #3)
> > @Tom is the fix available in mesa 7.10.1?
> > 
> > i'm still having this bug when using gnome-shell
> 
> Yes, it's in 7.10.
> 
> Note that this is not a bug, it's a hardware limitation. Sometimes we can
> improve the compiler so that it generates a little less instructions, but that
> only applies to shaders the size of which is very close to the hardware limit.
> Too long shaders are simply NOT supported by hardware. Period.
> 
> Please set the environment variable RADEON_DEBUG=fp and attach the output
> gnome-shell will generate (in a new bug).


thanks for explaining what does that mean. 

bug reported here: https://bugs.freedesktop.org/show_bug.cgi?id=35257


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.