Bug 30887 - Radial shading does not render correctly
Summary: Radial shading does not render correctly
Status: RESOLVED FIXED
Alias: None
Product: poppler
Classification: Unclassified
Component: cairo backend (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: poppler-bugs
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-15 01:28 UTC by Adrian Johnson
Modified: 2012-05-10 10:17 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Splash (5.31 KB, image/png)
2010-10-15 01:34 UTC, Adrian Johnson
Details
Cairo (11.99 KB, image/png)
2010-10-15 01:35 UTC, Adrian Johnson
Details
Ghostscript (2.81 KB, image/png)
2010-10-15 01:36 UTC, Adrian Johnson
Details
PDF file to reproduce bug (2.25 KB, application/pdf)
2010-10-15 05:24 UTC, Adrian Johnson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adrian Johnson 2010-10-15 01:28:38 UTC
The attached file contains a radial gradient. It renders correctly in acroread and gs but output from poppler/splash and poppler/cairo does not contain the gradient.
Comment 1 Adrian Johnson 2010-10-15 01:34:38 UTC
Created attachment 39460 [details]
Splash

Splash rendering from "pdftoppm -png".
Comment 2 Adrian Johnson 2010-10-15 01:35:47 UTC
Created attachment 39461 [details]
Cairo

Cairo rendering from "pdftocairo -png".
Comment 3 Adrian Johnson 2010-10-15 01:36:58 UTC
Created attachment 39462 [details]
Ghostscript

Ghostscript output showing correct rendering of radial gradient.
Comment 4 Adrian Johnson 2010-10-15 05:24:57 UTC
Created attachment 39467 [details]
PDF file to reproduce bug
Comment 5 Thomas Freitag 2010-10-16 09:27:09 UTC
The enclosure test in Gfx::doRadialShFill doesn't work properly if r0 > r1, I'll fix it together with bug 30446
Comment 6 Thomas Freitag 2010-10-16 09:38:47 UTC
(In reply to comment #5)
> The enclosure test in Gfx::doRadialShFill doesn't work properly if r0 > r1,
> I'll fix it together with bug 30446

Sorry, I meant bug 30436
Comment 7 Albert Astals Cid 2010-11-04 14:08:14 UTC
Fixed in the splash backend for 0.16.0
Comment 8 Thomas Freitag 2012-05-02 00:25:06 UTC
(In reply to comment #7)
> Fixed in the splash backend for 0.16.0
Did You miss to close it? Also in pdftocairo I can't see a problem with this PDF anymore!
Comment 9 Albert Astals Cid 2012-05-10 10:17:57 UTC
Seems to be fixed in the cairo backend too


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.