Bug 31179 - With xorg 1.9.0 the Synaptics driver 1.3.0 doesn't work on Fujitsu T900, 1.2.2 does ; 1.3.0 OK with 1.9.1
With xorg 1.9.0 the Synaptics driver 1.3.0 doesn't work on Fujitsu T900, 1.2....
Status: RESOLVED FIXED
Product: xorg
Classification: Unclassified
Component: Input/synaptics
unspecified
x86-64 (AMD64) Linux (All)
: medium major
Assigned To: Peter Hutterer
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-27 18:58 UTC by jim.diamond
Modified: 2012-04-29 23:17 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jim.diamond 2010-10-27 18:58:40 UTC
Using Slackware 64 13.1 on a Fujitsu T900, running a variety of recent 2.6.3x kernels, with xorg 1.9.0 and 1.9.1, I get the following sort of complaints in Xorg.0.log:

[    33.085] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event9)
[    33.085] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
[    33.085] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad"
[    33.085] (II) LoadModule: "synaptics"
[    33.085] (II) Loading /usr/lib64/xorg/modules/input/synaptics_drv.so
[    33.086] (II) Module synaptics: vendor="X.Org Foundation"
[    33.086]    compiled for 1.9.0, module version = 1.3.0
[    33.086]    Module class: X.Org XInput Driver
[    33.086]    ABI class: X.Org XInput driver, version 11.0
[    33.086] (II) Synaptics touchpad driver version 1.3.0
[    33.086] (**) Option "Device" "/dev/input/event9"
[    33.124] (--) SynPS/2 Synaptics TouchPad: x-axis range 1472 - 5378
[    33.124] (--) SynPS/2 Synaptics TouchPad: y-axis range 1408 - 4546
[    33.124] (--) SynPS/2 Synaptics TouchPad: pressure range 0 - 255
[    33.124] (--) SynPS/2 Synaptics TouchPad: finger width range 0 - 0
[    33.124] (--) SynPS/2 Synaptics TouchPad: buttons: left right scroll-buttons
[    33.124] (--) SynPS/2 Synaptics TouchPad: invalid finger width range.  defaulting to 0 - 16
[    33.124] (**) Option "TapButton1" "1"
[    33.124] (**) Option "TapButton2" "2"
[    33.124] (**) Option "TapButton3" "3"
[    33.156] (--) SynPS/2 Synaptics TouchPad: touchpad found
[    33.156] (**) SynPS/2 Synaptics TouchPad: always reports core events
[    33.172] (II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD)
[    33.172] (**) SynPS/2 Synaptics TouchPad: (accel) MinSpeed is now constant deceleration 2.5
[    33.172] (**) SynPS/2 Synaptics TouchPad: MaxSpeed is now 1.75
[    33.172] (**) SynPS/2 Synaptics TouchPad: AccelFactor is now 0.040
[    33.172] (**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
[    33.172] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration profile 1
[    33.172] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration factor: 2.000
[    33.172] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration threshold: 4
[    33.196] (--) SynPS/2 Synaptics TouchPad: touchpad found
[    33.196] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse1)
[    33.196] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad"
[    33.196] (II) Synaptics touchpad driver version 1.3.0
[    33.648] (EE) SynPS/2 Synaptics TouchPad no synaptics event device found
[    33.648] (**) Option "Device" "/dev/input/mouse1"
[    33.656] (--) SynPS/2 Synaptics TouchPad: invalid x-axis range.  defaulting to 1615 - 5685
[    33.656] (--) SynPS/2 Synaptics TouchPad: invalid y-axis range.  defaulting to 1729 - 4171
[    33.656] (--) SynPS/2 Synaptics TouchPad: invalid pressure range.  defaulting to 0 - 256
[    33.656] (--) SynPS/2 Synaptics TouchPad: invalid finger width range.  defaulting to 0 - 16
[    33.656] (**) Option "TapButton1" "1"
[    33.656] (**) Option "TapButton2" "2"
[    33.656] (**) Option "TapButton3" "3"
[    33.676] (EE) Query no Synaptics: 6003C8
[    33.676] (--) SynPS/2 Synaptics TouchPad: no supported touchpad found
[    33.676] (EE) SynPS/2 Synaptics TouchPad Unable to query/initialize Synaptics hardware.
[    33.689] (EE) PreInit failed for input device "SynPS/2 Synaptics TouchPad"
[    33.689] (II) UnloadModule: "synaptics"


When I reverted to xf86-input-synaptics-1.2.2 I was able to get the Synaptics driver to work.

Steps to Reproduce: 
Install Slackware64 13.1 on a Fujitsu T900.  
Upgrade the xorg with the packages in http://www.linuxquestions.org/questions/slackware-14/call-for-testing-xorg-updates-20100830-a-829336/

Actual Results: 
as above, synaptics driver is confused.

Expected Results: 
the Synaptics driver loads correctly

I have no idea whether this problem happens on other systems.

If anyone needs any more info, just let me know.
Comment 1 Peter Hutterer 2010-10-28 21:57:21 UTC
does the driver actually work? is it just complaints in the log?

(In reply to comment #0)
> [    33.124] (--) SynPS/2 Synaptics TouchPad: finger width range 0 - 0
> [    33.124] (--) SynPS/2 Synaptics TouchPad: buttons: left right
> scroll-buttons
> [    33.124] (--) SynPS/2 Synaptics TouchPad: invalid finger width range. 
> defaulting to 0 - 16

we've added finger width support, but only newer kernels provide the data. this message can be safely ignored, it's not an error.
> [    33.196] (II) Synaptics touchpad driver version 1.3.0
> [    33.648] (EE) SynPS/2 Synaptics TouchPad no synaptics event device found
> [    33.648] (**) Option "Device" "/dev/input/mouse1"

MatchDevicePath "dev/input/event*" in the config snippets will do. it tries to add /dev/input/mouse1 as a device, that's a config issue.
Comment 2 Robby Workman 2010-10-28 22:15:15 UTC
Hi Peter,
I'm the packager rather than the reporter, so I can't answer most of your questions; however, with respect to the config snippet, here's what the xf86-input-synaptics package ships:

Section "InputClass"
        Identifier "touchpad"
        Driver "synaptics"
        MatchIsTouchpad "on"
        Option "TapButton1" "1"
        Option "TapButton2" "2"
        Option "TapButton3" "3"
EndSection

That's the same file in the tarball at conf/50-synaptics.conf, aside from the TapButton lines that I added to (ideally) create better defaults for users.

I can certainly add the MatchDevicePath line to the file if that's the issue here, but if so, it needs to be correct in the upstream file as well :)
Comment 3 Peter Hutterer 2010-10-28 22:22:24 UTC
(In reply to comment #2)
> I can certainly add the MatchDevicePath line to the file if that's the issue
> here, but if so, it needs to be correct in the upstream file as well :)

note that the driver supports more than just linux so we can't add the /dev/input/event match paths here. it should still work on Solaris, the BSDs, etc. and they don't have the event interface.
Comment 4 jim.diamond 2010-10-31 08:56:19 UTC
(In reply to comment #1)
> does the driver actually work? is it just complaints in the log?
> 
> (In reply to comment #0)
> > [    33.124] (--) SynPS/2 Synaptics TouchPad: finger width range 0 - 0
> > [    33.124] (--) SynPS/2 Synaptics TouchPad: buttons: left right
> > scroll-buttons
> > [    33.124] (--) SynPS/2 Synaptics TouchPad: invalid finger width range. 
> > defaulting to 0 - 16
> 
> we've added finger width support, but only newer kernels provide the data. this
> message can be safely ignored, it's not an error.
> > [    33.196] (II) Synaptics touchpad driver version 1.3.0
> > [    33.648] (EE) SynPS/2 Synaptics TouchPad no synaptics event device found
> > [    33.648] (**) Option "Device" "/dev/input/mouse1"
> 
> MatchDevicePath "dev/input/event*" in the config snippets will do. it tries to
> add /dev/input/mouse1 as a device, that's a config issue.

Well, it works in the sense that the touchpad acted like a mouse.  However, I was not able to do things like turn off tap-to-click.  It was generating many spurious clicks, which (as you probably) appreciate can be really annoying.

Also, if I recall correctly, circular scrolling was not working either.

In summary, I was concerned about the functionality, not the comments in the log file.  Sorry I didn't make that sufficiently clear in the first report.
Comment 5 Robby Workman 2010-10-31 21:50:54 UTC
Jim, it seems that maybe the issue is simply that the default configuration isn't very usable for you (I personally abhor tap-to-click functionality, but others like it).  Have a look at /usr/share/X11/xorg.conf.d/50-synaptics.conf and see if you are able to get something that's workable.  Here's the file content:

  # DO NOT EDIT THIS FILE - IT WILL BE OVERWRITTEN ON UPGRADES
  # Copy this file to /etc/X11/xorg.conf.d/ and edit the copy
  #
  # Use "synclient -l" to see all available options
  # Use "man synaptics" for details about what the options do
  #
  Section "InputClass"
          Identifier "touchpad"
          Driver "synaptics"
          MatchDevicePath "/dev/input/event*"
          MatchIsTouchpad "on"
          Option "TapButton1" "1"
          Option "TapButton2" "2"
          Option "TapButton3" "3"
  EndSection

In fact, see if removing those three Option lines from the copy you place in /etc/X11/xorg.conf.d/ makes a difference - that's the only deviation I added from the default.
Comment 6 jim.diamond 2010-11-01 16:16:42 UTC
(In reply to comment #5)
> Jim, it seems that maybe the issue is simply that the default configuration
> isn't very usable for you (I personally abhor tap-to-click functionality, but
> others like it).  Have a look at /usr/share/X11/xorg.conf.d/50-synaptics.conf
> and see if you are able to get something that's workable.  Here's the file
> content:

Well, I tried various things at the time, and I *think* that since X was getting its nose out of joint and unloading the synaptics module, nothing I did to try to configure the synaptics driver had any effect.  I am assuming (dangerous, I know) that after the synaptics driver was (apparently) unloaded, the touchpad was being driver my the generic mouse driver, and I had no control over these things.

At one point I created an xorg.conf file and every time I tried to put in a section for the synaptics driver, it complained bitterly.

Also, I tried using synclient, which claimed there was no synpatics driver present.  So all in all,
- it doesn't seem the log report about the driver being unloaded is bogus, and
- with no synaptics driver loaded, I don't think I can modify the driver behaviour.

Perhaps those who know the code will be able to contradict the assumptions I made in my above statements.
Comment 7 jim.diamond 2010-11-01 16:18:26 UTC
(In reply to comment #1)
> does the driver actually work? is it just complaints in the log?
> 
> (In reply to comment #0)
> > [    33.124] (--) SynPS/2 Synaptics TouchPad: finger width range 0 - 0
> > [    33.124] (--) SynPS/2 Synaptics TouchPad: buttons: left right
> > scroll-buttons
> > [    33.124] (--) SynPS/2 Synaptics TouchPad: invalid finger width range. 
> > defaulting to 0 - 16
> 
> we've added finger width support, but only newer kernels provide the data. this
> message can be safely ignored, it's not an error.

Thanks.  I was using 2.6.36.  The last time I looked, that was as new as it got.
Or are you using development kernels?

Cheers.
Comment 8 Peter Hutterer 2010-11-01 16:39:43 UTC
> Thanks.  I was using 2.6.36.  The last time I looked, that was as new as it
> got.
> Or are you using development kernels?

v2.6.35-rc3-49-g2a8e771 says it's the commit in the kernel, so should be in 2.6.36.


(In reply to comment #6)
> (In reply to comment #5)
> Well, I tried various things at the time, and I *think* that since X was
> getting its nose out of joint and unloading the synaptics module, nothing I did
> to try to configure the synaptics driver had any effect.  I am assuming
> (dangerous, I know) that after the synaptics driver was (apparently) unloaded,
> the touchpad was being driver my the generic mouse driver, and I had no control
> over these things.

the X driver is only unloaded once _all_ instances are unloaded. so seeing a UnloadModule in the log doesn't necessary mean the module is gone.
there is (was?) a kernel bug where the touchpad lost sync and came back as normal PS/2 mouse. in which case it would be added with evdev and synclient wouldn't be able to configure it as you say.

for that i'd need to see your whole xorg.log and /var/log/messages though.
Comment 9 jim.diamond 2010-11-01 18:57:58 UTC
(In reply to comment #8)
>> Thanks.  I was using 2.6.36.  The last time I looked, that was as new as it
>> got.
>> Or are you using development kernels?

> v2.6.35-rc3-49-g2a8e771 says it's the commit in the kernel, so should be in
> 2.6.36.

OK, here are the messages from Robbie W's 1.9.1 packages for Slackware64 1.3.1
using 2.3.36.

X.Org X Server 1.9.1
Release Date: 2010-10-22
[  1760.948] X Protocol Version 11, Revision 0
[  1760.948] Build Operating System: Slackware 13.1 Slackware Linux Project
[  1760.948] Current Operating System: Linux jdiamond-nb2 2.6.36 #1 SMP PREEMPT Tue Oct 26 09:17:36 ADT 2010 x86_64
[  1760.948] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.36 root=/dev/sda5 ro vt.default_utf8=0 vga = normal
[  1760.948] Build Date: 23 October 2010  11:19:34PM

<snip>

[  1762.200] (--) SynPS/2 Synaptics TouchPad: invalid x-axis range.  defaulting to 1615 - 5685
[  1762.200] (--) SynPS/2 Synaptics TouchPad: invalid y-axis range.  defaulting to 1729 - 4171
[  1762.200] (--) SynPS/2 Synaptics TouchPad: invalid pressure range.  defaulting to 0 - 256
[  1762.200] (--) SynPS/2 Synaptics TouchPad: invalid finger width range.  defaulting to 0 - 16


I have CONFIG_MOUSE_PS2_SYNAPTICS=y in my .config.  Is there something
else I should have?


> (In reply to comment #6)
>> (In reply to comment #5)
>> Well, I tried various things at the time, and I *think* that since X was
>> getting its nose out of joint and unloading the synaptics module, nothing I did
>> to try to configure the synaptics driver had any effect.  I am assuming
>> (dangerous, I know) that after the synaptics driver was (apparently) unloaded,
>> the touchpad was being driver my the generic mouse driver, and I had no control
>> over these things.
> 
> the X driver is only unloaded once _all_ instances are unloaded. so seeing a
> UnloadModule in the log doesn't necessary mean the module is gone.
Thanks, I didn't know that before.  (But now that you mention it, I
see that some of my Xorg log files do claim they unload the module
more than once.)

> there is (was?) a kernel bug where the touchpad lost sync and came back as
> normal PS/2 mouse . in which case it would be added with evdev and synclient
> wouldn't be able to configure it as you say.

> for that i'd need to see your whole xorg.log and /var/log/messages though.

In order to get you an xorg.log file, I re-installed the 1.3.0 driver
on top of Robbie's 1.9.1 xorg.  Except for what I think are misleading
messages in Xorg.0.log, it seems to be working now; synclient happily
talks to the driver.

I think I would like to change the title of this to
  With xorg 1.9.0 the Synaptics driver 1.3.0 doesn't work on Fujitsu T900, 1.2.2 does
and be done with it.  And having 1.9.1, I think this can be dropped,
unless either
(1) you think the invalid range messages are a concern, or
(2) you think a better title would be "misleading messages in xorg.log
    from synaptics driver".
[  1762.220] (--) SynPS/2 Synaptics TouchPad: no supported touchpad found
[  1762.220] (EE) SynPS/2 Synaptics TouchPad Unable to query/initialize Synaptics hardware.
[  1762.233] (EE) PreInit failed for input device "SynPS/2 Synaptics TouchPad"
[  1762.233] (II) UnloadModule: "synaptics"
The way I read those 4 lines, it looks like Something Bad happened.

Thanks for your help with this.

				Jim
Comment 10 Peter Hutterer 2010-11-02 20:51:20 UTC
_please_, don't just quote excerpts from log messages because you will almost certainly missing vital information. that log you just posted here could be either a real driver bug or a misconfiguration. unfortunately the bit telling us which one it is is in the part you snipped out.
Comment 11 jim.diamond 2010-11-03 05:38:45 UTC
(In reply to comment #10)
> _please_, don't just quote excerpts from log messages because you will almost
> certainly missing vital information. that log you just posted here could be
> either a real driver bug or a misconfiguration. unfortunately the bit telling
> us which one it is is in the part you snipped out.

Sorry, my point was that those messages seem to be spurious, and I thought that would stand on its own.  Here is the whole Xorg.0.log.  

[    32.490]
X.Org X Server 1.9.1
Release Date: 2010-10-22
[    32.490] X Protocol Version 11, Revision 0
[    32.490] Build Operating System: Slackware 13.1 Slackware Linux Project
[    32.490] Current Operating System: Linux jdiamond-nb2 2.6.36 #1 SMP PREEMPT Tue Oct 26 09:17:36 ADT 2010 x86_64
[    32.490] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.36 root=/dev/sda5 ro vt.default_utf8=0 vga = normal
[    32.490] Build Date: 23 October 2010  11:19:34PM
[    32.490]
[    32.490] Current version of pixman: 0.19.2
[    32.490]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[    32.490] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    32.490] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Nov  2 09:14:19 2010
[    32.585] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    32.585] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    32.636] (==) No Layout section.  Using the first Screen section.
[    32.636] (==) No screen section available. Using defaults.
[    32.636] (**) |-->Screen "Default Screen Section" (0)
[    32.636] (**) |   |-->Monitor "<default monitor>"
[    32.652] (==) No monitor specified for screen "Default Screen Section".
        Using a default monitor configuration.
[    32.652] (==) Automatically adding devices
[    32.652] (==) Automatically enabling devices
[    32.653] (WW) The directory "/usr/share/fonts/local" does not exist.
[    32.653]    Entry deleted from font path.
[    32.653] (WW) The directory "/usr/share/fonts/CID" does not exist.
[    32.653]    Entry deleted from font path.
[    32.670] (==) FontPath set to:
        /usr/share/fonts/TTF,
        /usr/share/fonts/OTF,
        /usr/share/fonts/Type1,
        /usr/share/fonts/misc,
        /usr/share/fonts/75dpi/:unscaled,
        /usr/share/fonts/100dpi/:unscaled,
        /usr/share/fonts/75dpi,
        /usr/share/fonts/100dpi,
        /usr/share/fonts/cyrillic
[    32.670] (==) ModulePath set to "/usr/lib64/xorg/modules"
[    32.670] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
[    32.671] (II) Loader magic: 0x7c8020
[    32.671] (II) Module ABI versions:
[    32.671]    X.Org ANSI C Emulation: 0.4
[    32.671]    X.Org Video Driver: 8.0
[    32.671]    X.Org XInput driver : 11.0
[    32.671]    X.Org Server Extension : 4.0
[    32.672] (--) PCI:*(0:0:2:0) 8086:0046:10cf:1508 rev 2, Mem @ 0xf2000000/4194304, 0xd0000000/268435456, I/O @ 0x00001800/8
[    32.672] (II) Open ACPI successful (/var/run/acpid.socket)
[    32.672] (II) LoadModule: "extmod"
[    32.778] (II) Loading /usr/lib64/xorg/modules/extensions/libextmod.so
[    32.788] (II) Module extmod: vendor="X.Org Foundation"
[    32.788]    compiled for 1.9.1, module version = 1.0.0
[    32.788]    Module class: X.Org Server Extension
[    32.788]    ABI class: X.Org Server Extension, version 4.0
[    32.788] (II) Loading extension MIT-SCREEN-SAVER
[    32.788] (II) Loading extension XFree86-VidModeExtension
[    32.788] (II) Loading extension XFree86-DGA
[    32.789] (II) Loading extension DPMS
[    32.789] (II) Loading extension XVideo
[    32.789] (II) Loading extension XVideo-MotionCompensation
[    32.789] (II) Loading extension X-Resource
[    32.789] (II) LoadModule: "dbe"
[    32.789] (II) Loading /usr/lib64/xorg/modules/extensions/libdbe.so
[    32.797] (II) Module dbe: vendor="X.Org Foundation"
[    32.797]    compiled for 1.9.1, module version = 1.0.0
[    32.797]    Module class: X.Org Server Extension
[    32.797]    ABI class: X.Org Server Extension, version 4.0
[    32.797] (II) Loading extension DOUBLE-BUFFER
[    32.797] (II) LoadModule: "glx"
[    32.797] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[    32.799] (II) Module glx: vendor="X.Org Foundation"
[    32.799]    compiled for 1.9.1, module version = 1.0.0
[    32.799]    ABI class: X.Org Server Extension, version 4.0
[    32.799] (==) AIGLX enabled
[    32.799] (II) Loading extension GLX
[    32.800] (II) LoadModule: "record"
[    32.800] (II) Loading /usr/lib64/xorg/modules/extensions/librecord.so
[    32.806] (II) Module record: vendor="X.Org Foundation"
[    32.806]    compiled for 1.9.1, module version = 1.13.0
[    32.806]    Module class: X.Org Server Extension
[    32.806]    ABI class: X.Org Server Extension, version 4.0
[    32.806] (II) Loading extension RECORD
[    32.806] (II) LoadModule: "dri"
[    32.806] (II) Loading /usr/lib64/xorg/modules/extensions/libdri.so
[    32.827] (II) Module dri: vendor="X.Org Foundation"
[    32.827]    compiled for 1.9.1, module version = 1.0.0
[    32.827]    ABI class: X.Org Server Extension, version 4.0
[    32.827] (II) Loading extension XFree86-DRI
[    32.827] (II) LoadModule: "dri2"
[    32.827] (II) Loading /usr/lib64/xorg/modules/extensions/libdri2.so
[    32.828] (II) Module dri2: vendor="X.Org Foundation"
[    32.828]    compiled for 1.9.1, module version = 1.2.0
[    32.828]    ABI class: X.Org Server Extension, version 4.0
[    32.828] (II) Loading extension DRI2
[    32.828] (==) Matched intel as autoconfigured driver 0
[    32.828] (==) Matched vesa as autoconfigured driver 1
[    32.828] (==) Matched fbdev as autoconfigured driver 2
[    32.828] (==) Assigned the driver to the xf86ConfigLayout
[    32.828] (II) LoadModule: "intel"
[    32.829] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
[    32.840] (II) Module intel: vendor="X.Org Foundation"
[    32.840]    compiled for 1.9.0, module version = 2.13.0
[    32.840]    Module class: X.Org Video Driver
[    32.840]    ABI class: X.Org Video Driver, version 8.0
[    32.840] (II) LoadModule: "vesa"
[    32.841] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
[    32.850] (II) Module vesa: vendor="X.Org Foundation"
[    32.850]    compiled for 1.9.0, module version = 2.3.0
[    32.850]    Module class: X.Org Video Driver
[    32.850]    ABI class: X.Org Video Driver, version 8.0
[    32.850] (II) LoadModule: "fbdev"
[    32.851] (WW) Warning, couldn't open module fbdev
[    32.851] (II) UnloadModule: "fbdev"
[    32.851] (EE) Failed to load module "fbdev" (module does not exist, 0)
[    32.851] (II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
        i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G, 915G,
        E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM, Pineview G,
        965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33, GM45,
        4 Series, G45/G43, Q45/Q43, G41, B43, B43, Clarkdale, Arrandale,
        Sandybridge, Sandybridge, Sandybridge, Sandybridge, Sandybridge,
        Sandybridge, Sandybridge
[    32.851] (II) VESA: driver for VESA chipsets: vesa
[    32.851] (++) using VT number 7

[    32.853] (WW) Falling back to old probe method for vesa
[    32.880] drmOpenDevice: node name is /dev/dri/card0
[    32.880] drmOpenDevice: open result is 9, (OK)
[    32.985] drmOpenByBusid: Searching for BusID pci:0000:00:02.0
[    32.985] drmOpenDevice: node name is /dev/dri/card0
[    32.985] drmOpenDevice: open result is 9, (OK)
[    32.985] drmOpenByBusid: drmOpenMinor returns 9
[    32.985] drmOpenByBusid: drmGetBusid reports pci:0000:00:02.0
[    32.985] (II) intel(0): Creating default Display subsection in Screen section
        "Default Screen Section" for depth/fbbpp 24/32
[    32.985] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[    32.985] (==) intel(0): RGB weight 888
[    32.985] (==) intel(0): Default visual is TrueColor
[    32.985] (II) intel(0): Integrated Graphics Chipset: Intel(R) Arrandale
[    32.985] (--) intel(0): Chipset: "Arrandale"
[    32.985] (**) intel(0): Tiling enabled
[    32.985] (**) intel(0): SwapBuffers wait enabled
[    32.985] (==) intel(0): video overlay key set to 0x101fe
[    33.103] (II) intel(0): Output LVDS1 has no monitor section
[    33.103] (II) intel(0): found backlight control interface /sys/class/backlight/acpi_video0
[    33.123] (II) intel(0): Output VGA1 has no monitor section
[    33.132] (II) intel(0): Output HDMI1 has no monitor section
[    33.133] (II) intel(0): Output DP1 has no monitor section
[    33.142] (II) intel(0): Output HDMI2 has no monitor section
[    33.143] (II) intel(0): Output DP2 has no monitor section
[    33.255] (II) intel(0): EDID for output LVDS1
[    33.255] (II) intel(0): Manufacturer: BOE  Model: a28  Serial#: 0
[    33.255] (II) intel(0): Year: 2007  Week: 0
[    33.255] (II) intel(0): EDID Version: 1.3
[    33.255] (II) intel(0): Digital Display Input
[    33.255] (II) intel(0): Max Image Size [cm]: horiz.: 29  vert.: 18
[    33.255] (II) intel(0): Gamma: 2.20
[    33.255] (II) intel(0): No DPMS capabilities specified
[    33.255] (II) intel(0): Supported color encodings: RGB 4:4:4 YCrCb 4:4:4
[    33.255] (II) intel(0): First detailed timing is preferred mode
[    33.255] (II) intel(0): redX: 0.563 redY: 0.354   greenX: 0.331 greenY: 0.542
[    33.255] (II) intel(0): blueX: 0.146 blueY: 0.117   whiteX: 0.300 whiteY: 0.320
[    33.255] (II) intel(0): Manufacturer's mask: 0
[    33.255] (II) intel(0): Supported detailed timing:
[    33.255] (II) intel(0): clock: 71.1 MHz   Image Size:  286 x 179 mm
[    33.255] (II) intel(0): h_active: 1280  h_sync: 1328  h_sync_end 1360 h_blank_end 1440 h_border: 0
[    33.255] (II) intel(0): v_active: 800  v_sync: 803  v_sync_end 809 v_blanking: 823 v_border: 0
[    33.255] (II) intel(0):
[    33.255] (II) intel(0):  BOE HYDIS
[    33.255] (II) intel(0):  HV133WX1
[    33.255] (II) intel(0): EDID (in hex):
[    33.255] (II) intel(0):     00ffffffffffff0009e5280a00000000
[    33.255] (II) intel(0):     00110103801d12780a6f8c905a548a25
[    33.255] (II) intel(0):     1e4c5200000001010101010101010101
[    33.256] (II) intel(0):     010101010101c71b00a0502017303020
[    33.256] (II) intel(0):     36001eb310000019000000fe000a2020
[    33.256] (II) intel(0):     20202020202020202020000000fe0042
[    33.256] (II) intel(0):     4f452048594449530a202020000000fe
[    33.256] (II) intel(0):     004856313333575831202020200a002f
[    33.256] (II) intel(0): EDID vendor "BOE", prod id 2600
[    33.256] (II) intel(0): Printing DDC gathered Modelines:
[    33.256] (II) intel(0): Modeline "1280x800"x0.0   71.11  1280 1328 1360 1440  800 803 809 823 -hsync -vsync (49.4 kHz)
[    33.256] (II) intel(0): Not using default mode "320x240" (doublescan mode not supported)
[    33.256] (II) intel(0): Not using default mode "400x300" (doublescan mode not supported)
[    33.256] (II) intel(0): Not using default mode "400x300" (doublescan mode not supported)
[    33.256] (II) intel(0): Not using default mode "512x384" (doublescan mode not supported)
[    33.256] (II) intel(0): Not using default mode "640x480" (doublescan mode not supported)
[    33.256] (II) intel(0): Not using default mode "640x512" (doublescan mode not supported)
[    33.256] (II) intel(0): Not using default mode "800x600" (doublescan mode not supported)
[    33.256] (II) intel(0): Not using default mode "896x672" (doublescan mode not supported)
[    33.256] (II) intel(0): Not using default mode "928x696" (doublescan mode not supported)
[    33.256] (II) intel(0): Not using default mode "960x720" (doublescan mode not supported)
[    33.256] (II) intel(0): Not using default mode "700x525" (doublescan mode not supported)
[    33.256] (II) intel(0): Not using default mode "1024x768" (doublescan mode not supported)
[    33.256] (II) intel(0): Printing probed modes for output LVDS1
[    33.256] (II) intel(0): Modeline "1280x800"x60.0   71.11  1280 1328 1360 1440  800 803 809 823 -hsync -vsync (49.4 kHz)
[    33.256] (II) intel(0): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz)
[    33.256] (II) intel(0): Modeline "800x600"x60.3   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz)
[    33.256] (II) intel(0): Modeline "800x600"x56.2   36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz)
[    33.256] (II) intel(0): Modeline "640x480"x59.9   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz)
[    33.276] (II) intel(0): EDID for output VGA1
[    33.285] (II) intel(0): EDID for output HDMI1
[    33.286] (II) intel(0): EDID for output DP1
[    33.295] (II) intel(0): EDID for output HDMI2
[    33.296] (II) intel(0): EDID for output DP2
[    33.296] (II) intel(0): Output LVDS1 connected
[    33.296] (II) intel(0): Output VGA1 disconnected
[    33.296] (II) intel(0): Output HDMI1 disconnected
[    33.296] (II) intel(0): Output DP1 disconnected
[    33.296] (II) intel(0): Output HDMI2 disconnected
[    33.296] (II) intel(0): Output DP2 disconnected
[    33.296] (II) intel(0): Using exact sizes for initial modes
[    33.296] (II) intel(0): Output LVDS1 using initial mode 1280x800
[    33.296] (II) intel(0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.
[    33.296] (II) intel(0): Kernel page flipping support detected, enabling
[    33.296] (**) intel(0): Display dimensions: (290, 180) mm
[    33.296] (**) intel(0): DPI set to (112, 112)
[    33.296] (II) Loading sub module "fb"
[    33.296] (II) LoadModule: "fb"
[    33.297] (II) Loading /usr/lib64/xorg/modules/libfb.so
[    33.302] (II) Module fb: vendor="X.Org Foundation"
[    33.302]    compiled for 1.9.1, module version = 1.0.0
[    33.302]    ABI class: X.Org ANSI C Emulation, version 0.4
[    33.302] (II) UnloadModule: "vesa"
[    33.302] (II) Unloading /usr/lib64/xorg/modules/drivers/vesa_drv.so
[    33.302] (==) Depth 24 pixmap format is 32 bpp
[    33.302] (==) intel(0): VideoRam: 262144 KB
[    33.302] (II) intel(0): [DRI2] Setup complete
[    33.302] (II) intel(0): [DRI2]   DRI driver: i965
[    33.302] (II) intel(0): Allocated new frame buffer 1280x800 stride 5120, tiled
[    33.309] (II) UXA(0): Driver registered support for the following operations:
[    33.309] (II)         solid
[    33.309] (II)         copy
[    33.309] (II)         composite (RENDER acceleration)
[    33.309] (II)         put_image
[    33.309] (II)         get_image
[    33.309] (==) intel(0): Backing store disabled
[    33.309] (==) intel(0): Silken mouse enabled
[    33.310] (II) intel(0): Initializing HW Cursor
[    33.373] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[    33.374] (==) intel(0): DPMS enabled
[    33.374] (==) intel(0): Intel XvMC decoder enabled
[    33.374] (II) intel(0): Set up textured video
[    33.374] (II) intel(0): [XvMC] xvmc_vld driver initialized.
[    33.374] (II) intel(0): direct rendering: DRI2 Enabled
[    33.374] (--) RandR disabled
[    33.374] (II) Initializing built-in extension Generic Event Extension
[    33.374] (II) Initializing built-in extension SHAPE
[    33.374] (II) Initializing built-in extension MIT-SHM
[    33.374] (II) Initializing built-in extension XInputExtension
[    33.374] (II) Initializing built-in extension XTEST
[    33.374] (II) Initializing built-in extension BIG-REQUESTS
[    33.374] (II) Initializing built-in extension SYNC
[    33.374] (II) Initializing built-in extension XKEYBOARD
[    33.374] (II) Initializing built-in extension XC-MISC
[    33.374] (II) Initializing built-in extension XINERAMA
[    33.374] (II) Initializing built-in extension XFIXES
[    33.374] (II) Initializing built-in extension RENDER
[    33.374] (II) Initializing built-in extension RANDR
[    33.374] (II) Initializing built-in extension COMPOSITE
[    33.374] (II) Initializing built-in extension DAMAGE
[    33.439] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[    33.439] (II) AIGLX: enabled GLX_INTEL_swap_event
[    33.439] (II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
[    33.439] (II) AIGLX: enabled GLX_SGI_make_current_read
[    33.439] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
[    33.439] (II) AIGLX: Loaded and initialized /usr/lib64/xorg/modules/dri/i965_dri.so
[    33.439] (II) GLX: Initialized DRI2 GL provider for screen 0
[    33.439] (II) intel(0): Setting screen physical size to 338 x 211
[    33.693] (II) config/udev: Adding input device Power Button (/dev/input/event3)
[    33.693] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    33.693] (**) Power Button: Applying InputClass "keyboard-all"
[    33.693] (II) LoadModule: "evdev"
[    33.694] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[    33.702] (II) Module evdev: vendor="X.Org Foundation"
[    33.702]    compiled for 1.9.0, module version = 2.5.0
[    33.702]    Module class: X.Org XInput Driver
[    33.702]    ABI class: X.Org XInput driver, version 11.0
[    33.703] (**) Power Button: always reports core events
[    33.703] (**) Power Button: Device: "/dev/input/event3"
[    33.710] (--) Power Button: Found keys
[    33.710] (II) Power Button: Configuring as keyboard
[    33.710] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
[    33.710] (**) Option "xkb_rules" "evdev"
[    33.710] (**) Option "xkb_model" "evdev"
[    33.710] (**) Option "xkb_layout" "us"
[    33.710] (WW) Option "xkb_variant" requires an string value
[    33.710] (WW) Option "XkbVariant" requires an string value
[    33.710] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[    33.734] (II) config/udev: Adding input device Fujitsu FUJ02E3 (/dev/input/event5)
[    33.734] (**) Fujitsu FUJ02E3: Applying InputClass "evdev keyboard catchall"
[    33.734] (**) Fujitsu FUJ02E3: Applying InputClass "keyboard-all"
[    33.735] (**) Fujitsu FUJ02E3: always reports core events
[    33.735] (**) Fujitsu FUJ02E3: Device: "/dev/input/event5"
[    33.743] (--) Fujitsu FUJ02E3: Found keys
[    33.743] (II) Fujitsu FUJ02E3: Configuring as keyboard
[    33.743] (II) XINPUT: Adding extended input device "Fujitsu FUJ02E3" (type: KEYBOARD)
[    33.743] (**) Option "xkb_rules" "evdev"
[    33.743] (**) Option "xkb_model" "evdev"
[    33.743] (**) Option "xkb_layout" "us"
[    33.743] (WW) Option "xkb_variant" requires an string value
[    33.743] (WW) Option "XkbVariant" requires an string value
[    33.743] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[    33.743] (II) config/udev: Adding input device Video Bus (/dev/input/event11)
[    33.743] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[    33.743] (**) Video Bus: Applying InputClass "keyboard-all"
[    33.743] (**) Video Bus: always reports core events
[    33.743] (**) Video Bus: Device: "/dev/input/event11"
[    33.752] (--) Video Bus: Found keys
[    33.752] (II) Video Bus: Configuring as keyboard
[    33.752] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD)
[    33.752] (**) Option "xkb_rules" "evdev"
[    33.752] (**) Option "xkb_model" "evdev"
[    33.752] (**) Option "xkb_layout" "us"
[    33.752] (WW) Option "xkb_variant" requires an string value
[    33.752] (WW) Option "XkbVariant" requires an string value
[    33.752] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[    33.752] (II) config/udev: Adding input device Fujitsu FUJ02B1 (/dev/input/event4)
[    33.753] (**) Fujitsu FUJ02B1: Applying InputClass "evdev keyboard catchall"
[    33.753] (**) Fujitsu FUJ02B1: Applying InputClass "keyboard-all"
[    33.753] (**) Fujitsu FUJ02B1: always reports core events
[    33.753] (**) Fujitsu FUJ02B1: Device: "/dev/input/event4"
[    33.759] (--) Fujitsu FUJ02B1: Found keys
[    33.759] (II) Fujitsu FUJ02B1: Configuring as keyboard
[    33.759] (II) XINPUT: Adding extended input device "Fujitsu FUJ02B1" (type: KEYBOARD)
[    33.759] (**) Option "xkb_rules" "evdev"
[    33.759] (**) Option "xkb_model" "evdev"
[    33.759] (**) Option "xkb_layout" "us"
[    33.759] (WW) Option "xkb_variant" requires an string value
[    33.759] (WW) Option "XkbVariant" requires an string value
[    33.759] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[    33.763] (II) config/udev: Adding input device Power Button (/dev/input/event2)
[    33.763] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    33.763] (**) Power Button: Applying InputClass "keyboard-all"
[    33.763] (**) Power Button: always reports core events
[    33.763] (**) Power Button: Device: "/dev/input/event2"
[    33.771] (--) Power Button: Found keys
[    33.771] (II) Power Button: Configuring as keyboard
[    33.771] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
[    33.771] (**) Option "xkb_rules" "evdev"
[    33.771] (**) Option "xkb_model" "evdev"
[    33.771] (**) Option "xkb_layout" "us"
[    33.771] (WW) Option "xkb_variant" requires an string value
[    33.771] (WW) Option "XkbVariant" requires an string value
[    33.771] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[    33.771] (II) config/udev: Adding input device Lid Switch (/dev/input/event1)
[    33.771] (II) No input driver/identifier specified (ignoring)
[    33.776] (II) config/udev: Adding input device CNF8248 (/dev/input/event8)
[    33.776] (**) CNF8248: Applying InputClass "evdev keyboard catchall"
[    33.776] (**) CNF8248: Applying InputClass "keyboard-all"
[    33.776] (**) CNF8248: always reports core events
[    33.776] (**) CNF8248: Device: "/dev/input/event8"
[    33.783] (--) CNF8248: Found keys
[    33.783] (II) CNF8248: Configuring as keyboard
[    33.783] (II) XINPUT: Adding extended input device "CNF8248" (type: KEYBOARD)
[    33.783] (**) Option "xkb_rules" "evdev"
[    33.783] (**) Option "xkb_model" "evdev"
[    33.783] (**) Option "xkb_layout" "us"
[    33.783] (WW) Option "xkb_variant" requires an string value
[    33.783] (WW) Option "XkbVariant" requires an string value
[    33.783] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[    33.789] (II) config/udev: Adding input device fsc tablet buttons (/dev/input/event6)
[    33.789] (**) fsc tablet buttons: Applying InputClass "evdev keyboard catchall"
[    33.789] (**) fsc tablet buttons: Applying InputClass "keyboard-all"
[    33.789] (**) fsc tablet buttons: always reports core events
[    33.789] (**) fsc tablet buttons: Device: "/dev/input/event6"
[    33.796] (--) fsc tablet buttons: Found keys
[    33.796] (II) fsc tablet buttons: Configuring as keyboard
[    33.796] (II) XINPUT: Adding extended input device "fsc tablet buttons" (type: KEYBOARD)
[    33.796] (**) Option "xkb_rules" "evdev"
[    33.796] (**) Option "xkb_model" "evdev"
[    33.796] (**) Option "xkb_layout" "us"
[    33.796] (WW) Option "xkb_variant" requires an string value
[    33.796] (WW) Option "XkbVariant" requires an string value
[    33.796] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[    33.796] (II) config/udev: Adding input device fsc tablet switch (/dev/input/event7)
[    33.796] (II) No input driver/identifier specified (ignoring)
[    33.797] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event0)
[    33.797] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[    33.797] (**) AT Translated Set 2 keyboard: Applying InputClass "keyboard-all"
[    33.797] (**) AT Translated Set 2 keyboard: always reports core events
[    33.797] (**) AT Translated Set 2 keyboard: Device: "/dev/input/event0"
[    33.807] (--) AT Translated Set 2 keyboard: Found keys
[    33.807] (II) AT Translated Set 2 keyboard: Configuring as keyboard
[    33.807] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
[    33.807] (**) Option "xkb_rules" "evdev"
[    33.807] (**) Option "xkb_model" "evdev"
[    33.807] (**) Option "xkb_layout" "us"
[    33.807] (WW) Option "xkb_variant" requires an string value
[    33.807] (WW) Option "XkbVariant" requires an string value
[    33.807] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[    33.807] (II) config/udev: Adding input device PS/2 Generic Mouse (/dev/input/event9)
[    33.807] (**) PS/2 Generic Mouse: Applying InputClass "evdev pointer catchall"
[    33.807] (**) PS/2 Generic Mouse: always reports core events
[    33.807] (**) PS/2 Generic Mouse: Device: "/dev/input/event9"
[    33.815] (--) PS/2 Generic Mouse: Found 3 mouse buttons
[    33.815] (--) PS/2 Generic Mouse: Found relative axes
[    33.815] (--) PS/2 Generic Mouse: Found x and y relative axes
[    33.815] (II) PS/2 Generic Mouse: Configuring as mouse
[    33.815] (**) PS/2 Generic Mouse: YAxisMapping: buttons 4 and 5
[    33.815] (**) PS/2 Generic Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[    33.815] (II) XINPUT: Adding extended input device "PS/2 Generic Mouse" (type: MOUSE)
[    33.815] (**) PS/2 Generic Mouse: (accel) keeping acceleration scheme 1
[    33.815] (**) PS/2 Generic Mouse: (accel) acceleration profile 0
[    33.815] (**) PS/2 Generic Mouse: (accel) acceleration factor: 2.000
[    33.815] (**) PS/2 Generic Mouse: (accel) acceleration threshold: 4
[    33.815] (II) PS/2 Generic Mouse: initialized for relative axes.
[    33.815] (II) config/udev: Adding input device PS/2 Generic Mouse (/dev/input/mouse0)
[    33.815] (II) No input driver/identifier specified (ignoring)
[    33.816] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event10)
[    33.816] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
[    33.816] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad"
[    33.816] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
[    33.816] (II) LoadModule: "synaptics"
[    33.816] (II) Loading /usr/lib64/xorg/modules/input/synaptics_drv.so
[    33.821] (II) Module synaptics: vendor="X.Org Foundation"
[    33.821]    compiled for 1.9.0, module version = 1.3.0
[    33.821]    Module class: X.Org XInput Driver
[    33.821]    ABI class: X.Org XInput driver, version 11.0
[    33.821] (II) Synaptics touchpad driver version 1.3.0
[    33.821] (**) Option "Device" "/dev/input/event10"
[    33.859] (--) SynPS/2 Synaptics TouchPad: x-axis range 1472 - 5378
[    33.859] (--) SynPS/2 Synaptics TouchPad: y-axis range 1408 - 4546
[    33.859] (--) SynPS/2 Synaptics TouchPad: pressure range 0 - 255
[    33.859] (--) SynPS/2 Synaptics TouchPad: finger width range 0 - 15
[    33.859] (--) SynPS/2 Synaptics TouchPad: buttons: left right scroll-buttons
[    33.859] (**) Option "SHMConfig" "on"
[    33.859] (**) Option "TapButton1" "0"
[    33.859] (**) Option "TapButton2" "0"
[    33.859] (**) Option "TapButton3" "0"
[    33.859] (**) Option "CircularScrolling" "1"
[    33.859] (**) Option "CircScrollTrigger" "7"
[    33.891] (--) SynPS/2 Synaptics TouchPad: touchpad found
[    33.891] (**) SynPS/2 Synaptics TouchPad: always reports core events
[    33.907] (II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD)
[    33.907] (**) SynPS/2 Synaptics TouchPad: (accel) MinSpeed is now constant deceleration 2.5
[    33.907] (**) SynPS/2 Synaptics TouchPad: MaxSpeed is now 1.75
[    33.907] (**) SynPS/2 Synaptics TouchPad: AccelFactor is now 0.040
[    33.907] (**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
[    33.907] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration profile 1
[    33.907] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration factor: 2.000
[    33.907] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration threshold: 4
[    33.931] (--) SynPS/2 Synaptics TouchPad: touchpad found
[    33.931] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse1)
[    33.931] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad"
[    33.931] (II) Synaptics touchpad driver version 1.3.0
[    34.475] (EE) SynPS/2 Synaptics TouchPad no synaptics event device found
[    34.475] (**) Option "Device" "/dev/input/mouse1"
[    34.483] (--) SynPS/2 Synaptics TouchPad: invalid x-axis range.  defaulting to 1615 - 5685
[    34.483] (--) SynPS/2 Synaptics TouchPad: invalid y-axis range.  defaulting to 1729 - 4171
[    34.483] (--) SynPS/2 Synaptics TouchPad: invalid pressure range.  defaulting to 0 - 256
[    34.483] (--) SynPS/2 Synaptics TouchPad: invalid finger width range.  defaulting to 0 - 16
[    34.483] (**) Option "TapButton1" "1"
[    34.483] (**) Option "TapButton2" "2"
[    34.483] (**) Option "TapButton3" "3"
[    34.503] (EE) Query no Synaptics: 6003C8
[    34.503] (--) SynPS/2 Synaptics TouchPad: no supported touchpad found
[    34.503] (EE) SynPS/2 Synaptics TouchPad Unable to query/initialize Synaptics hardware.
[    34.517] (EE) PreInit failed for input device "SynPS/2 Synaptics TouchPad"
[    34.517] (II) UnloadModule: "synaptics"
[    48.152] (II) intel(0): EDID vendor "BOE", prod id 2600
[    48.152] (II) intel(0): Printing DDC gathered Modelines:
[    48.152] (II) intel(0): Modeline "1280x800"x0.0   71.11  1280 1328 1360 1440  800 803 809 823 -hsync -vsync (49.4 kHz)
[    48.304] (II) intel(0): EDID vendor "BOE", prod id 2600
[    48.304] (II) intel(0): Printing DDC gathered Modelines:
[    48.304] (II) intel(0): Modeline "1280x800"x0.0   71.11  1280 1328 1360 1440  800 803 809 823 -hsync -vsync (49.4 kHz)
[ 50064.084] (II) PM Event received: Capability Changed
[ 50064.084] I830PMEvent: Capability change
[ 50064.335] (II) AIGLX: Suspending AIGLX clients for VT switch
[ 50069.750] (II) Open ACPI successful (/var/run/acpid.socket)
[ 50069.750] (II) AIGLX: Resuming AIGLX clients after VT switch
[ 50069.916] (II) intel(0): EDID vendor "BOE", prod id 2600
[ 50069.916] (II) intel(0): Printing DDC gathered Modelines:
[ 50069.916] (II) intel(0): Modeline "1280x800"x0.0   71.11  1280 1328 1360 1440  800 803 809 823 -hsync -vsync (49.4 kHz)
[ 50070.064] (--) SynPS/2 Synaptics TouchPad: touchpad found
[ 50095.531] (II) AIGLX: Suspending AIGLX clients for VT switch
[ 50133.447] (II) UnloadModule: "synaptics"
[ 50133.447] (II) PS/2 Generic Mouse: Close
[ 50133.447] (II) UnloadModule: "evdev"
[ 50133.447] (II) AT Translated Set 2 keyboard: Close
[ 50133.447] (II) UnloadModule: "evdev"
[ 50133.447] (II) fsc tablet buttons: Close
[ 50133.447] (II) UnloadModule: "evdev"
[ 50133.447] (II) CNF8248: Close
[ 50133.447] (II) UnloadModule: "evdev"
[ 50133.447] (II) Power Button: Close
[ 50133.447] (II) UnloadModule: "evdev"
[ 50133.447] (II) Fujitsu FUJ02B1: Close
[ 50133.447] (II) UnloadModule: "evdev"
[ 50133.447] (II) Video Bus: Close
[ 50133.447] (II) UnloadModule: "evdev"
[ 50133.447] (II) Fujitsu FUJ02E3: Close
[ 50133.447] (II) UnloadModule: "evdev"
[ 50133.447] (II) Power Button: Close
[ 50133.447] (II) UnloadModule: "evdev"


I have put the following in /etc/X11/xorg.conf.d/50-synaptics.conf:

Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        # Stop this thing from generating spurious clicks!
        # These lines were 1, 2 and 3, respectively
        Option "TapButton1" "0"
        Option "TapButton2" "0"
        Option "TapButton3" "0"
        Option "SHMConfig" "on"
        # added the rest from an old xorg.conf file
        Option      "CircScrollTrigger"     "7"
        Option      "CircularScrolling"     "1"
EndSection
Comment 12 Peter Hutterer 2010-11-03 17:24:53 UTC
you seem to have two InputClasses, one named "touchpad" which is likely a system-provided one and the "touchpad catchall". the errors you see is because the MatchDevicePath line is missing from the "touchpad" class, so the server tries to add it as /dev/input/mouse1, failing because it's the wrong device. doesn't matter though, the device is added as /dev/input/event10 and succeeds.


other than that, I've lost track of what the actual bug is here.
Comment 13 jim.diamond 2010-11-04 09:52:03 UTC
(In reply to comment #12)
> you seem to have two InputClasses, one named "touchpad" which is likely a
> system-provided one and the "touchpad catchall". the errors you see is because
> the MatchDevicePath line is missing from the "touchpad" class, so the server
> tries to add it as /dev/input/mouse1, failing because it's the wrong device.
> doesn't matter though, the device is added as /dev/input/event10 and succeeds.
> 
> 
> other than that, I've lost track of what the actual bug is here.

The original bug was that my touchpad wasn't working with 1.9.0.  It works with 1.9.1, so I think this should be marked as "resolved".  Any disagreement?

Thanks for the explanation of the error message.  You are right, the /usr/share/X11/xorg.conf.d/50-synaptics.conf file does not have a MatchDevicePath line.
(Robbie, you still reading this?)
Comment 14 Robby Workman 2010-11-04 10:46:26 UTC
I am.  You should check for updates; aside from a newer xf86-input-synaptics build, there are also newer versions of some other stuff (including pixman, which your log indicates is out of date) :)
Comment 15 Peter Hutterer 2012-04-29 23:17:40 UTC
Closing as fixed per comment #13