Bug 31232 - Wine games crash with r300 gallium (r300_get_swizzle_combined+0x21)
Summary: Wine games crash with r300 gallium (r300_get_swizzle_combined+0x21)
Status: RESOLVED WORKSFORME
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r300 (show other bugs)
Version: git
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-30 04:18 UTC by demon
Modified: 2011-02-11 09:31 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Log (16.26 KB, text/plain)
2010-10-30 04:18 UTC, demon
Details
Log 2 (15.33 KB, text/plain)
2010-10-30 04:30 UTC, demon
Details
Backtrace of a crash - mesa compiled with debugging (16.04 KB, application/octet-stream)
2010-10-30 17:15 UTC, demon
Details
Another backtrace (3.74 KB, application/octet-stream)
2010-10-30 17:19 UTC, demon
Details
Zuma backtrace (1.75 KB, text/plain)
2010-10-31 07:26 UTC, demon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description demon 2010-10-30 04:18:13 UTC
Created attachment 39900 [details]
Log

...and it works just fine with classic driver, so I woukd say it's a bug in gallium driver, not in game itself or in wine.
Comment 1 demon 2010-10-30 04:30:22 UTC
Zuma DeLuxe (besides Star Trek Armada 2) also crashes.
Comment 2 demon 2010-10-30 04:30:54 UTC
Created attachment 39901 [details]
Log 2
Comment 3 Marek Olšák 2010-10-30 14:55:30 UTC
I've been playing Zuma Deluxe over here and I don't get any crashes.
Comment 4 demon 2010-10-30 15:02:29 UTC
Well, my wine crash, obviously. If I use classic driver, they work just fine.
Is there any way I can make more useful data?
Comment 5 Marek Olšák 2010-10-30 15:13:15 UTC
Please compile Mesa from git with --enable-debug and post the backtrace you will get. It should contain more information than is in your logs.
Comment 6 demon 2010-10-30 17:15:44 UTC
Created attachment 39915 [details]
Backtrace of a crash - mesa compiled with debugging
Comment 7 demon 2010-10-30 17:19:28 UTC
Created attachment 39916 [details]
Another backtrace

I don't know if this can, it's a backtrace from another game. It isn't the same as with other games...
Comment 8 demon 2010-10-31 05:23:17 UTC
These are the compilation flags:


  ./autogen.sh --prefix=/usr \
    --with-dri-driverdir=/usr/lib/xorg/modules/dri \
    --with-dri-drivers=swrast,radeon,r200,r300,r600 \
    --with-state-trackers=dri,egl,glx \
    --with-egl-platforms=x11,drm \
    --enable-glx-tls \
    --with-driver=dri \
    --enable-gles1 \
    --enable-gles2 \
    --enable-gles-overlay \
    --enable-xcb \
    --enable-glx-tls \
    --disable-glut \
    --enable-gallium-llvm \
    --enable-gallium-swrast \
    --enable-gallium-radeon \
    --enable-gallium-r600 \
    --enable-debug || return 1
Comment 9 Marek Olšák 2010-10-31 06:47:51 UTC
The logs are not backtraces. A backtrace is actually a call stack. r300_get_swizzle_combined+0x21 is the first line of it.

Could you possibly use this HOWTO to get the whole backtrace?
http://wiki.winehq.org/Backtraces
Comment 10 demon 2010-10-31 07:26:04 UTC
Created attachment 39924 [details]
Zuma backtrace

I'm sorry, this is everything I could get. I know it's not the thing you need. But I tried following that HOWTO without success.
Comment 11 Marek Olšák 2011-02-10 18:00:04 UTC
Is this issue still present with the current Mesa master branch?
Comment 12 demon 2011-02-11 09:08:08 UTC
Hi Marek.
I've switched to r600 card in the meantime, so I can not give any further details. Sorry.
Comment 13 Marek Olšák 2011-02-11 09:31:24 UTC
Because nobody else can reproduce this bug, I am closing it. Feel free to reopen it if you test r300g again and the issue is still present.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.