Bug 31255 - Unigine Sanctuary v2.2: some surfaces have wrong colours
Summary: Unigine Sanctuary v2.2: some surfaces have wrong colours
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r300 (show other bugs)
Version: git
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-31 04:48 UTC by Pavel Ondračka
Modified: 2010-11-21 22:50 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
screenshot (924.09 KB, image/png)
2010-10-31 04:48 UTC, Pavel Ondračka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Ondračka 2010-10-31 04:48:41 UTC
Created attachment 39922 [details]
screenshot

In Unigine Sanctuary v2.2 with shaders quality set to high (low and medium works fine) some surfaces have wrong colours, they are over bright, it looks like they are reflecting too much light from nearby torches. 
I've tried some older mesa versions and I've found out this is a regression from glsl2 merge.
This is with r300g driver, RV530, mesa a15cf3cd0b21d593033a3abd2b1788de292001bd, 2.6.36 kernel. I'm setting component to mesa core for now but it may as well be some r300g problem only exposed by glsl2 merge. Any logs needed?
Comment 1 Pavel Ondračka 2010-11-16 03:04:33 UTC
This works fine with Tom Stellards sched-perf-rebase branch, so it seems like r300g bug after all.
Comment 2 Tom Stellard 2010-11-21 21:55:48 UTC
Can you try this again with the latest git master?
Comment 3 Pavel Ondračka 2010-11-21 22:50:42 UTC
Fixed with latest git.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.