Bug 31407 - Bind Channel.Messages.MessageTypes property, check message header and deprecated methods for changes
Summary: Bind Channel.Messages.MessageTypes property, check message header and depreca...
Status: RESOLVED DUPLICATE of bug 41356
Alias: None
Product: Telepathy
Classification: Unclassified
Component: tp-qt (show other bugs)
Version: git master
Hardware: All All
: medium enhancement
Assignee: Telepathy bugs list
QA Contact: Telepathy bugs list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 33115
  Show dependency treegraph
 
Reported: 2010-11-05 01:39 UTC by Olli Salli
Modified: 2011-10-07 07:03 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Olli Salli 2010-11-05 01:39:51 UTC
The spec says

sender-nickname (s)
The nickname chosen by the sender of the message, which can be different for each message in a conversation.
Comment 1 Andre Moreira Magalhaes 2011-01-14 08:43:55 UTC
Besides sender-nickname, check other changes in the header for removals/additions (protocol-token/message-token/...) and also bind MessageTypes, falling back to GetMessageTypes if the property does not exist.
Comment 2 Olli Salli 2011-05-15 05:31:50 UTC
http://telepathy.freedesktop.org/spec/Channel_Interface_Messages.html#Simple-Type:Delivery_Report_Header_Key

These keys added in spec 0.19.8 are quite important, yet we haven't added friendly accessors for any of them.
Comment 3 Olli Salli 2011-10-07 07:03:04 UTC
Actually we've had this since 0.7.0, except for MessageTypes which now has a separate bug 41356.

*** This bug has been marked as a duplicate of bug 41356 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.