Bug 31427 - refresh-cache time exceeded but not refreshing cache.
Summary: refresh-cache time exceeded but not refreshing cache.
Status: RESOLVED INVALID
Alias: None
Product: PackageKit
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-06 04:32 UTC by Jordi Chulia
Modified: 2012-01-05 11:08 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
related gconf and packagekitd outputs (6.27 KB, text/plain)
2010-11-06 04:32 UTC, Jordi Chulia
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jordi Chulia 2010-11-06 04:32:19 UTC
Created attachment 40082 [details]
related gconf and packagekitd outputs

Hi everyone:

I'm giving a try to packagekit on my systems, but in one of them I have a problem: 

$ pkcon get-time refresh-cache outputs more than 144000 seconds and augmenting,  while from gconf  I see that the frequency for refreshing cache is 86400 seconds as default and I've not changed it.

something that might be a key: in other system with exactly the same configuration, the refresh was performed as expected as soon as the counter reached the 86400 seconds, but in the "anomalous" system, the counter was exceeded because the computer was not running, and when was started, the timer was already higher than the limit for a cache refresh.

The expected behaviour shouldn't be that as soon as packagekit notices that he exceeded the time for a cache refresh, perform a new one refresh?

What is he waiting for?


also, Packagekit has performend some get-updates, but, logically, since the cache hasn't been refreshed, nothing happens (I know I have updates to install xD)
(Also, if I force a refresh-cache manually, everything goes as expected)

as an attachments:

the output for $gconftool-2 -R /apps/gnome-packagekit and the output of packagekitd started in verbose mode

other info:

Archlinux i686
gnome 2.32
packagekit 0.6.10
backend in use alpm
connecting to router via wifi
kernel 2.6.35
networkmanager 0.8.1


As a side point: I've seen in another bug report that there's a discussion about the convenience of refreshing cache each time a get-updates is performed... well, I think that this would be the expected behaviour ;)

Thank you for your work.
Comment 1 Jordi Chulia 2010-11-06 07:36:51 UTC
Correction, I suffer the same problem on all my machines, and reaching the refresh cache time while the computer is running does not make any difference, the refresh cache time is ignored , and continues growing indefinitely.
Comment 2 Richard Hughes 2010-11-15 08:17:50 UTC
Is gpk-update-icon running in the session of the computer that doesn't refresh?
Comment 3 Jean-François Fortin Tam 2012-01-05 11:08:11 UTC
Hi there,
This particular bug needs additional information to fix the bug. Please test the latest version of PackageKit and see if it fixes your problem. If it does not, please provide additional information to help the developers.


bug/show.html.tmpl processed on Mar 25, 2017 at 23:29:38.
(provided by the Example extension).