Bug 31482 - When trying to put the fullscreen window, data show and LCD laptop screen, the screen windwos screw up
Summary: When trying to put the fullscreen window, data show and LCD laptop screen, th...
Status: RESOLVED NOTOURBUG
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: XOrg git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-08 17:58 UTC by Maximiliano Castañón
Modified: 2010-11-18 14:06 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
/var/log/messages (88.92 KB, application/x-bzip2)
2010-11-11 17:43 UTC, Maximiliano Castañón
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Maximiliano Castañón 2010-11-08 17:58:31 UTC
When trying to put the fullscreen window, using hardware button, i can change between various modes, but when it's the turn of fullscreen of OpenOffice/LibreOffice, in both screen, LCD and VGA output, the image screw up.
The screw up only happen when i change between modes with the hardware button, because if i use the F5 button (OpenOffice/LibreOffice fullscreen) that doesn't happen, probably a xrandr problem?
Comment 1 Alex Deucher 2010-11-08 22:00:23 UTC
Does the "hardware button" generate an acpi event or do something else (like banging the hw directly behind the driver's back)?  What system is this?  Please attach your xorg log and dmesg output.
Comment 2 Maximiliano Castañón 2010-11-11 17:38:00 UTC
Seems to be managed by a kernel driver... don't know which

Nov 11 22:30:15 localhost kernel: [74389.406194] atkbd serio0: Unknown key pressed (translated set 2, code 0xf8 on isa0060/serio0).
Nov 11 22:30:15 localhost kernel: [74389.406205] atkbd serio0: Use 'setkeycodes e078 <keycode>' to make it known.
Nov 11 22:30:15 localhost kernel: [74389.413290] atkbd serio0: Unknown key released (translated set 2, code 0xf8 on isa0060/serio0).
Nov 11 22:30:15 localhost kernel: [74389.413298] atkbd serio0: Use 'setkeycodes e078 <keycode>' to make it known.
Nov 11 22:30:17 localhost kernel: [74392.162654] atkbd serio0: Unknown key pressed (translated set 2, code 0xf8 on isa0060/serio0).
Nov 11 22:30:17 localhost kernel: [74392.162660] atkbd serio0: Use 'setkeycodes e078 <keycode>' to make it known.
Nov 11 22:30:17 localhost kernel: [74392.169601] atkbd serio0: Unknown key released (translated set 2, code 0xf8 on isa0060/serio0).
Nov 11 22:30:17 localhost kernel: [74392.169607] atkbd serio0: Use 'setkeycodes e078 <keycode>' to make it known.

i'm on Fedora 14, xrandr 1.3.3 

Linux localhost.localdomain 2.6.35.6-48.fc14.x86_64 #1 SMP Fri Oct 22 15:36:08 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux


Name        : xorg-x11-drv-ati
Arch        : x86_64
Version     : 6.13.1
Comment 3 Maximiliano Castañón 2010-11-11 17:43:40 UTC
Created attachment 40220 [details]
/var/log/messages 

the file is compressed because it's 1200 KB size
Comment 4 Maximiliano Castañón 2010-11-11 18:50:55 UTC
http://img143.imageshack.us/img143/829/libreofficefail.png this is an example... 

this is how it look after a screen change, i mean the press of hardware button changin between modes, dual screen, single screen, etc...
Comment 5 Alex Deucher 2010-11-11 21:15:22 UTC
I think the app does not update it's itself properly after the screen geometry changes.
Comment 6 Maximiliano Castañón 2010-11-12 08:05:23 UTC
I guess i found the problem, GLX it´s a module loaded by the Xorg, i disable it with 

 Section "Module"
        Disable "glx"
    EndSection


And now it seems to work normally, i can move the slides of Impress, i will check with Dual Screen...and that options...
Comment 7 Maximiliano Castañón 2010-11-12 08:11:41 UTC
Ok, the X server are running much better, but still existing the problem of Fullscreen with Openoffice, what can i provide to get that working?

Thanks guys
Comment 8 Maximiliano Castañón 2010-11-12 08:26:55 UTC
[13:15] <agd5f> yeah, webchat is blocked due to spammers
[13:15] <Guest80184> agd5f i disabled the GLX module
[13:16] <agd5f> you also have to be logged in to send to the channel
[13:17] <Guest80184> now the X are running swiftly
[13:17] <Guest80184> oh holy shit, I´m registered, but the nick doesn´t change
[13:18] <Guest80184> look, -NickServ- You are already logged in as maximi89.
[13:21] <agd5f> I think the issue is with openoffice
[13:22] <Guest80184> i believe the same
[13:22] <agd5f> it needs to re-org itself when the screen geomtry changes
[13:22] <Guest80184> what about the problem of GLX?
[13:22] <Guest80184> it´s another history
[13:23] <agd5f> is that a different bug?
[13:23] <Guest80184> if i contact the developers of Libreoffice, you
could provide to them information?
[13:23] <Guest80184> yeah, GLX it´s another bug, when i move the
slides in Impress, that uses entire CPU...
[13:23] <agd5f> "/msg nickserv GHOST nickname your-password" to log
out your other session
[13:24] <Guest80184> and changing between screens modes, it take minus time
[13:24] <Guest80184> [13:24] *nickserv* GHOST maximi89
[13:24] <Guest80184> -NickServ- maximi89 is not online.
[13:25] <Guest80184>  == maximi89 #radeon Cannot change nickname while
banned on channel
[13:25] <agd5f> webchat is still blocked
[13:25] <Guest80184> anyway, i be back to my house in a while
[13:26] <Guest80184> but, now you know what it´s the bug origin :D
[13:26] <agd5f> file a different bug fo the glx thing.
[13:26] <Guest80184> thanks men!
[13:26] <Guest80184> i will
[13:26] <agd5f> np

2010/11/12, bugzilla-daemon@freedesktop.org <bugzilla-daemon@freedesktop.org>:
> https://bugs.freedesktop.org/show_bug.cgi?id=31482
>
> --- Comment #5 from Alex Deucher <agd5f@yahoo.com> 2010-11-11 21:15:22 PST
> ---
> I think the app does not update it's itself properly after the screen
> geometry
> changes.
>
> --
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
>
Comment 9 Maximiliano Castañón 2010-11-12 09:14:31 UTC
Ok, I have created a bug against OpenOffice, LibreOffice and GLX

GLX https://bugs.freedesktop.org/show_bug.cgi?id=31586

OpenOffice and GLX http://www.openoffice.org/issues/show_bug.cgi?id=108700

LibreOffice about FullScreen https://bugs.freedesktop.org/show_bug.cgi?id=31475
Comment 11 Maximiliano Castañón 2010-11-14 15:23:12 UTC
Please refer to https://bugs.freedesktop.org/show_bug.cgi?id=31475

I believe it's another project related to that problem, probably xrandr with the resize screen...
Comment 12 Maximiliano Castañón 2010-11-18 14:06:47 UTC
well, it seems to be a bug related with how LO interacts with something who interacts with Xorg server, so closing this one as invalid :D

Thanks guys!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.