Bug 31500 - RFE: Spice server on 32bit
RFE: Spice server on 32bit
Status: RESOLVED FIXED
Product: Spice
Classification: Unclassified
Component: server
unspecified
Other All
: medium normal
Assigned To: Spice Bug List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-09 06:03 UTC by Michael Niehren
Modified: 2015-06-17 13:17 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Niehren 2010-11-09 06:03:52 UTC
Hi,

i read in the FAQ, that spice server currently need's 64 Bit OS Support.
As i have running much KVM's on 32 Bit Linux Systems and want to
use spice there too, i want to ask whether it will be possible in the future
to have a 32 Bit spice-server version ?

best regards and keep on your good work
  Michael
Comment 1 aix 2011-04-14 01:50:53 UTC
(In reply to comment #0)
> Hi,
> 
> i read in the FAQ, that spice server currently need's 64 Bit OS Support.
> As i have running much KVM's on 32 Bit Linux Systems and want to
> use spice there too, i want to ask whether it will be possible in the future
> to have a 32 Bit spice-server version ?
> 
> best regards and keep on your good work
>   Michael

Hi,
It may be possible but It's not currently priority on the roadmap. However I believe, any contributions are welcome.
Comment 2 Christophe Fergeau 2015-06-17 13:17:17 UTC
This hasn't been heavily tested, but nowadays SPICE can be built on x86, closing this bug, if you run SPICE on 32 bit and are having issues, please open more specific bugs explaining the issue you hit.